my system automatically going to suspend or hibernate ?

Asked by ankapanaidu on 2011-11-02

i am using ubuntu 11.. my hard disk 250gb ram 2gb.
i am installed linux 1 week ago on my pc . but there is a problem with linux.my system suddenly going to hibernate or suspend . it happening 3 times frequently (after hibernate i will turn on pc again it hibernates, gain like this it happening 3 times). after 3 times running normally. after some time it's happening again 3 times. what is the cause of it. please i want solution.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-power-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Warren Hill
Solved:
2011-11-04
Last query:
2011-11-04
Last reply:
2011-11-03
Warren Hill (warren-hill) said : #1

This is a feature.

It's called power management and is set to turn off if your PC is left idle for some time.

It can be turned off however.

Reboot your PC and select Ubuntu classic mode. I'm sure you can do what you want in Unity or KDE as well but I'm not as familiar with that interface.

From the Top menu bar select System >Preferences>Power Management

from here you can set "Put computer to sleep.." to Never

Click "Make Default" and enter your password.

Job Done.

You can now reboot normally and use whatever front end you prefer.

ankapanaidu (damanani) said : #2

how can i enter in ubuntu classic mode.
I am new to linux. please specifiy some more briefly ).

Lalatendu Mohanty (then4way) said : #3

ankapanaidu (damanani) : the above does give you the exact steps for classic mode. Do you want the exact steps for Unity?

Best Warren Hill (warren-hill) said : #4

When you turn your computer on there is a log on screen where it asks you for user name and password. You may have it set to log you on automatically after a few seconds delay.

On the bottom of the screen there is a drop down list which tells you which tells you the graphical front end you are using. On your system this probably says Unity. Click on this and change it to classic. You can then follow all the steps in my original post.

Don't worry about the fact that this desktop looks different because next time you start you machine it will go back to whatever you normally use.

The only reason I am using Classic Mode is that I prefer it, it is a personal choice. You may decide you agree with me in which case you can make it the default. You may decide you prefer Unity the default desktop in which case having turned off Power management you never have to use Classic Mode again.

If you want the exact steps for Unity just ask here again. I won't be able to help but there are plenty of people here who can

ankapanaidu (damanani) said : #5

Thanks Warren Hill, that solved my question.