ubuntu 11.04 goes to sleep after ten minutes

Asked by john hitchcock on 2011-05-19

I cant change the sleep time even when i choose never go to sleep...any ideas on a postcard please!!!!!!!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-power-manager Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2011-05-23
Last query:
2011-05-23
Last reply:
2011-05-21
wojox (wojox) said : #1

Power Management > Actions > Never
Power Management > Display > Never
Make Default
Reboot

john hitchcock (jd-badcocks) said : #2

No that didn't work for me laptop still goes to sleep after ten minutes.........have to enter pass word..........????

How to disable Hibernated and suspend

I know A and B and C and D methods

========================================================
The "A" and "D" method will disable the system wide Suspend Hibernate for all the users

A) - Open a terminal from Applications → Accessories → Terminal and type:

sudo gedit /etc/default/acpi-support

give your user password when requested, you don't see nothing when you type it, then press enter.

Look for and change the rows as below:
Alternatively, they could be simply commented out with a pound sign (#)

ACPI_SLEEP=false

ACPI_HIBERNATE=false

Reboot, these should completely disable hibernation and suspend.

========================================================
The "B" and "C" method will disable Suspend Hibernate only for current logged user

B) - Open the System → Preferences → Power management and play with settings (but sometimes don't works)

C) To disable Suspend and Hibernate for a user account, not system wide.

Open a terminal from Applications → Accessories → Terminal and type:

gconf-editor

Navigate to: apps → gnome power manager → general and remove the ticks at: can_hibernate and can_suspend

Note: this is a user preference: repeat this in each user account.

Hope this helps

D ) Changing the /etc/gdm file

gdm.conf (this is system default and should not be edited - but some values can be copied and altered)
gdm.conf-custom (this is where I made the changes - it will not be overwritten by the system)

sudo cp /etc/gdm/gdm.conf /etc/gdm/gdm.conf-custom

On the

[daemon] section added/modified
SystemCommandsInMenu=HALT;REBOOT;CUSTOM_CMD
(copied this from the gdm.conf but removed HIBERNATE and SUSPEND

This would prevent accidentally hibernating the system

john hitchcock (jd-badcocks) said : #4

many thanks.....

john hitchcock (jd-badcocks) said : #5

Thanks marcobra (Marco Braida), that solved my question.