top panel disappeared

Asked by fferreira

Binary package hint: gnome-panel

I have a hp2585ep, with a Nvidia 8400, and using Hardy Heron with compiz. I also Avant Window Navigator on my desktop so I deleted the down panel.

Recently my top panel disappeared. Since I don't have the down panel I cannot add a new one. I tryed to uninstall compiz-gnome and install it again but it did not work.

What can I do next ?


Question information

English Edit question
Ubuntu gnome-panel Edit question
No assignee Edit question
Solved by:
Harvey Muller
Last query:
Last reply:

This question was originally filed as bug #249257.

Revision history for this message
Nick Ellery (nick.ellery) said :

Thank you for your report. This doesn't look like a bug, and is more of a support issue. For this reason, I am converting this report into a question. Please don't hesitate to report bugs in the future. Thanks again!

Revision history for this message
Robert Di Gioia (digioiar) said :


Running these two commands in a terminal should get it back for you. To get a terminal open without your panels, press ALT+F2 and type gnome-terminal in the box, then click run.

gconftool-2 --recursive-unset /apps/panel
killall gnome-panel

Good luck

Revision history for this message
fferreira (fabiojoel) said :

I have already tried that because I saw that in another forum but unfortunately that didn't work.

What can I do next ?

Revision history for this message
Best Harvey Muller (hlmuller) said :


That looked like an interesting problem to solve, so I deleted my top panel.

Reinstalling gnome-panel did not help.

Deleting ~/.gconf/apps/panel and rebooting did. Just logging out and logging back in afterwards should work too.

Here's what I did in a terminal:

    $ rm -rf ~/.gconf/apps/panel

To get a terminal without the Applications menu because you don't have a panel, hit Alt-F2 key combination and type in gnome-terminal.

Then I rebooted.

The default gnome panel will be restored, and you will lose any customizations to your panel.

Please return to Launchpad and mark this question Solved, if this resolves your issue.



Revision history for this message
fferreira (fabiojoel) said :

I got the solution, but your proposal not only is interesting but also was near to the problem.

The problem was very simple indeed. I don't know why, the gnome-panel has uninstalled all by it self.... I didn't have it installed.

after installing it everything was fine.

Despite this is a dumb problem with a very simple solution, its origin might be a bug that should be investigated.

thanks for the support.

Revision history for this message
Gastón (givanse) said :

I found out that removing evolution-data-server-common also removes gnome-panel. You can see that when you install gnome-panel, that package is automatically installed.

But reinstalling gnome-panel is not enough, because now I can't add the trash and volume control applets. They show this errors:

The panel encountered a problem while loading "OAFIID:GNOME_Panel_TrashApplet".

The panel encountered a problem while loading "OAFIID:GNOME_MixerApplet".

So then I installed gnome-applets.

Revision history for this message
marcobra (Marco Braida) (marcobra) said :

@ gaston

Please don't append a new question on a already answered or marked as solved question.
Please make new question from here:
you will get better chance to get right answer on a fresh tagged "open" question.
Solved or answered question are usually not read from answering people.

Thank you

Revision history for this message
JonNicholson (nicholso) said :

Robert di Gioia -- Your solution worked for me. Worked like a charm!