can't remove gnome panel

Asked by VincentvanG on 2008-03-10

Binary package hint: gnome-panel

when i click on my gnome panel to change or remove it i can only choose between panel info and help.

ProblemType: Bug
Architecture: i386
Date: Mon Mar 10 16:27:56 2008
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/gnome-panel
NonfreeKernelModules: nvidia
Package: gnome-panel 1:2.20.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: gnome-panel --sm-client-id default1
ProcCwd: /home/vincent
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-panel
Uname: Linux VINCENT 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-panel Edit question
Assignee:
No assignee Edit question
Solved by:
VincentvanG
Solved:
2008-03-11
Last query:
2008-03-11
Last reply:
2008-03-10

This question was originally filed as bug #200611.

VincentvanG (vsg-music) said : #1
Pedro Villavicencio (pedro) said : #2

Thank you for your comments. This does not appear to be a bug report and we are closing it. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. https://answers.launchpad.net/ubuntu

Grazieno Pellegrino (grazieno) said : #3

Hi VincentvanG,

When you right-clicking in gnome-panel, what the options that are show?

Grazieno

If you trying to remove both panels the only way to be able to do that would be to remove gnome-panel package but doing this will also remove other packages so do this at your own risk.

VincentvanG (vsg-music) said : #5

I removed the whole panel, and now i have avn dock, much better:D
thanks for reactions!

drink (martin-espinoza) said : #6

On Hardy you could disable the gnome-panel via the sessions control panel. This panel has had the most important tab removed - the one that allows you to edit the whole session. The relevant item (gnome-panel) doesn't seem to be in my ~/.gnome2/session file... I do not want to REMOVE gnome-panel, which is necessary for the failsafe GNOME desktop. I can't delete the last panel. Functionality has been removed from GNOME. Why?

Bernhard (b.a.koenig) said : #7

Yes, I'm also encountering the same problem atm. Why is it so difficult to remove the gnome-panel? It comes back up if I kill it and I cannot click it away in the "Sessions" either. Nowadays, with docks and everything, you might want to completely remove gnome-panel (without deinstalling it).

Bernhard (b.a.koenig) said : #8

I guess you could make the panel completely empty, and then hide it or make it transparent. But that's not really a clean solution, I just want to end the process "gnome-panel" permanently.

drink (martin-espinoza) said : #9

There is a way to use gconf-editor to fix this problem. The problem is
that in the latest release gnome-panel is set as a required gnome
component. I tried to find the link I found this information on but
don't seem to have it saved and on dialup, finding it again is going
to be an exercise in pain. I no longer have an intrepid machine (Gave
up on it on my nw9440, Ubuntu's been getting less stable and supports
less of my hardware steadily since gutsy.) But once you tunnel through
gconf and find the list of required applications for the gnome
desktop, you can delete gnome-panel from the list, and this will
enable you to remove it from your startup.

On 1/11/09, Bernhard <email address hidden> wrote:
> Question #26740 on gnome-panel in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-panel/+question/26740
>
> Bernhard posted a new comment:
> I guess you could make the panel completely empty, and then hide it or
> make it transparent. But that's not really a clean solution, I just want
> to end the process "gnome-panel" permanently.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

zyodei (buddhaflow) said : #10

My solution to this:

1) Launch gconf-editor
2) Navigate to desktop-gnome-session-required_components
3) Change the "panel" value to "gnome-panel.null" (to make it easy to undo later)
4) Quit and restart.

However, I am a bit of a noob, and i'm not sure if this is a good idea. It seems to work, and allows AWN to take the notification area.

I noticed that doing so seemed to disable the alt-f2 run dialog. I got around this by making an alt-f2 keyboard shortcut to gnome-do in compiz. I don't know if it disables anything else...

Is this a good way to disable it?