Missing network panel icon

Asked by ealthuis on 2015-01-23

On my laptop, using Unity desktop, the network applet is missing, when using the Gnome desktopit is present.

I have tried all remedies I found in other questions, but no luck.

Linux vostro 3.13.0-44-generic #73-Ubuntu SMP Tue Dec 16 00:22:43 UTC 2014 x86_64 x86_64 x86_64 GNU/Linu

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-panel Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2015-01-23
Last query:
2015-01-23
Last reply:
2015-01-23

Unless you are connecting to a new network the icon isn't needed. It's just a GUI for network-manager. If you have already configured your network connectivity then it's not needed. The lack of icon doesn't stop the connection.

If you press ALT + F2 and run :

nm-applet

You should see the icon.

ealthuis (ealthuis) said : #2

ALT+F2 does nothing, using terminal it did not show either:

ea@vostro:~$ sudo nm-applet
sudo: unable to resolve host vostro
[sudo] password for ea:
nm-applet-Message: using fallback from indicator to GtkStatusIcon

ealthuis (ealthuis) said : #3

I also lost Bluetooth while trying to get the network GUI

I need it so I can connect to other wifi locations (the network GUI I mean)

The application doesn't need sudo access. If it did I would have added 'gksudo' to the command. ....

ealthuis (ealthuis) said : #5

ea@vostro:~$ nm-applet
nm-applet-Message: using fallback from indicator to GtkStatusIcon

(nm-applet:4812): nm-applet-WARNING **: Could not find ShellVersion property on org.gnome.Shell after 5 tries

As I said before, ALT+F2 did not work.
I used Terminal, and the above are the result.

This problem is NOT resolved, I still need an answer....

ealthuis (ealthuis) said : #7

Thanks actionparsnip, that solved my question.

ealthuis (ealthuis) said : #8

The install reinstall libappindicator part solved the problem

ealthuis (ealthuis) said : #9

I don't know if ayone looks at this post, but just in case, I also lost Wi-Fi and bluetoothwhile trying to resolve the problem.
No idea why, so when trying to get it started I did one thing I had done a number of times to resolve the original problem, which is pressing ALT+F2...
and lo and behold Wi-Fi and bluetooth were back and working.

A word to the wise