Ubuntu 12.04 Gome Fallback - Buttons keep dissaperaing

Asked by Nolan on 2013-03-14

Ubuntu 12.04 have installed Gnome fallback.

Each time I log back in I have to keep running Metacity --replace.
Because the buttons keep dissapearing and the applications keep opening in the upper
left hand corner with no way to close or move them.

What is the permanent fix?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-panel Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2013-03-14
Last query:
2013-03-14
Last reply:
2013-03-14
Nolan (nolanzoe) said : #1

When I adjust Gnome Tweak Tool:

(gnome-tweak-tool:3926): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3926): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3926): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3926): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3926): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3926): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

(gnome-tweak-tool:3926): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 25

N1ck 7h0m4d4k15 (nicktux) said : #2

Hi Nolan,
Stop the X server and try to re-install some packages (not remove , just re-install) and see if situation gets better.

Hit CTRL+ALT+F1 and login from this "big" terminal and the apply the following commands one by one

     sudo service lightdm stop
     sudo apt-get install --reinstall gsettings-desktop-schemas
     sudo apt-get install --reinstall gnome-panel
     sudo service lightdm start

Regards
 NikTh

Nolan (nolanzoe) said : #3

Still no buttons visible. Went into "Advanced Settings" Buttons are set
to "ALL" but none are visible.

On 03/14/2013 06:51 AM, NikTh wrote:
> Your question #224266 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/224266
>
> Status: Open => Answered
>
> NikTh proposed the following answer:
> Hi Nolan,
> Stop the X server and try to re-install some packages (not remove , just re-install) and see if situation gets better.
>
> Hit CTRL+ALT+F1 and login from this "big" terminal and the apply the
> following commands one by one
>
> sudo service lightdm stop
> sudo apt-get install --reinstall gsettings-desktop-schemas
> sudo apt-get install --reinstall gnome-panel
> sudo service lightdm start
>
> Regards
> NikTh
>

--

Nolan (nolanzoe) said : #4

Another problem I notice. Thunderbird opens in the top left corner and
cannot be moved by the mouse.

I cannot send via the mouse. I have to use the keyboard.

Please advise.

On 03/14/2013 08:01 AM, Nolan wrote:
> Your question #224266 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/224266
>
> Status: Answered => Open
>
> You are still having a problem:
> Still no buttons visible. Went into "Advanced Settings" Buttons are set
> to "ALL" but none are visible.
>
>
> On 03/14/2013 06:51 AM, NikTh wrote:
>> Your question #224266 on Ubuntu changed:
>> https://answers.launchpad.net/ubuntu/+question/224266
>>
>> Status: Open => Answered
>>
>> NikTh proposed the following answer:
>> Hi Nolan,
>> Stop the X server and try to re-install some packages (not remove , just re-install) and see if situation gets better.
>>
>> Hit CTRL+ALT+F1 and login from this "big" terminal and the apply the
>> following commands one by one
>>
>> sudo service lightdm stop
>> sudo apt-get install --reinstall gsettings-desktop-schemas
>> sudo apt-get install --reinstall gnome-panel
>> sudo service lightdm start
>>
>> Regards
>> NikTh
>>
>
> --
>

--

N1ck 7h0m4d4k15 (nicktux) said : #5

Hi ,
I can give you some commands that will reset EVERYTHING to default settings. It is easier than searching what setting is wrong. Probably some thing with Compiz or/and metacity.. but who knows what ?

BE AWARE that everything will reset to default settings. Backup your bookmarks (if you have) , even the wallpaper will reset to default. You will not lose any personal files ... etc. Just the settings of the entire environment and programs.

Execute the following commands , one by one

     gconftool --shutdown
     sudo killall -r -I gconf
     sudo killall -r -I dconf
     rm -rf .compiz* .gconf* .config/dconf/ .config/compiz*

PLEASE copy-paste from here for more accuracy. No mistakes allowed.

Then reboot your PC.

Regards
 NikTh

Add a startup item to run the command. In future I suggest you install Xubuntu and it will give a familiar desktop session. It is GTK based so your usual Gnome applications will run without issue and with fewer packages as dependencies

Nolan (nolanzoe) said : #7

Which command do I program to run at startup??

When I log in I have several options. Gnome Classic runs ok. For now
I'll stick with that until I can install Kubuntu

On 03/14/2013 09:26 AM, actionparsnip wrote:
> Your question #224266 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/224266
>
> actionparsnip proposed the following answer:
> Add a startup item to run the command. In future I suggest you install
> Xubuntu and it will give a familiar desktop session. It is GTK based so
> your usual Gnome applications will run without issue and with fewer
> packages as dependencies
>

--

Add the command:

metacity --replace

I thought that was a little obvious.....

Nolan (nolanzoe) said : #9

Case closed