I cant make my wifi button switch on in ubuntu 12.10

Asked by hardik juneja on 2013-01-12

hi
wifi on my hp-dv6 has suddenly stop working. it didn't get connected and when i checked my network setting i found that when i try to make the wireless button on it remain off. and nothing happens

please help em solve this problem

Output from: sudo lspci --
...
0a:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
...

Output from: sudo lshw -class network --

*-network DISABLED
       description: Wireless interface
       product: Centrino Wireless-N 2230
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0a:00.0
       logical name: wlan0
       version: c4
       serial: 68:5d:43:c1:6f:dd
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.5.0-21-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:46 memory:d4500000-d4501fff

Output from: sudo rfkill list all --

0: hp-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: yes
1: hp-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: yes
2: hp-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: yes
3: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
4: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no

i also tried sudo rfkill unblock all
it dont work

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-panel Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2013-01-13
Last query:
2013-01-13
Last reply:
2013-01-12

Do you have a switch to enable/disable WiFi?
Do you dual boot the system?

my switch is enabled
and yes it is a dual boot

In Windows device manager, disable the ability of the device to wake up the system as well as disable power management.

can to tell me how to do that

Right click My Computer -> Manage
Device Manager, expand network devices, right click WiFi adapter -> properties

You'll find one of the tabs has the 2 options

Thanks actionparsnip, that solved my question.