11.04 Natty Narwhal - minimized windows disappear, app still running

Asked by RocketScientist77 on 2012-07-24

I'm thinking this is due to some file corruption on disk. Basically, my 11.04 installation has worked great until recently.
Now, when I minimize a window, it simply disappears, even though System Monitor shows it still running (sleeping).

Before this problem occurred a minimized window could be restored or maximized from its respective workspace, just as you might expect it to do.

I have the workspace switcher, so my work around has been to open each window in a separate workspace. But it's annoying and
sometimes I forget and open a new app in the same workspace and BAM the previous application window disappears as described above.

What's to be done? Is there some part of 11.04 I could re-install? A window manager or something? I know just enough about linux to be dangerous, so if you have a solution PLEASE DESCRIBE IT IN EXCRUCIATING DETAIL

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-panel Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-07-25
Last query:
2012-07-25
Last reply:
2012-07-24

Do you use Unity or fallback?

I suggest you upgrade to a newer release soon, Natty is EOL in October.

Fallback....Ubuntu Classic

I wasn't happy to see the direction Natty was going...I'm sure the next versions will be just as fiddly to "fallback" as this one was..
not terribly interested in inheriting a bunch of new problems.

Natty works fine...no need to take "two steps forward and one step back" if I can just get it working like it used to work

If you open a terminal and run:

gconftool --recursive-unset /apps/panel && killall gnome-panel

It will reset the panels to defaults.

Thanks actionparsnip, that solved my question.