Unity on Ubuntu 11.10 new install, i have no desktop icons

Asked by Richard Harrington

Brand new to Ubuntu, very limited computing experience, please address responses accordingly.

Installed Ubuntu (11.10) for the first time this evening and can login but am presented with an almost entirely white desktop. I have a blank 2cm grey strip down the left-hand side of the screen (no icons or wording) and a narrow grey strip at the top with a menu in the top-right. I can access drop-down menus from here.

In the drop-down menus the only thing that has any effect is to click on Startup Applications... which reproduces those words at the top-left of the screen. When I move the cursor over the grey strip on the left after this I get wording (Dash home, Home Folder, Firefox Web Browser, etc), but still no icons. I can right-click on these to get a further menu but selecting anything from here also has no effect.

Install appeared to go fine as far as I could tell. Any help or suggestions would be appreciated.

Question information

English Edit question
Ubuntu gnome-panel Edit question
No assignee Edit question
Solved by:
Richard Harrington
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Are you connected to the web. A wired connection will pick up DHCP automagically in most cases

Revision history for this message
Richard Harrington (richbharrington) said :

I didn't set up my wireless network during installation, was going to do it later.

Had another crack at installation, this time intending to set up wireless, but although my network is listed and I can enter my password, clicking on the 'Connect' button has no effect. The only way to progress past this screen is to indicate 'I don't wish to connect to a wi-fi network right now'. The rest of the installation follows as previously, with the same result.

BTW, 'automagically' is definitely my new favoutite word.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Log in to Unity2D session and you will be ok. Your OS may simply need updates. If you use nvidia or amd video hardware, you can install the proprietary driver there

Revision history for this message
Richard Harrington (richbharrington) said :

Help much appreciated. 2D'll have to do on this old machine until my extra RAM arrives.