Minimise actually closes windows.

Asked by John Everingham on 2011-09-12

I have just installed Maverick.

I am having trouble with personalising the windows with gconf-editor. The changes don't seem to be applied.

A more serious problem is that windows that I minimise disappear... they are actually closed.

I am suspicious of the hardware in my box as my attempted update from Lucid to Maverick failed and I made a new installation for a CD. I still get a computation error message from BOINC , malariacontrol.net. This is what prompted my system reconfigure.

Any comments would be very gratefully received... I've spent a lot of time on these issues.

Thanks John

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-panel Edit question
Assignee:
No assignee Edit question
Solved by:
John Everingham
Solved:
2011-09-12
Last query:
2011-09-12
Last reply:
2011-09-12

For correct the button, do this:
Press Alt+F2,and type gconf-editor in pop-up “Run Application” window,and then “Configuration Editor” opened up.Navigate to apps –> metacity –> general, double-click the Value of “button_layout” in right box and change into minimize,maximize,close:

this will restore your button to right of the window. If you want the button at the left, change the Value of “button_layout” into :minimize,maximize,close

Than close.

John Everingham (g4trn) said : #2

Thank you Enrico

I've done it. (many times!)

 It doesn't work on the box in question. I am living with the buttons where my choice theme puts them. Its what I get and I can't change it. I mentioned it because it might help in the diagnosis.

The serious issue is the closing of windows that I minimise. Its not a workspace thing and I have tried replacing the 'show desktop' applet. That did not do the trick.

I am deeply suspicious of my hardware. The memory tests ok. I am hoping that someone with more experience may be able to tell me if I'm 'flogging a dead horse'.

John

Try this, from terminal, to reset yuor gnome panels to the default:

gconftool --recursive-unset /apps/panel && killall gnome-panel

it may help

John Everingham (g4trn) said : #4

Thank you marcobra.

I've tried it. i'm not sure what has changed, its not obvious. the problem remains.

John

Please create a new user and try with it... if it works is something wrong in your old user settings

John Everingham (g4trn) said : #6

Thank you for your thoughts on this.

I think you have got a grip on the issue.

I tried creating a new just before I got your last suggestion.

The new user desktop works ok.

I don't know my way around very well and I'm now trying to find and delete the .gnome configuration file for the user that has the problems, as suggeted in 'Ubuntu Kung Fu'.

John Everingham (g4trn) said : #7

Bingo!!!

The problem is solved.

I found the .gconf folder in the home folder after hitting Ctl H and moved it to the rubbish bin.

Now that I have rebooted I have a fully working desktop, but without my personal settings. No problem. I can easily put them back.

Thank you for your time in guiding me to the solution of my problem.

John