Gnome panel shortcuts don't have permission to run

Asked by Paul Kelly on 2011-08-31

I'm running Ubuntu 11.04 and I'm logging into the workstation using XRDP from my Windows 7 desktop.

When I try to run non default installed applications from the top left Gnome Panel (such as GADMIN-SQUID) I get the error messages:

Failed to run /usr/sbin/gadmin-squid as user root.

Unable to copy the user's Xauthorization file.

This isn't a problem for shortcuts that came installed with the system by default, they run just fine. If I run the utility from the Gnome terminal then the utility starts up just fine.

I suspect that my permissions are wrong slightly because I'm logging in through an XRDP session.

I have completely rebuilt my Gnome Panels using http://www.watchingthenet.com/restore-panels-in-ubuntu-back-to-their-default-settings.html

Any assistance would be greatly appreciated. I am a bit of a linux nub by the way.

Regards,
Paul

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-panel Edit question
Assignee:
No assignee Edit question
Solved by:
Paul Kelly
Solved:
2011-08-31
Last query:
2011-08-31
Last reply:
2011-08-31

What command does the shortcut run?

Paul Kelly (logiboy123) said : #2

The shortcut runs that command:

su-to-root -X -c /usr/sbin/gadmin-dhcpd

Paul Kelly (logiboy123) said : #3

If I run "/usr/sbin/gadmin-dhcpd" then I get a popup saying:

You must be root to run: gadmin-dhcpd
This window will close in 10 seconds

ok try:

gksdo /usr/sbin/gadmin-dhcpd

Should be ok

Paul Kelly (logiboy123) said : #5

I tried:

gksudo /usr/sbin/gadmin-dhcpd

which gives me the error message:

Error copying '/home/paul/.Xauthority' to '/tmp/libgksu-KK1Y42': No such file or directory

ok and the output of:

file /home/paul/.Xauthority

Thanks

Paul Kelly (logiboy123) said : #7

I'm slightly embarrassed to admit that I've given up trying to get this working.

I'm going to try to get Zentyal up and running instead, this was purpose built for what I'm trying to achieve anyway so hopefully I can get it working.

But thank you very much for putting in the effort to try and help me.

Regards,
Paul