System admin windows and panel menus close randomly

Asked by pererik87 on 2010-09-12

System admin windows and panel menus close randomly.

How do you monitor keys pressed or even better is it possible to disable the esc key?

Before i posted this as a bug i want to do some resarch. I can make all the windows that close randomly can be closed by using the esc key and im on a old computer. I think maybe somehow the keyboard might be spamming the esc key. Don't want to waste programmers and triagers time if this is a hardware issue.

Thank you
Eric

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-panel Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2010-09-12
Last query:
2010-09-12
Last reply:
2010-09-12
pererik87 (pererik87) said : #1

I found the answer how to monitor myself the xev command and the keyboard is indeed spamming x. i was using the wrong search words in google.

I found this:
<quote>
 Re: disable key on keyboard
This works for symbols. Since it is merely sending a signal, I would expect it to work for this situation as well.

Run the following command to find the keycode value of the desired key:
Code:

xev

With the small box in foreground, press the sleep key and note the keycode value.
Then run this:
Code:

 xmodmap -e 'keycode number = NoSymbol'

That should disable the key. To make it permanent, put this command in the System, Preferences, Sessions, Startup Programs folder, Add.

Edit: Typo corrected. Thanks Sepero.
Last edited by drs305; June 16th, 2010 at 08:55 PM..
</quote>

xmodmap -e 'keycode (keysym 0xff1b, Escape) = NoSymbol'
esc key still woks :(

pererik87 (pererik87) said : #2

the code: (xmodmap -e 'keycode 0xff1b = NoSymbol') *emoved the w*ong key. *eboting.

pererik87 (pererik87) said : #3

maybe its not the esc key after all. i dont understand anything of this. running lucid lynx. I cant get the windows to stop closing. i cant type my password, because the dialogue closes.

Launch the app from terminal. When it closes you should see clues in the terminal

pererik87 (pererik87) said : #5

Dosn't output anything. Not its not the spplications that are closing its the administrative windows. The password type in, the keyring type in. The application menu. If i click add server in Mumble, that window also dissapear. Not the main window only the add server window

pererik87 (pererik87) said : #6

can it be some kind of virus or worm??

Highly unlikely. Most are in labs and made by devs to test stuff. The others are not wild at all so you have very little to worry about.

Could try a different keyboard

pererik87 (pererik87) said : #8

It's a laptop :( and i dont have a spare external keyboard. If i could disable it i could test with another laptop in the remote desktop client.

You can connect USB keyboards to laptops so the fact it's a laptop is moot. I suggest borrowing / stealing a keyboard to test. You should also check the language you set the keyboard to in preferences. You could also try logging on as a new user to see if its profile related (make a new user if you don't have more than one (saves the usual "I am the only user" nonesense))

pererik87 (pererik87) said : #10

But if it is the keyboard, it will still happen if i plug in a usb keyboard. Don't i need to disable the one i think is the problem somehow. I cant just unplug it because then i have to disassemble the entire laptop.

Trying the user thing at least.

pererik87 (pererik87) said : #11

It's not the user account :/

pererik87 (pererik87) said : #12

Trying a run from the a live usb with maveric meercat beta. Checking if this entirely can be software related. If it ends up negative, meaning the problem also exist on the live sesion. I will just post a solution that this is most likely a keyboard error. If it is not existing in the live session i will get back yo you.

pererik87 (pererik87) said : #13

The problem is Hardware related.
The same thing happens in Bios.

It most definitely is the esc key or any other similar key stroke. It would be nice to be able to disable the key while waiting for a new keyboard, thou.

Thanks to actionparsnip for all the help

pererik87 (pererik87) said : #14

Thanks actionparsnip, that solved my question.