menubar missing on desktop, can't launch programs

Asked by LizaSisson on 2010-05-25

Running Ubuntu 8.4
there is no menu bar on the desktop. I can't launch programs from the desktop. My desktop only shows my desktop folders and my wallpaper.
Whenever I open any window, the min/max/close buttons are missing also.
When I open the web browser, it shows me as being offline, and I can't locate the wireless program to learn anything else about the connectivity problem.
Trying to solve the problem myself, I restarted the system and got an error message that said something like Nautilus failed to open because it couldn't locate the factory. The message never came up again, but the problem persists.

I am on a dell mini 10, which does not have an optical drive. I am on the road with a touring group now, so I also can't order a disk. I'm looking for a fix with what I already have.

I am really new to Linux, so please be patient and very specific.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-panel Edit question
Assignee:
No assignee Edit question
Last query:
2010-05-25
Last reply:
2010-05-25
Jens Maucher (jensmaucher) said : #1

Hmmm... what happens when you add a new user via terminal and login with the new one?
The problem still exists?

Switch to terminal with Strg+Alt+F1 and type:
sudo adduser NewUser

Jens Maucher (jensmaucher) said : #2

What i forgot to say, can you open a terminal with pressing Alt+F2, starting gnome-terminal type gnome-panel.

Any error messages?

In addition to the terminal + gnome-panel Jens mentioned, open another terminal and type in »metacity --replace«. Please report if everything works then.

To make sure that both the panel and the window manager (metacity) are required by the system, open yet another terminal and copy-paste both commands, running them by pressing enter after each one:
gconftool-2 --set /desktop/gnome/session/required_components/panel --type string "gnome-panel"
gconftool-2 --set /desktop/gnome/session/required_components/windowmanager --type string "metacity"

As a workaround (if all else fails), to make sure both panel and window manager start on startup, go to System → Preferences → Startup Applications and add the two:
Panel command: gnome-panel
Window manager command: metacity

(Name can be anything, comment is optional)

LizaSisson (liza-sisson) said : #4

Thank you for your speedy responses!

I added a new user per your instructions and signed on under the new account. The environments looks way different from my personal account (the new user's account has the interactive 1" tall bar across the top with the oversized icons). However, the menubar doesn't show in the new user's account either.

I tried launching the terminal with alt + f2, but nothing happens. I can, however, access the terminal with ctrl + alt + f1. But sometimes, I can't return to the desktop with that method, and when I press ctrl + alt + f7 I only get a blank screen with a blinking cursor.

I typed the "metacity --replace" into the terminal but got the error "window manager error: unable to open X display"

Also, since I don't have the menubar, I am having trouble finding my system preferences. All I can do is try to navigate through the file system at this point. Is there an easy way to access the system preferences this way?

Since when does the error occur?

I may have found a solution (resets your panel): http://www.backports.ubuntuforums.org/showpost.php?p=9225731&postcount=3

LizaSisson (liza-sisson) said : #6

The menu bar disappeared last night. I went to click on the power icon to power down the computer, and the menu bar literally disappeared the second I clicked on it. At first, I thought the system was just shutting down bit by bit, but when I realized that nothing else was happening, I knew something was wrong.

I read a few other threads of people with similar problems, and some of them suggested that I reset all of my settings to the default, so I think that solves my connectivity problem. But right now, it's honestly the last thing on my mind. I think that if I get the panel working again, I should be good to go in figuring out the rest.

LizaSisson (liza-sisson) said : #7

when I say it "solves" my connectivity problem, I mean that I think that explains it. I had to fidget a lot with the settings to get it to connect to my university's connection, so I feel pretty sure that the default settings aren't cutting it.

thank you for that link to the ubuntuforums. i tried their fix, but when I type the first line, i get a line saying:
     rm: cannot remove '/home/liza/.gconf/apps/panel': no such file or directory

when i enter the line to kill the gnome-panel, nothing happens, so I don't know if anything was fixed. I power cycled, and the problem persists.

The directory might not be there because you are using Ubuntu 8.04. I don’t know where exactly that version stores the panel configuration but it has to be in the home folder.

My best advice now is for you to use Ctrl+h to display hidden files and folders and search for something like panel or gnome-panel, then delete it (better make a backup copy of it first).

Can you help with this problem?

Provide an answer of your own, or ask LizaSisson for more information if necessary.

To post a message you must log in.