Broadcom BCM4306 [14e4:4320] (rev 03) problem

Asked by Eric on 2010-01-24

My wife recently purchased a Compaq Armada 110 from an auction at a local school. I have a Linksys WPC54G wireless card that I am trying to use. I downloaded the b43-fwcutter, along with wl_apsta.o and wl_apsta_mimo.o and extracted the firmware to /lib/firmware. I now have both the b43 and b43 legacy firmwares installed on the system, and the wireless is still not working. When I run lspci I get this at the bottom:

02:00.0 Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 03)
Subsystem: Linksys Device [1737:4320]
Flags: fast devsel, IRQ 11
Memory at 18000000 (32-bit, non-prefetchable) [disabled] [size=8k]
Capabilities: [40] Power Management version 2
Kernel modules: ssb

I can also run ifconfig -v and get this:

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:720 (720.0 B) TX bytes:720 (720.0 B)

Something else that bothers me is in network tools, the only interface I have available is Loopback Interface (lo)
I tried editing the interfaces using nano /etc/network/interfaces.

I can change it to whatever I want it seems, save using ctrl + o, but it never changes the available interfaces in the network tools gui. I tried installing ndiswrapper and the associated tools, after which I uninstalled and went to b43-fwcutter when I figured all of that out. It seems I cant get Ubuntu to recognize the wirelss card, or something along those lines. Help?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Eric
Solved:
2010-01-24
Last query:
2010-01-24
Last reply:
2010-01-24
bojomojo (shadi-phi) said : #1

On the Broadcom website, search for hybrid linux drivers, follow the steps in the readme file, it worked like charm for me.

Eric (phuzzy88) said : #2

I went to the Broadcom website and searched all over for hybrid drivers, and even "bcm4306". It seems they do not have a driver specific to what I have here. Do you know what driver file you downloaded?

bojomojo (shadi-phi) said : #3

this is the name of the one I installed:
hybrid-portsrc-x86_64-v5.10.91.9.3 because I have a 64 bit...

You do not have to get a specific one for your card, just download the one you find and it will work

Colin Ian King (colin-king) said : #4

Have you used the Broadcom STA proprietary wireless driver (wl.ko)? Use Jockey to install this: System->Administration->Hardware Drivers and select the Broadcom STA driver. This may give you better mileage.

Eric (phuzzy88) said : #5

This was becoming too much of a pain. I've been trying at this for hours. I finally dug through all my old computer crap and found another card. It's a compaq networking card, and worked as soon as I plugged it in. Not sure what I did, I just hope it keeps working.