broadcom wireless network card not detected

Asked by Ron Jordan on 2010-01-22

I am new to Ubuntu, and Linux as a whole; I recently (3 days ago) switched from Windows. I have installed Unbuntu 9.10 (Karmic Koala) on my E-Machines Em-250 Netbook. It does not have a CD Rom drive of course so I installed from a Live USB. When running from the Live USB the wireless card was detected and worked fine, but after the full install, it was no longer detected under Hardware Drivers. When I run "sudo lshw -C network" from the terminal it lists my wireless card there (BCM4312 802.11b/g from Broadcom). After some tweaking and reading on some of the cIommunty forums; trying what I saw there, and pure dumb luck... I managed to get the Broadcom B43 and Broadcom STA wireless drivers to actually get detected under Hardware Drivers. However, when I attempt to install either driver from the Hardware Drivers interface, the program freezes. I am now attempting to install them from the terminal, and I get the following:

ron@ron-laptop:~$ sudo apt-get install b43-fwcutter
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  b43-fwcutter
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/18.1kB of archives.
After this operation, 115kB of additional disk space will be used.
Media change: please insert the disc labeled
 'Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)'
in the drive '/cdrom/' and press enter

Obviously this is a problem as my netbook has no CD-Rom drive. Is there a way to get the system to read from the usb as opposed to the CD-Rom?
Apparently there are a lot of other people having problems with the 9.10 release and their wireless; is my search in vain, or is there hope? Any help would be greatly appreciated.

Thank you,
Ron Jordan

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Ron Jordan
Solved:
2010-01-24
Last query:
2010-01-24
Last reply:
2010-01-23

Use a wired internet connection til you get righted, or as the installer says, insert the installation CD to install from that

Duane Hinnen (duanedesign) said : #2

Since you dont have a CD-ROM drive we will need to set up the USB as the apt source. But i think you already knew that ;)
1.) Insert the usb drive and run in a Terminal (Applications > Accesories > Terminal):
sudo fdisk -l (lowercase L)
2.) Locate the entry for your usb drive. If you need to pull the drive out and run it again to see what changes, that is acceptable. Mine looked like this:
   Device Boot Start End Blocks Id System
/dev/sdc1 1 488 3919841 b W95 FAT32
3.) Create an entry in fstab. Start by opening the the file by running the following command in the Terminal:
 sudo gedit /etc/fstab
4.) Add an entry to the bottom of the file. Her is what mine would look like based on the output of fdisk -l (this also assumes your usb is formatted FAT32):
/dev/sdc1 /media/usb vfat defaults 0 0
5.) now make the directory, you specified in the fstab entry, for the disk to mount to. Run the following in the Terminal:
sudo mkdir /media/usb
6.)Now specify our new mount point as the apt source you wish to use (if you used a name for your mount point other than /media/usb you will need to reflect that in this command). Run the following in a Terminal:
sudo apt-cdrom -d /media/usb add
7.) Try and install your package

For more information on options available with your fstab file see the link below:
http://ubuntuforums.org/showthread.php?t=283131

Greg (gsmorgansen) said : #3

I had the same problem. The issue is that any drivers for hardware are downloaded from the Ubuntu server. They are not on the CD Live version, other than to give the user an idea of how things work in a more limited version than the full install. So, you have just found out that the full install does not include drivers present in the Live CD. All you have to do to get your Broadcom up and running is go to System>Administration>Hardware Drivers and the window will appear with the colored bar going back and forth. Wait for the window with the proprietary drivers to appear. Among the drivers will be the Broadcom you are looking for. When you see it, click on it and then click on the "activate" button. The package will download. It will either install itself or ask you for permission.

When you have the driver installed, you must find out how you switch your system to the internal wireless mode. Disconnect you ethernet chord from the laptop. Having done that, you will see the ethernet icon disappear from the right-hand end of the top task bar. It will take the system a minute to detect the available wireless sites close enough to you for your use. After a minute, left-click on the unplugged icon that took the place of the ethernet icon. A list of the available wireless sites will appear. Left-click on the one you want. The swirling icon will appear and in a few seconds will be replaced with another icon that shows that you are connected to the wireless site you have chosen.

Mail me back when you have made you connection or have more questions. :-)

Ron Jordan (disciple6640) said : #4

i solved my problem... sort of. I was unable to get a fix through either means, so i decided to try a previous release. I am now running 9.04 (jaunty jackalope) with no problems. boots much smoother and my wireless automatically detected. thank you all for the suggestions.