kernel update wifi doesn't work anymore Ubuntu 9.10

Asked by zuperman on 2009-12-10

Hello!!

After I've made an update to ubuntu 9.10 through update manager I've noticed that my wifi is not working any more.
The update I think included a new version of kernel: 2.6.31-16-generic

after trying a lots of commands I've notice that my wifi starts working when I run this:
$ sudo modprobe -r ath5k
$ sudo modprobe ath5k

but after a restart wifi doesn't work again.
here is some output:

lshw -C network

*-network
       description: Wireless interface
       product: AR5001 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: wmaster0
       version: 04
       serial: 00:16:44:d9:15:cb
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath5k ip=192.168.2.4 latency=0 multicast=yes wireless=IEEE 802.11bg
       resources: irq:18 memory:fa000000-fa00ffff
----------------------------------------------------------------------------------------------------------------------------------------
dmesg | egrep -i '(ath|wifi)'

[ 0.994000] device-mapper: multipath: version 1.1.0 loaded
[ 0.994003] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 13.907336] ath5k 0000:08:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 13.907352] ath5k 0000:08:00.0: setting latency timer to 64
[ 13.907405] ath5k 0000:08:00.0: registered as 'phy0'
[ 14.025526] ath: EEPROM regdomain: 0x30
[ 14.025530] ath: EEPROM indicates we should expect a direct regpair map
[ 14.025534] ath: Country alpha2 being used: AM
[ 14.025536] ath: Regpair used: 0x30
[ 14.105877] ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
----------------------------------------------------------------------------------------------------------------------------------------
lsmod | grep ath

ath_pci 196788 0
wlan 228464 1 ath_pci
ath_hal 362144 1 ath_pci
ath5k 124260 0
mac80211 181076 1 ath5k
led_class 4096 1 ath5k
ath 8060 1 ath5k
cfg80211 93052 3 ath5k,mac80211,ath
----------------------------------------------------------------------------------------------------

thanks!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
zuperman
Solved:
2009-12-10
Last query:
2009-12-10
Last reply:
2009-12-10
Jim Bauwens (jimbauwens) said : #1

Try installing linux-backports-modules-karmic.

Jim

zuperman (madebybackbl) said : #2

I've installed linux-backports-modules-karmic but nothing changed. Maybe if I had this installed before the update of kernel I wouldn't have this problem. :|

zuperman (madebybackbl) said : #3

I've managed to make it work finally.
The solution is very simple:
sudo gedit /etc/rc.local

and put this lines before exit 0

echo 1 > /proc/driver/acerhk/wirelessled
modprobe -r ath5k
modprobe ath5k