Can't connect Ubuntu 9.10 to Internet

Asked by Mark on 2009-11-25

Hello. I have tried Ubuntu 9.10 on various machines, Dell GX-260, GX-270, GX-280, GX-620, HP Pavilion, etc. and I can't get Firefox to go on the Internet. I see many forum answers here on commands to enter but nothing has worked. I have used command such as:

sudo gedit /etc/resolv.conf
sudo chattr +i /etc/resolv.conf
sudo iwlist eth0 scan
http://www.ubuntugeek.com/ubuntu-network-troubleshooting-tips.html
iwconfig
ifconfig
ping -c 4 google.com
traceroute google.com
route -n
netstat -nr
netstat -a
netstat -l
lspci
System->Preferences->Network Proxy->Direct Internet connection->Apply system-wide
sudo pppoeconf
sudo lshw -C network; ifconfig
Firefox Network settings

and they all look "right" but I have no way of knowing. The problem is interpreting the results. I have no idea what is right or wrong. So if there was some explanation somewhere that would be very useful.

It would be nice if there was a Internet Troubleshooting tool that you could download that would automatically detect the problem and tell you how to fix it (or fix it automatically).

By the way, expect more questions about getting the Internet to work, as Ubuntu was given the endorsement of Brian Krebs of the Washington Post:

http://voices.washingtonpost.com/securityfix/2009/10/e-banking_on_a_locked_down_non.html

and

http://voices.washingtonpost.com/securityfix/2009/10/e-banking_on_a_locked_down_pc.html

Thanks in advance for your help

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-25
Last reply:
2009-11-29

Thats why the forum exists. Can you give the output of those commands

Thanks

Amit Kucheria (amitk) said : #2

Before you go about editing your config files, can you describe your setup?

Are you trying to use wired or wireless networking?
If so, what hardware?
Do you actually get an IP address?
Are you behind a proxy?

Mark (markkrenik) said : #3

I will reproduce those output and post them here.

Meanwhile the configuration has always been the same. I am using a cable modem, connected to a router on a local area network. I have tried it on two separate networks. Each uses DHCP (one provides DHCP from a W2K Server and the other provides DHCP from a Linksys Router). The Ethernet is all 100Mbps. In each case the Ethernet card shows up, and the network settings look correct, with an assigned IP address, and the resolv.conf has the correct DNS name servers.

It just seems to me that rather than asking folks to post all this output to resolve these issues with Internet connectivity, it would be more efficient to create an Internet Connection Troubleshooter for Ubuntu that would automate this process. So if you know of such a utility I would be greatly interested. It would be even better if Ubuntu included this with its release, but that probably asking too much...

Thanks,
Mark

Mark (markkrenik) said : #4

I will reproduce those output and post them here.

Meanwhile the configuration has always been the same. I am using a cable modem, connected to a router on a local area network. I have tried it on two separate networks. Each uses DHCP (one provides DHCP from a W2K Server and the other provides DHCP from a Linksys Router). The Ethernet is all 100Mbps. In each case the Ethernet card shows up, and the network settings look correct, with an assigned IP address, and the resolv.conf has the correct DNS name servers.

It just seems to me that rather than asking folks to post all this output to resolve these issues with Internet connectivity, it would be more efficient to create an Internet Connection Troubleshooter for Ubuntu that would automate this process. So if you know of such a utility I would be greatly interested. It would be even better if Ubuntu included this with its release, but that probably asking too much...

Thanks,
Mark

Vikram Dhillon (dhillon-v10) said : #5

Alright it seems like your network card isn't supported, have you
tried this [1] it might just work.

[1] https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

--
Regards,
Vikram

On Wed, Nov 25, 2009 at 1:35 PM, Mark
<email address hidden> wrote:
> Question #91671 on Ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+question/91671
>
> Mark posted a new comment:
> I will reproduce those output and post them here.
>
> Meanwhile the configuration has always been the same.  I am using a
> cable modem, connected to a router on a local area network.  I have
> tried it on two separate networks.  Each uses DHCP (one provides DHCP
> from a W2K Server and the other provides DHCP from a Linksys Router).
> The Ethernet is all 100Mbps.  In each case the Ethernet card shows up,
> and the network settings look correct, with an assigned IP address, and
> the resolv.conf has the correct DNS name servers.
>
> It just seems to me that rather than asking folks to post all this
> output to resolve these issues with Internet connectivity, it would be
> more efficient to create an Internet Connection Troubleshooter for
> Ubuntu that would automate this process.  So if you know of such a
> utility I would be greatly interested.  It would be even better if
> Ubuntu included this with its release, but that probably asking too
> much...
>
> Thanks,
> Mark
>
> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

Amit Kucheria (amitk) said : #6

Erm, why does he need Ndiswrapper? He said it the network is all ethernet and apparently it gets an IP address from the DHCP server.

To the original poster: Could you post the output of 'ifconfig' after you get an IP address from the DHCP server?

Tom (ecosseman) said : #7

For Amit Kucheria I too have tried all sorts of attempts to get Firefox/Thunderbird on 9.10. My 8.04 and 8.10 or OK on same computer(64-bit) - Ethernet/ADSLmodem. Have ifconf'd 9.10. Hope this helps. I'll follow up any of your suggestions.
Thanks
Tom
user@user:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:1a:4d:7e:e0:d0
          inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::21a:4dff:fe7e:e0d0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1079 (1.0 KB) TX bytes:4653 (4.6 KB)
          Interrupt:23 Base address:0xa000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)

user@user:~$

Can you give the output of:

sudo lshw -C network; ifconfig; route; cat /etc/resolv.conf

olly_b (olly-xquest) said : #9

I have had exactly the same problem on kubuntu 9.10 as well as ubuntu 9.10
I can connect with no problems on the same network from another PC running kubuntu 8.10
I can ping ubuntu.com with 100% success but cannot connect to the internet via firefox
I have a wired connection with DHCP enabled.
The router is a D-Link DSL 504T
The PC is a Dell Optiplex 745 dual booted with XP
The results of the commands requested are:
 *-network
       description: Ethernet interface
       product: NetXtreme BCM5754 Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 02
       serial: 00:18:8b:24:39:d4
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.99 duplex=full firmware=5754-v3.15 ip=192.168.1.4 latency=0 link=yes multicast=yes port=twisted pair speed=100MB/s
       resources: irq:28 memory:dfaf0000-dfafffff
olly@ubuntu:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:18:8b:24:39:d4
          inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::218:8bff:fe24:39d4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:2352 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1450 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:506449 (506.4 KB) TX bytes:234213 (234.2 KB)
          Interrupt:16

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

olly@ubuntu:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 1 0 0 eth0
link-local * 255.255.0.0 U 1000 0 0 eth0
default mygateway.ar7 0.0.0.0 UG 0 0 0 eth0
olly@ubuntu:~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 192.168.1.1

ok run:

gksudo gedit /etc/resolv.conf

and add these lines:

nameserver 208.67.220.220
nameserver 208.67.222.222

save the new file, close gedit and retry web browsing.

olly_b (olly-xquest) said : #11

Thanks for your help.
I have added the extra lines to resolv.conf, but with no success.
I can still ping ubuntu.com but get a timeout with firefox.
Olly

olly_b (olly-xquest) said : #12

Maybe this will help:
Here are the results of the same commands run on the machine running kubuntu 8.10 WHICH WORKS OK on the same network via the same router but on a different PC.

  *-network
       description: Ethernet interface
       product: 82557/8/9/0/1 Ethernet Pro 100
       vendor: Intel Corporation
       physical id: c
       bus info: pci@0000:00:0c.0
       logical name: eth0
       version: 08
       serial: 00:90:27:b0:2e:43
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.23-k4-NAPI duplex=full firmware=N/A ip=192.168.1.2 latency=32 link=yes maxlatency=56 mingnt=8 module=e100 multicast=yes port=MII speed=100MB/s
  *-network DISABLED
       description: Ethernet interface
       physical id: 1
       logical name: pan0
       serial: 86:a8:e3:68:c9:47
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes
olly@kblinux40gb:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:90:27:b0:2e:43
          inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::290:27ff:feb0:2e43/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:2726 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2685 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2237106 (2.2 MB) TX bytes:460242 (460.2 KB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:418 errors:0 dropped:0 overruns:0 frame:0
          TX packets:418 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:184201 (184.2 KB) TX bytes:184201 (184.2 KB)

olly@kblinux40gb:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 1 0 0 eth0
default mygateway.ar7 0.0.0.0 UG 0 0 0 eth0
olly@kblinux40gb:~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 192.168.1.1

Can you help with this problem?

Provide an answer of your own, or ask Mark for more information if necessary.

To post a message you must log in.