Upgrade to 9.10 - slow loading of web pages- IPV6 Prob?

Asked by Mike Cummings on 2009-11-20

After upgrading to Karmic 9.10 from 9.04, i found that web pages in both Firefox and the Google Chrome unstable version I am playing with were having problems resolving the addresses. I quickly found that this was an issue with all the apps that access the internet. This was not an issue on 9.04.

 In a forum on Ubuntu, I found an instruction to try and disable IPV6; I inserted the following line into the menu.lst line for my kernel 26.31-14-

 ipv6.disable=1.

 This worked beautifully, as long as I used legacy grub. I have since upgraded grub to grub2, as I read somewhere else that that would solve the problem, as well. Now I am back to the same problem- pages are very slow to resolve.

Is there a more permanent solution to this problem outside of disabling IPV6? Was there a change made in 9.10 that causes an incompatibility with my network? I am hard-wired to a D-link DIR-615 router connecting to an Earthlink DSL modem, using DNS relay to the Earthlink DNS servers. The connection info show the address of the router as the primary DNS. My other (Windows) computers on the network have no problems, and Juanty worked fine.

Any ideas?.

PS- edited /etc/default/grub to disable ipv6 in grub2 - pages loading, but clearly, there is still an issue with ipv6. Possibly the new network manager? I noticed that my wired connection, eth0, shows as "never used" in the network connections dialog. if I set the ipv6 settings - method to anything but "ignore", the network becomes unavailable.

Question information

Gabe Gorelick (gabegorelick) said : #1

Regressions involving the performance of IPv6 in Karmic are already known. Therefore, this bug is being converted into a question to clear up any questions you have.

Gabe Gorelick (gabegorelick) said : #2

Bug #417757, which documents the IPv6 performance regression in Karmic, has more information on this subject.

Alle de Jong (alledejong) said : #3

The problem is what I gather that Firefox asks a IPv6 adress from the DNS. As IPv6 is not operational it does not get an answer and times out (about 10 sec) then it will look for an IPv4 address et voilá there it is. My solution is type in the Firefox address about:config You will get a warning to promise you will be carefull. After this you will get all the settings. Look at the network setting IPv6 ignore. This probably is set to False. Click it and it will turn to True. Problem solved.

Schreiber (schreiber07) said : #4

The problem is only saved for firefox, not for konqueror, not for other webapplication like google earth. I always got a server-error in googleearth. Then I temporary use OpenDNS and it works.
I think it is not a goot solution. But I don't know another.

Greetings

Can you help with this problem?

Provide an answer of your own, or ask Mike Cummings for more information if necessary.

To post a message you must log in.