Lost web access after suspend/resume

Asked by David Fourer on 2007-06-22

After about 6 or 8 suspend/resume cycles or about 24 hours, I can't access any web pages or get my email on a wired connection (firefox & Thunderbird) NetworkManager says I'm still connected to the wired internet. Currently I re-boot to fix. I don't know how to troubleshoot this. I suspect I don't have to worry about suspend but just make a simple fix each time I loose access. I don't know much about networks or internet connection. I tried resetting network connection in System/Admin/Network/

From NetworkManager (while connection is working):
Active Connection Information:
   Interface --- Wired Ethernet (eth0)
   Speed 100 Mb/s
   Driver b44

   IP address 192.168.254.104
   Broadcast Addr 255.255.255.255
   Subnet Mask 255.255.255.0
   Default Route 192.168.254.254
   Primary DNS 192.168.254.254
   Secondary DNS 0.0.0.0
   Hdwr Addr 00:14:22:DA:6F:E2

From Network Tools
   Network device loopback interface (lo)
   IP information
       protocol-IPv4 IP Address-127.0.0 Netmask/prefix-255.0.0.0
       protocol-IPv6 IP Address-- ::1 Netmask/Prefix-128 Scope-host

Thanks
*********************************
*********************************
Replying to your request for more information.

Network Manager--Active Connection Information
After resume, when fault occurs:

Interface: wired Ethernet (eth0)
Speed 100 Mb/s
Driver b44

IP Adress 0.0.0.0
Broadcast Address 0.0.0.0
Subnet Mask 0.0.0.0
Default Route 0.0.0.0
Primary DNS 0.0.0.0
Secondary DNS 0.0.0.0
Hardware Address 00:14:22:DA:6F:E2

The whole of dmesg.txt, after resume when fault occurs, and then after reboot, when network is connected, is located here:
https://home.comcast.net/~davidfourer/dmesg.txt

************************************************
This solution seems to work great, and it's easy. Uninstall Network-Manager and install [URL="http://wicd.sourceforge.net/"]WICD[/URL].
[QUOTE=walkerk;3127434]I had a similar problem in Ubuntu using network-manager. This is a known issue. My fix was to install [URL="http://wicd.sourceforge.net"]WICD[/URL][/QUOTE]
Found here: http://ubuntuforums.org/showthread.php?p=3127434#poststop
Another thread: http://ubuntuforums.org/showthread.php?p=2960591#poststop

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
David Fourer
Solved:
2007-07-05
Last query:
2007-07-05
Last reply:
2007-06-29
David Portwood (dzportwood) said : #1

Thanks for reporting this bug.
I have a couple of questions for you
Can you give some output from dmesg at the time you resume? Also is the IP address shown above the same that is issued when you do a reboot, or when the network is functioning properly?

David Fourer (dfourer) said : #2

David Portwood: I appended more info you requested, to original request above (gn8584)

David Portwood (dzportwood) said : #3

Can you try to disable wired networking, then re-enable it after it fails on resume, it appears network manager is not asking for a new IP address from the DHCP server. Let me know how this goes.

David Fourer (dfourer) said : #4

I recall that I tried turning wired connection off and on with System>Admin>Network and it didn't help (I have to wait for the next resume problem to try it again)
I tried turning the graphics system off and on with alt-ctrl-backspace. This closes all apps, shuts down the window system, and makes me log in again. No help.
Also someone on a forum suggested:
   sudo /etc/dbus-1/event.d/25NetworkManager stop
   sudo /etc/dbus-1/event.d/25NetworkManager start
but I don't think I understand what it does. It didn't help

Do you more specific recommendations?
Occurs to me I didn't try a very simple thing--unplugging the wire and plugging it back in. Does sound unlikely.

Thanks for your help.

David Portwood (dzportwood) said : #5

Those commands will stop and start network manager, you can also combine them into a single command sudh as:
'sudo /etc/dbus-1/event.d/25NetworkManager restart'

I'm pretty sure after a resume, right click on network-manager applet on the upper systeray area, uncheck enable networking, then recheck enable networking will solve this, so next time you run into the problem on resume give that a shot.

David Fourer (dfourer) said : #6

Success, I think. I used "Network administration tool" in system>Admin>network to un-check and re-check wired network. This time it worked. I'll have to try it again next time I have a failure. It acted differently than usual, quickly processing my changes instead of taking 20 or 30 seconds. The next step, if it is working, will be to write a shell script to do it with a click. (Not turning Net manager off, but turning off the connection?) I'll let you know what happens.

David Fourer (dfourer) said : #7

Failed again.
I turned on videos on two web sites on Firefox browser, followed by suspend. Videos had a history of problems, or I wouldn't notice. Then I did suspend/resume and lost network contact. Then I tried network config tool and network manager manual config. I got the long wait for during "Changing Interface Configuration" No re-connection even though it says "Wired network connection"

Funny that it behaved differently that one time, and reconnected. I'm sure there is a simple solution. Any more ideas?

David Portwood (dzportwood) said : #8

I think your confusing it by using both, Can you try just using network-manager the one with the icon in the systray. For testing, do not use system --> admin --> network, just network-manager applet. By using a manual config + network manager it gets confused, network-manager expects the file /etc/network/interfaces to all be set to auto, such as:
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp
auto ath1
iface ath1 inet dhcp

Hope this helps.
David

David Fourer (dfourer) said : #9

I still have a problem, but less often. I thought Network Manager might be part of the problem, so I dissabled it and tried to establish a connection but no luck yet.
I can tell when the connection is off because of all the zeros in "Network Manager--Active Connection Information" (see top post).
I noticed an strange thing: /etc/network/interfaces looks like this:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
# The loopback network interface
auto lo
iface lo inet loopback
# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
# The primary network interface
iface eth0 inet dhcp
iface eth1 inet dhcp
wireless-essid linksys
auto eth1
auto eth0

But after a fault, there are a bunch of blank lines inserted after the line 'wireless-essid linksys' or in other places. Can 5 or 10 blank lines cause a problem?

When I first noticed the blank lines, I edited them out, and didn't have a problem for several days. When connection dropped, some of the blank lines were back.

------David

David Fourer (dfourer) said : #10

More information:
:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
03:01.2 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
03:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
david@davidf:~$

Best David Fourer (dfourer) said : #11

The following was suggested by a forum user:

david@davidf:~$ sudo /etc/init.d/dbus restart
Password:
 * Stopping System Tools Backends system-tools-backends [ OK ]
 * Stopping network events dispatcher NetworkManagerDispatcher [ OK ]
 * Stopping Avahi mDNS/DNS-SD Daemon: avahi-daemon [ OK ]
 * Stopping network connection manager NetworkManager [ OK ]
 * Stopping DHCP D-Bus daemon dhcdbd [ OK ]
 * Stopping Hardware abstraction layer hald [ OK ]
 * Stopping system message bus dbus [ OK ]
 * Starting system message bus dbus [ OK ]
 * Starting Hardware abstraction layer hald [ OK ]
 * Starting DHCP D-Bus daemon dhcdbd [ OK ]
 * Starting network connection manager NetworkManager [ OK ]
 * Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon [ OK ]
 * Starting network events dispatcher NetworkManagerDispatcher [ OK ]
 * Starting System Tools Backends system-tools-backends [ OK ]
david@davidf:~$

This worked. This is easier than re-boot. My next question is how to make a one-click fix?

David Portwood (dzportwood) said : #13

You can make this into a script

'echo /etc/init.d/dbus restart > dbus.sh'
'chmod +x dbus.sh'

then if your using gnome create a new launcher by right clicking on the desktop new launcher, then name it whatever you want, and in the command blank put 'gksudo dbus.sh'