Verizon Wireless UM150 usb modem

Asked by Santi on 2009-04-21

WIll version 9.04 support this EVDO USB Modem from Verizon out of the box? I am new to linux and scripts that I have tried don't seem to work.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Craig Huffstetler
Solved:
2009-04-21
Last query:
2009-04-21
Last reply:
2009-04-21
Craig Huffstetler (xq) said : #1

What version of Ubuntu are you running currently?

With the UM150 USB Modem plugged in can you issue the following command on a terminal (Applications > Accessories > Terminal):

lsusb

And list the contents in the next message you post back. Also, what have you tried thus far?

I will ask one more question: When did you purchase the modem/plan? If you are within 30 days, I can recommend a more "Linux" friendly USB modem that Verizon should allow you to exchange that USB Modem for without any hassle.

Best Craig Huffstetler (xq) said : #2

To answer your question completely, and not to try to get it working in the current version of Ubuntu, a Fix was indeed released on 2009-03-04 to Ubuntu-2.6.28-8.21. It was an issue with the kernel in Intrepid Ibex.

It has been fixed in the latest version of Jaunty.

Cheers,

Craig

Santi (santiago-cuellar) said : #3

So I should be able to download the new version Jaunty and get my Verizon Wireless cards to work.

My question is, will is work out of the box or do I have to run complicated scripts?

Craig Huffstetler (xq) said : #4

In Intrepid, however, just make sure you have the latest updates (and kernel) installed. It may still be in proposed, but I doubt it. This is from reading the last comment on the attached bug.

("I ran into this bug on Intrepid, with a 2.6.27-11 kernel.

I can also confirm that installing "linux-image" from intrepid-proposed fixes it. The version I installed from there is 2.6.27-13.")

Please go to a terminal and type in:

sudo apt-get update

then

sudo apt-get upgrade

This will NOT upgrade you to Jaunty, just upgrade the latest packages. It will ask you to restart if it installs the latest kernel.

The latest images (daily), if you do decide to install Jaunty as a clean install, can be found here:
http://cdimage.ubuntu.com/daily/current/
I recommend you use these. Jaunty will be released in two days as you may already know. This is the final release candidate.

If you would rather just upgrade from your current version, instead of a fresh install, then follow these instructions:
Type ALT+F2 in Gnome and then in the run box:
update-manager -d
Press enter.
This will begin the upgrade process. Follow the instructions on screen.

Craig Huffstetler (xq) said : #5

It will work out of the box because the kernel has support for it. Basically, the problem *should* be solved in Intrepid by now. It was a problem with the kernel (a "regression" as we call it -- basically something regressed to a broken state...after it was already fixed). So, it has been fixed again.

You're good to go in Jaunty. It will hop right out of the box. Users have already confirmed this.

I have a similar question. I have been having trouble with my laptop screen freezing and turning gray part of the time or just freezing. So I 'chatted online' with a person from Verizon. She informed me there would be no problem in my area using their Wireless Modem 'UML2900 LTE Modem'. Well, it arrived today and I cannot get the 'VZAccess Manager' installed as the CD is for Windows etc.... So my question is, can I run say Windows 7 with Ubuntu? They told me when I called they never heard of Linux. Or is there a Linux system that would work with this Wireless modem? I currently have Ubuntu 10.04.2 LTS... Need help in the next 2 or 3 days at the most. Only have 14 days to return it. I am not highly computer program knowledgeable. The instructions say 'not to plug the modem in, till VZAccess Manager is installed' and I am not having any luck trying to do so. Does anyone think Mandrake or another Linux OS would be more compatible. I have not heard of 'Intripid'. What's that? What is Jaunty?