how to use Proxy to the Internet

Asked by YJ on 2007-03-14

I am using proxy to the Internet, the firefox works, but the ubuntu
seems not working. I can not download the packages from ubuntu. Can anyone tell me how to solve this? Thank you very much!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2007-03-14
Last reply:
2008-08-12

Under System --> Preferences there is an option called "Network Proxy" where you can set the proxy that is used by most applications. This includes the package management tools.

YJ (zacha0223) said : #2

I have set the proxy.But in the terminal I still can not ping, for example www.google.com.

weldan jamili (ibnujamili) said : #3

Have you mount your network devices?

System -> Administration -> Networking

YJ (zacha0223) said : #4

Yeah.The firefox works perfectly. But I can not download package information from http://de.archive.ubuntu.com or other sites.
And in System -> Administration -> Network Tools

I tried to ping www.google.com, but packets losses is 100%.

frank (frankzhu-2001) said : #6

Somehow ubuntu setting proxy isn't so easy, what I find so far is
To synaptic PM, setting the system/preference/network proxy works for me
To use terminal such as apt-get, you need set proxy in bash shell,
add a line export http_proxy='proxy address' into ~/.bashrc, for example, if the proxy is http proxy, it will be 'http://proxy_address:proxy_port'

I haven't figure out how to get the proxy working for dictionary and im (pidgin/gaim) at work.

good luck!

Lorant (kiskacsa) said : #7

Hello

For pidgin i use the tsocks application, and it works fine (apt-get install tsocks, then edit the /etc/tsocks.conf file, the run the pidgin this way: tsocks pidgin)

Tsocks homepage is: http://tsocks.sourceforge.net/

Callum Macdonald (chmac) said : #8

@Lorant: Do you use the standard version of tsocks? Any custom settings?

I find that launching `tsocks pidgin` causes my CPU usage to hit 100% until I close pidgin. I think it's some sort of DNS leaking issue or something, I'm not sure. Pidgin invariably causes my SSH tunnel (dynamic port forward for a SOCK proxy) to lose connections.

Can you help with this problem?

Provide an answer of your own, or ask YJ for more information if necessary.

To post a message you must log in.