No Internet but able to ping

Asked by Brian Oliver on 2007-02-05

I have just installed Ubuntu (latest version). newbie to Linux old hand with windows going back to the dos days.

I cannot access the internet.
I have a d-link adsl router and am able to contact that through firefox and check its settings etc. Http://
So I know that the network side of the system is OK
I can ping outside lines ie

Neither , Firefox, email client, or Ubuntu downloading can access the internet.

It feels like there is a firewall in place preventing access to the internet or a permission setting.

I have looked at other answers but they don't appear to apply.

I have looked at all the settings that would appear to be relevant but nothing appears to work.

Help would be appreciated.


Question information

English Edit question
Ubuntu gnome-nettool Edit question
No assignee Edit question
Last query:
Last reply:

This question was reopened

Luca Falavigna (dktrkranz) said : #1

Are you able to resolv domain names? Try with command "host".

Maurizio Moriconi (bugman) said : #2

Maybe you don't configure DNS.

Try to view /etc/resolv.conf and add a dns server.

If there is a line with dns server (nameserver try to ping this.

Brian Oliver (brianoliver) said : #3

Not sure where to type in 'host'
is this a command line request? if so how do I access the command line? (sorry to be thick) I have been using Network tools to check out the settings and pings.

Looked at the file 'resolv-config'

Line was "nameserver"

I can ping without problems

Its defenatly somthing to do with the router because I tested my laptop using Ubantu (cd disk version) on both my work router (dynalink) where it worked fine and here on the d-link where it did not.
Router is working fine with windows - using it now.
Where do I configer the router access in Linux ?

Maurizio Moriconi (bugman) said : #4


Try to change resolv.conf with

"nameserver" removing http://

To do this open a Terminal and type:

"gksu gedit /etc/resolv.conf" then insert your password and modify the line.


McShifty (benharris1984) said : #5

I also seem to have the exact same problem. I too have a d-link router and whilst I can ping google and other computers on my network I'm unable to access the internet. I followed the instructions on this thread and I was given the answer:


Which to me seems to be correct as this is the address of my router. Does anyone have anymore suggestions?

Alan (mrintegrity) said : #6

The problem is that your router is very bad as a nameserver. You need to find out the real name servers that the router is using, on the instructions provided by your ADSL provider there will be the name servers that you should use. If you can't find this then you will have to log into the router by browsing to "" in firefox and see what it says on the "status" page or "network information" page about the DNS server IP addresses.

Once you have these two addresses you need to add them to /etc/resolve.conf but the best way is to manually specify the DNS addresses in "network-admin". So, run "gksudo network-admin" or select "network" from the System > Administration menu and from there click on the "DNS" tab, you will see your routers IP address ( you need to remove this and replace it with two new entries, the DNS addresses we discovered earlier!

Good luck

Alan (mrintegrity) said : #7

BTW, you should not directly modify /etc/resolve.conf as this will interfere with Ubuntu's network manager.

McShifty (benharris1984) said : #8

Mr. Alan Mc, you are both a gentleman and a scholar. Your suggestion worked a treat and thanks to you I have a renewed enthusiasm for this crazy linux world.

Cheers Mate

(a very grateful noob)

Alan (mrintegrity) said : #9

No problem :)

Steve Clarke (clarkesj) said : #10

Hi Alan Mc, I too can ping anything but not connect with Firefox 0n 7.10 live CD. If I should not directly modify /etc/resolve.conf, how should I do it?

Thanks for your help,

Steve Clarke (clarkesj) said : #11

OK worked that out and OK, but still no internet fo me.
What else can I try?

Thanks for any help.

Steve Clarke (clarkesj) said : #12

I now have it that I can ping www & get a reply. But no connection for firefox, thunderbird or synaptic package manager.

Any suggestions?
Thanks for any help.

Hike B (hike-briano) said : #13

I have the same problem. And tried changing the DNS through network-admin but couldn't. And then changed it through /etc/resolve.conf and that didn't work either. I noticed that it does receive some packets at first but immediately it stops receiving. I'm able to ping (ping and resolve (host Any ideas???

T.B.I. (tbi-loading) said : #14

I had the same problem - I solved it by changing my Gateway because it wasn't set right!

Can you help with this problem?

Provide an answer of your own, or ask Brian Oliver for more information if necessary.

To post a message you must log in.