unable to ping but can browse the internet using firefox

Asked by kjerryn on 2008-01-28

Unable to ping internet from terminal or network tools, however can still browse internet using firefox. Pinging web-site such as google.com shows ip address for that web-site, but says 100% package loss. Ping works normal when pinged to local intranet address. Same problem is also happening with other utilities such traceroute. I have checked the dns and other network settings for my organization, they are normal. The problem started after my organization removed proxy server and allowed direct connection to internet. I have checked my proxy settings and they point to no proxy option.

Any tip will be highly appreciated

Request to admin: This question is unsolved and needs to be listed as such.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Jim Hutchinson
Solved:
2008-02-09
Last query:
2008-02-09
Last reply:
2008-02-08

It is your actual Network Address.
You need to go to "Administration"->"Network" to see your DNS Settings

kjerryn (kjerryn) said : #2

thank you Thanos Koukoulis
sorry for misunderstanding but
i know my ip, dns, proxy, and the gateway but i don't know which one to put or be putting in the places where it says network address.

Network tools is just a set of tools to test your network as well as a number of extra tools relating to network issues.
Like Ping, Netstat etc

If you want to set the network parameters for your computer you need to go to :

System -> Administration - > Network
Choose the connection you want to set the parameters for (most probably it will say wired connection)
choose Properties -> Static IP Address and fill in the required parameters.

In tab DNS add the DNS Servers.

I hope that I understood now what you are trying to do and explained the procedure.
If I misunderstood please tell me exactly what you are trying to do and I am sure we will find
the solution.

kjerryn (kjerryn) said : #4

hello Thanos
i've been trying to run these commands below in terminal and as you can see they have 100% packages loses except in one. i don't know what these mean but when i saw PING in network tools being empty i thougth that was the reason so i've been wanting to know how to fill it. Also i keep getting could not download all repositories responces and an Err message in one package when i run sudo apt-get update

kwam@kwam-desktop:~$ ping gb.archive.ubuntu.com
PING gb.archive.ubuntu.com (194.169.254.10) 56(84) bytes of data.

--- gb.archive.ubuntu.com ping statistics ---
7 packets transmitted, 0 received, 100% packet loss, time 5999ms

kwam@kwam-desktop:~$ ping archive.ubuntu.com
PING archive.ubuntu.com (91.189.88.31) 56(84) bytes of data.

--- archive.ubuntu.com ping statistics ---
6 packets transmitted, 0 received, 100% packet loss, time 5010ms

kwam@kwam-desktop:~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=63 time=4.36 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=63 time=4.50 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=63 time=4.23 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=63 time=4.61 ms
64 bytes from 192.168.1.1: icmp_seq=5 ttl=63 time=4.27 ms
64 bytes from 192.168.1.1: icmp_seq=6 ttl=63 time=4.37 ms

--- 192.168.1.1 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5000ms

Well do you have any internet access ?

Can you ping www.google.com ?

If not what are your network settings ?

check System -> Administration - > Network -> choose your ethernet connection - > properties

from what I see you can reach 192.168.1.1. Is that your local IP address ? A router of some sort ?

kjerryn (kjerryn) said : #6

i have internet access
but i do not know how to ping google.
do i just type it into the ping under nettools.

my proxy is 192.168.1.5 port 8080
dns 192.168.1.2
ip 192.168.10.67
gw 192.168.10.254

192.168.1.1 shows up sometimes in terminal but i don't know what it really though it looks very similar to the domain

yeah if you want to ping a server either go to
System - > Administration -> Network Tools
in the tab Ping in the field 'Network Address' type in the address that you want

OR

open a console and just type

ping www.google.com

kjerryn (kjerryn) said : #8

 hello Thanos,
i just typed www.google.com under the ping tab
packets transmitted:5
packets received:0
successful packets:0%

pls what does ping do anyway. is it going to help with the could not download all repositories problem?

Jim Hutchinson (jphutch) said : #9

Do you have an active network connection? Based on what I can gather from the discussion it sounds like you don't. 100% packet loss (0% successful) indicates problems.

A ping test should respond with repeating "pings" from the server you are pinging. Ping just tries to get a response from whatever server you put in. Think of it like sonar. You send out a call to the sever and see if it bounces back. If it does, great. If not, you have issues. I prefer to do this in a terminal.

ping www.google.com

I'm stuck on win at work but your output should look similar to:

Pinging www.l.google.com [64.233.167.104] with 32 bytes of data:

Reply from 64.233.167.104: bytes=32 time=315ms TTL=125
Reply from 64.233.167.104: bytes=32 time=422ms TTL=125
Reply from 64.233.167.104: bytes=32 time=247ms TTL=125
Reply from 64.233.167.104: bytes=32 time=137ms TTL=125

Ping statistics for 64.233.167.104:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 137ms, Maximum = 422ms, Average = 280ms

Please clarify what you are trying to accomplish.

kjerryn (kjerryn) said : #10

hello Jim,
the response to the command is below

kwam@kwam-desktop:~$ ping www.google.com
PING www.l.google.com (64.233.161.147) 56(84) bytes of data.

--- www.l.google.com ping statistics ---
144 packets transmitted, 0 received, 100% packet loss, time 143077ms

kwam@kwam-desktop:~$

pls how do i resolve this issues that i may have. i would appreciate a step by step guide- am new to ubuntu. And am actually trying to resolve a could not download all repositories response that i've been getting.
i do have an internet connection that i have downloaded and installed realplayer for ubuntu and it works fine.

Jim Hutchinson (jphutch) said : #11

Based on that ping data you don't have an active connection. Before we can solve the other issue (most likely related) we need to resolve this. You mention that you do have an internet connection. Can you test that again? Open firefox and try to go to google and some other sites. If that works, open up the terminal again and ping google. Technically both should work or both won't. It would be odd for you to be able to surf the web but not ping anything. Also try pinging by IP

ping 64.233.161.147

If you can ping by IP but not domain name it could be a DNS issue. Please try and clarify the status of your internet connection and the additional ping data. Thanks.

kjerryn (kjerryn) said : #12

hello Jim
this is what i got

kwam@kwam-desktop:~$ ping www.google.com
PING www.l.google.com (64.233.161.104) 56(84) bytes of data.

--- www.l.google.com ping statistics ---
25 packets transmitted, 0 received, 100% packet loss, time 23999ms

kwam@kwam-desktop:~$ ping 64.233.161.147
PING 64.233.161.147 (64.233.161.147) 56(84) bytes of data.

--- 64.233.161.147 ping statistics ---
7 packets transmitted, 0 received, 100% packet loss, time 6010ms

kwam@kwam-desktop:~$
i also typed 64.233.161.147 under the ping tab in the nettools
the response was 5, 0 and 0% successful packages.

i think may be i do not understand what you guys want me to do exactly.
maybe a step by step guide will help me to follow what you say.

Jim Hutchinson (jphutch) said : #13

Well, I'm mainly trying to understand the problem. Until then I can't offer a step by step guide. For example, you stated "i do have an internet connection that i have downloaded and installed realplayer for ubuntu and it works fine" but you can't ping anything. Those two facts are in conflict. I'm also unclear about what you are trying to do. The original question was about network addresses but we are not talking about that anymore. If you could answer the two questions below, perhaps we can get this back on track.

1. Clearly describe the problem or question you have.
2. What symptoms do you have to lead you to believe you have a problem?

kjerryn (kjerryn) said : #14

hello Jim,
i tried to reload in the synaptic but received the could not download all repositories reply. from the forum the suggestion was to check the network settings which i think is fine. then there were suggestion to type some three ping commands in the terminal but the first two had 100% package loses. then i found the nettools with many tabs requesting my network address which i didn't know if that is the ip, dns etc. which ever i entered and clicked ping resulted 100%, www.google.com typed in also has the same result. the reason why i think there's a problem is because i have some questions which finally got 0% loss.
i'd like to repeat this question -what does pinging do anyway? and will it stop the could not download all repositories responses.

Best Jim Hutchinson (jphutch) said : #15

Ping doesn't "do" anything. It's just a small network testing tool. It won't fix any problem, it doesn't change any settings. It just sends out a signal to a server and sees if it gets a reply. If it gets a reply then you have a working connection between your computer and that server. If the server is on the web (like google) then you have a working internet connection. If it doesn't work you don't have working internet connection.

Ping won't fix the "could not download all repositories" response. It will only tell us if the reason you are getting is because you have a bad network connection. It's also possible to get that if the repository server is down or configured wrong in you /etc/apt/sources.list.

kjerryn (kjerryn) said : #16

Thanks Jim Hutchinson, that solved my question.

rabbitson (rabbitson) said : #17

Hi there,

I've also got a question about this, I've installed UBUNTU and also have a problem getting the network connections running successfully. I've tried to follow several other threads but somehow they haven't helped.

I also have this packet lose problem when I use ping from a terminal, but what's unclear for me is if the network connection is not configured how th eping command is able to resolve an ip address from a name.

For example, if I enter ping www.microsoft.com then the response does not come back (I need to do a ctrl+c to see that no packets have been transmitted successfully) but the ping command returns:

PING lb1.www.ms.akadns.net (207.46.19.190) 56(84) bytes of data

then after ctrl+c:

118 packets transmitted, 0 received, 100% packet loss, time 117008ms

so surely something in the network connectivity must be working to be able to resolve www.microsoft.com in the first place?

Presumably this is a security setting problem in that case? Now that I think about it, I did get a message after installing Ubuntu (7.1 Desktop) saying that there was a problem with installing some security components but I didn't really understand it at the time.

Any tips appreciated!

rabbitson (rabbitson) said : #18

Oddly enough I have seen that with the two other pcs that are on my home network (a vista box on 192.168.1.6 and an XP box on 192.168.1.2) that I can ping and connect to the XP box, but not to the Vista box

Harish (harish-narl) said : #19

Like kjerryn and rabbitson, I am also having same problem. I searched several forums but haven't found the answer.
The problem is I can browse the internet using firefox but unable to ping from terminal as well as from network tools. However, I am able to ping all the computers on intranet. The problem started when my organization discontinued using proxy server and asked us to connect to internet using no proxy option in firefox.

Any tips will be highly appreciated!

oldwillow (oldoldwillow) said : #20

Hi, I had what sounds like the same problem.

I could surf with Firefox, (on both Hardy intallation and live disc) and I.E., with some lag.
I could download files, starting at maybe 100kB/s, dropping almost immediately to say 10 kB/s.
I could not download Windows Update, and I got "unable to authenticate" on linux update.
In Network tools, ping with ip address no go.
                          , traceroute no go
                          , DNS services no go.
 I thought it was DHCP problem.
I was assigned a blackhole server as an IP address

Well after getting onto ISP (Virgin). They sent me a new modem. Connection is now better, getting 256kB/s (2Meg svc).

I think i still have some IP issues, hence finding this page.

What I would like to understand is how one protocol works when a lower level does'nt.

I dont know if it is relevant, but I did try to implement IP6 just prior to probs.

Cheers.

@ oldwillow

Please don't append a new question on a already answered or marked as solved question.
Please make new question from here: https://answers.launchpad.net/ubuntu/+addquestion
you will get better chance to get right answer on a fresh tagged "open" question.
Solved or answered questions are usually not read from answering people.

Thank you