Wlan stops working after Ubuntu 12.04 update

Asked by Franz Hollerer on 2013-01-30

Hi,

I have a Dell Vostro 3700 notebook running Ubuntu 12.04.1 LTS and a Netgear FWG114P WLAN router which I bought 2005.
Since the update on Sunday 27. January 2013 the NetworkManager fails to connect to my WLAN Router.

The Indicator applet shows all available wireless networks, but the NetworkManager fails to establish the connection. Due to the fact that I see the available networks I think the WLAN driver itself works fine. It seems to be a DHCP problem, but I have no idead how to solve it.

If I boot from an Ubuntu 12.04 USB stick which I created about 1 year ago WLAN works fine. Thus it's not a hardware problem.

Please could you give me some hints how to solve this problem.

Thanks & Best regards,

Franz Hollerer

# /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr f0:4d:a2:87:90:5a
          inet addr:192.168.0.7 Bcast:192.168.0.255 Mask:255.255.255.0
          inet6 addr: fe80::f24d:a2ff:fe87:905a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
          RX packets:2032 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1793 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1465900 (1.4 MB) TX bytes:249876 (249.8 KB)
          Interrupt:47 Base address:0x6000

eth1 Link encap:Ethernet HWaddr 5c:ac:4c:7e:c4:0f
          inet6 addr: fe80::5eac:4cff:fe7e:c40f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:22 errors:2 dropped:0 overruns:0 frame:3780
          TX packets:300 errors:141 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3602 (3.6 KB) TX bytes:66602 (66.6 KB)
          Interrupt:17

# iwconfig
lo no wireless extensions.

eth1 IEEE 802.11abg ESSID:"Catopsis"
          Mode:Managed Frequency:2.432 GHz Access Point: 00:0F:B5:51:94:4A
          Bit Rate=54 Mb/s Tx-Power=200 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70 Signal level=-21 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.
lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:392 errors:0 dropped:0 overruns:0 frame:0
          TX packets:392 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:33528 (33.5 KB) TX bytes:33528 (33.5 KB)

Excerpt from dmsg:
[ 11.517377] eth1: Broadcom BCM4727 802.11 Hybrid Wireless Controller 6.20.155.1 (r326264)

Excerpt from /var/log/syslog:

avahi-daemon[945]: Joining mDNS multicast group on interface eth1.IPv6 with address fe80::5eac:4cff:fe7e:c40f.
avahi-daemon[945]: New relevant interface eth1.IPv6 for mDNS.
avahi-daemon[945]: Registering new address record for fe80::5eac:4cff:fe7e:c40f on eth1.*.
NetworkManager[948]: <info> Auto-activating connection 'Catopsis'.
NetworkManager[948]: <info> Activation (eth1) starting connection 'Catopsis'
NetworkManager[948]: <info> (eth1): device state change: disconnected -> prepare (reason 'none') [30 40 0]
NetworkManager[948]: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager[948]: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) started...
NetworkManager[948]: <info> Activation (eth1) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager[948]: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) complete.
NetworkManager[948]: <info> Activation (eth1) Stage 2 of 5 (Device Configure) starting...
NetworkManager[948]: <info> (eth1): device state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[948]: <info> Activation (eth1/wireless): access point 'Catopsis' has security, but secrets are required.
NetworkManager[948]: <info> (eth1): device state change: config -> need-auth (reason 'none') [50 60 0]
NetworkManager[948]: <info> Activation (eth1) Stage 2 of 5 (Device Configure) complete.
NetworkManager[948]: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager[948]: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) started...
NetworkManager[948]: <info> (eth1): device state change: need-auth -> prepare (reason 'none') [60 40 0]
NetworkManager[948]: <info> Activation (eth1) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager[948]: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) complete.
NetworkManager[948]: <info> Activation (eth1) Stage 2 of 5 (Device Configure) starting...
NetworkManager[948]: <info> (eth1): device state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[948]: <info> Activation (eth1/wireless): connection 'Catopsis' has security, and secrets exist. No new secrets needed.
NetworkManager[948]: <info> Config: added 'ssid' value 'Catopsis'
NetworkManager[948]: <info> Config: added 'scan_ssid' value '1'
NetworkManager[948]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
NetworkManager[948]: <info> Config: added 'psk' value '<omitted>'
NetworkManager[948]: <info> Activation (eth1) Stage 2 of 5 (Device Configure) complete.
NetworkManager[948]: <info> Config: set interface ap_scan to 1
NetworkManager[948]: <info> (eth1): supplicant interface state: disconnected -> scanning
wpa_supplicant[1003]: Trying to associate with 00:0f:b5:51:94:4a (SSID='Catopsis' freq=2432 MHz)
NetworkManager[948]: <info> (eth1): supplicant interface state: scanning -> associating
wpa_supplicant[1003]: Associated with 00:0f:b5:51:94:4a
wpa_supplicant[1003]: WPA: Key negotiation completed with 00:0f:b5:51:94:4a [PTK=CCMP GTK=TKIP]
wpa_supplicant[1003]: CTRL-EVENT-CONNECTED - Connection to 00:0f:b5:51:94:4a completed (reauth) [id=0 id_str=]
NetworkManager[948]: <info> (eth1): supplicant interface state: associating -> completed
NetworkManager[948]: <info> Activation (eth1/wireless) Stage 2 of 5 (Device Configure) successful. Connected to wireless network 'Catopsis'.
NetworkManager[948]: <info> Activation (eth1) Stage 3 of 5 (IP Configure Start) scheduled.
NetworkManager[948]: <info> Activation (eth1) Stage 3 of 5 (IP Configure Start) started...
NetworkManager[948]: <info> (eth1): device state change: config -> ip-config (reason 'none') [50 70 0]
NetworkManager[948]: <info> Activation (eth1) Beginning DHCPv4 transaction (timeout in 45 seconds)
NetworkManager[948]: <info> dhclient started with pid 2455
NetworkManager[948]: <info> Activation (eth1) Beginning IP6 addrconf.
avahi-daemon[945]: Withdrawing address record for fe80::5eac:4cff:fe7e:c40f on eth1.
avahi-daemon[945]: Leaving mDNS multicast group on interface eth1.IPv6 with address fe80::5eac:4cff:fe7e:c40f.
avahi-daemon[945]: Interface eth1.IPv6 no longer relevant for mDNS.
NetworkManager[948]: <info> Activation (eth1) Stage 3 of 5 (IP Configure Start) complete.
dhclient: Internet Systems Consortium DHCP Client 4.1-ESV-R4
dhclient: Copyright 2004-2011 Internet Systems Consortium.
dhclient: All rights reserved.
dhclient: For info, please visit https://www.isc.org/software/dhcp/
dhclient:
NetworkManager[948]: <info> (eth1): DHCPv4 state changed nbi -> preinit
dhclient: Listening on LPF/eth1/5c:ac:4c:7e:c4:0f
dhclient: Sending on LPF/eth1/5c:ac:4c:7e:c4:0f
dhclient: Sending on Socket/fallback
dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
avahi-daemon[945]: Joining mDNS multicast group on interface eth1.IPv6 with address fe80::5eac:4cff:fe7e:c40f.
avahi-daemon[945]: New relevant interface eth1.IPv6 for mDNS.
avahi-daemon[945]: Registering new address record for fe80::5eac:4cff:fe7e:c40f on eth1.*.
dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
kernel: [ 1167.949197] eth1: no IPv6 routers present
dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
NetworkManager[948]: <info> (eth1): IP6 addrconf timed out or failed.
NetworkManager[948]: <info> Activation (eth1) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
NetworkManager[948]: <info> Activation (eth1) Stage 4 of 5 (IPv6 Configure Timeout) started...
NetworkManager[948]: <info> Activation (eth1) Stage 4 of 5 (IPv6 Configure Timeout) complete.
dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15
dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 19
NetworkManager[948]: <warn> (eth1): DHCPv4 request timed out.
NetworkManager[948]: <info> (eth1): canceled DHCP transaction, DHCP client pid 2455
NetworkManager[948]: <info> Activation (eth1) Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
NetworkManager[948]: <info> Activation (eth1) Stage 4 of 5 (IPv4 Configure Timeout) started...
NetworkManager[948]: <info> (eth1): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
NetworkManager[948]: <warn> Activation (eth1) failed for access point (Catopsis)
NetworkManager[948]: <info> Marking connection 'Catopsis' invalid.
NetworkManager[948]: <warn> Activation (eth1) failed.
NetworkManager[948]: <info> Activation (eth1) Stage 4 of 5 (IPv4 Configure Timeout) complete.
NetworkManager[948]: <info> (eth1): device state change: failed -> disconnected (reason 'none') [120 30 0]
NetworkManager[948]: <info> (eth1): deactivating device (reason 'none') [0]
avahi-daemon[946]: Withdrawing address record for fe80::5eac:4cff:fe7e:c40f on eth1.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-31
Last reply:
2013-01-31
NickThom  (nick-athens30) said : #1

Try to clear up the wlan connection from update-manager ..

Open update-manager go to "edit connections" > "Wireless" and "edit" your connection. Remove it completely and create a new one. Place carefully your wpa key and your SSID.
Disaple Ipv6 and make this connection "available to all users" . (you will see the box , mark the box).

Then reboot and see if is able to connect.

Otherwise we will need more info (terminal commands) .

cat /etc/hosts

cat /etc/resolv.conf

lspci -nnk | grep -iA2 net

rfkill list all

Thanks

Franz Hollerer (f-hollerer) said : #2

Hi,
thanks for your answer. Unfortunately connecting to the wireless network still fails.

# cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 dionaea
192.168.0.6 aldrovanda

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

# cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1

 lspci -nnk | grep -iA2 net
12:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
 Subsystem: Dell Inspiron M5010 / XPS 8300 [1028:0010]
 Kernel driver in use: wl
--
13:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
 Subsystem: Dell Device [1028:0442]
 Kernel driver in use: r8169

# rfkill list all
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: brcmwl-0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
2: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no

Thanks
Franz Hollerer

Please open a Terminal and execute the following commands:

sudo apt-get update

sudo apt-get install linux-headers-generic

sudo apt-get install bcmwl-kernel-source

sudo apt-get install wicd

sudo apt-get install --reinstall bcmwl-kernel-source

echo "blacklist bcma" | sudo tee -a /etc/modprobe.d/blacklist.conf

echo "blacklist brcmsmac" | sudo tee -a /etc/modprobe.d/blacklist.conf

echo "blacklist brcm80211" | sudo tee -a /etc/modprobe.d/blacklist.conf

echo "blacklist b43" | sudo tee -a /etc/modprobe.d/blacklist.conf

Then REBOOT and retest wireless using wicd network manager instead of NetworkManager.

Set eth1 as wireless interface name in wicd.

Also temporarily disable wireless encryption and enable SSID broadcasting on your wireless router (for troubleshooting purposes).

Source: http://forum.ubuntu-fr.org/viewtopic.php?id=1171261

Franz Hollerer (f-hollerer) said : #4

Hi,

I followed your instructions but it did not solve the problem. Thus I undid some changes (removed the additional blacklist entries and uninstalled wicd).

I found that connecting to the wireless network succeeds if I deactive DHCP and use a static IP address instead. If DCHP is enabled than the log in the router says that it gots a DHCP request and has offered a proper IP addresss. But the DCHP client on the Ubuntu notebook runs into an timeout.

Well, it works. But it's not the preferred solution.

Thanks & Best regards,

Franz Hollerer

I'm having the same problem - if I use static IP instead of DHCP, I can connect.
This has been working fine for years, but it stopped working yesterday! I didn't change the configuration of either laptop or router, so I suspect it happened because of upgrading some Ubuntu packages. It was actually after an (unintentional) reboot that the problem came.
I have an HP Pavilion dv6, with Broadcom BCM4313 802.11b/g/n Wireless LAN Controller.

I guess I should also add the following:
* When booting my laptop into Windows7, wifi work fine
* I tried connecting (from Ubuntu) to another router, it had the same problem
* Interestingly, if I connect (from Ubuntu) to my Android phone's hot spot, it works (!)

I had this problem after installing some updates today. Connection to my router worked for years and all of the sudden stopped working. Non-Ubuntu devices can connect to the router with no problem. I followed Franz's suggestion and set a static connection and it worked again. So, updates broke something with DHCP.

I went ahead and create a bug report from this question: https://bugs.launchpad.net/ubuntu/+source/gnome-nettool/+bug/1112751

Can you help with this problem?

Provide an answer of your own, or ask Franz Hollerer for more information if necessary.

To post a message you must log in.