Wi-Fi Card detected not working Ubuntu 12.10

Asked by Niel Gow on 2012-10-27

Hey guys, Ive just installed Ubuntu 12.10 as a secondary OS on my laptop, Dell studio 1737, and it doesnt pick up any wifi networks.

I've used a lspci grep to get my network adapters, both are broadcom one wireless one ethernet port. Ethernet works fine put wifi one doesn't.

Ive tried uninstalling STA drivers and re-installing.

Anyone else had the same problem? Can anyone give me any suggestions on how to fix this?

the particulars for me wifi card follow:

04:00.0 Network Controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY
 [14e4:4315] (rev 01)
            Subsystem: Dell wireless 1397 WLAN Mini-Card [1028:000c]
            Kernel Modules: ssb

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Ubfan
Solved:
2012-10-28
Last query:
2012-10-28
Last reply:
2012-10-27

Can you give the output of:

sudo lshw -C network; dmesg | grep -i firm; lsb_release -a; uname -a

Thanks

Niel Gow (niel3000) said : #2

  *-network UNCLAIMED
       description: Network controller
       product: BCM4312 802.11b/g LP-PHY
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f8000000-f8003fff
  *-network
       description: Ethernet interface
       product: NetLink BCM5784M Gigabit Ethernet PCIe
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: eth0
       version: 10
       serial: 00:22:19:ec:4b:a9
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.123 duplex=full firmware=sb v2.17 ip=192.168.0.21 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:49 mem

No LSB Modules are availableory:fc100000-fc10ffff

Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal

Linux Niel-Ubuntu-Laptop 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Try:

sudo modprobe b43

Does the wifi device then work?

Niel Gow (niel3000) said : #4

No still no connection options showing up =/

Best Ubfan (ubfan1) said : #5

With the Ubuntu 11.x releases, the proprietary Broadcom drivers stopped
working with the 4311 Broadcom chips (see bug 732677), which may also affect
your 4312 chip. However
your 4312 chip works fine with the open b43 driver, but you first need
to install its firmware -- easily done with a package install.
Remove the proprietary STA driver (and its configuration files which
suppress the working b43 driver) by reversing whatever you did to install them:
sudo apt-get purge bcmwl-kernel-source
and/or run additional-drivers and unselect the Broadcom STA driver

Check that your removal/deactivation above is complete:
all the lines with "blacklist b43" should have
been removed from all files in /etc/modprobe.d. These blacklist lines suppress
the b43 driver, so they must be removed -- just the exact "b43" and b43legacy
ones, leave the bcm43xx alone. Deal with any leftovers:
 sudo rm /etc/modprobe.d/blacklist-bcm43.conf
 gksudo gedit any-file-found-with-b43
   and delete or put a # at the beginning.

The proprietary firmware cannot be distributed with the release,so you
have to manually add it. Use a wired connection, and in a terminal:
   sudo apt-get update
   sudo apt-get install b43-fwcutter
and accept the offer to download the Broadcom files, which
will put the Broadcom firmware into /lib/firmware/b43.
If you don't get the offer to download, then purge the package
and try again:
   sudo apt-get purge b43-fwcutter
   sudo apt-get install b43-fwcutter

You can even use the open source firmware (which is what I use):
   sudo apt-get install firmware-b43-lpphy-installer
but only one set of firmware is needed (other chips should
check for needing other versions of the firmware (like
firmware-b43-installer). If both sets of firmware are
present, the proprietary set in /lib/firmware/b43 will be used.

With the firmware in place, NetworkManager may start scanning,
if not, manually load the b43 driver module, or just reboot.
 sudo modprobe b43

NetworkManager should start scanning and offer a list of possible
connection points within a few seconds.

Select your access point, select the correct encryption method, and enter
your key. If you are not broadcasting your ssid and it does not show up in
the list of access points, you might have to left click NetworkManager and
select the menu item "connect to hidden network", and enter your ssid. Next
boot, the connection should be automatic.

Niel Gow (niel3000) said : #6

Thankyou very much @Ubfan

Works fine now, decided to go straight for the one you use seen as it's obvious you are connected.

Thanks again

Niel Gow (niel3000) said : #7

Thanks Ubfan, that solved my question.