Can't connect to wireless network

Asked by Rae on 2007-12-30

HI, OK I just installed Ubuntu 7.10 and it seems to be working fine but after finally getting the usb network adapter installed, it won't connect to the web. It's a Belkin Wireless G network adapter F5D7050 version 3002. I tried a different belkin one that went into the motherboard but i think its defective. This usb one was fine and i used that nsidwrapper thing to get it installed and it shows that my device is installed and everything when i go to system>administration>networks but it won't connect to my network I have existing. I have a laptop separate from this computer that is on that wireless network and it connects fine. This one just will not connect and after troubleshooting its definitely a linux issue and not an issue with my linksys access point....

I have this computer hooked up to both LAN and WLAN so that I would be able to get the terminal info copied and pasted properly. My ethernet is working fine, so its just wireless......

this is what I get when I did a few commands that I saw on some of the other help files: Thanks in advance....

rae@LT-Destop:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 735 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:09.0 Ethernet controller: Belkin Unknown device 700f (rev 20)
00:11.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX200] (rev b2)
rae@LT-Destop:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:07:95:C3:D1:E5
          inet addr:65.86.99.114 Bcast:255.255.255.255 Mask:255.255.255.240
          inet6 addr: fe80::207:95ff:fec3:d1e5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:1284 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1200 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1424334 (1.3 MB) TX bytes:180644 (176.4 KB)
          Interrupt:11 Base address:0xcc00

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1408 (1.3 KB) TX bytes:1408 (1.3 KB)

rae@LT-Destop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
          Mode:Managed Channel:0 Access Point: Not-Associated
          Retry min limit:7 RTS thr:off Fragment thr=2346 B
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

rae@LT-Destop:~$ CAT /etc/network/interfaces
bash: CAT: command not found
rae@LT-Destop:~$ CAT/etc/network/interfaces
bash: CAT/etc/network/interfaces: No such file or directory
rae@LT-Destop:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

iface eth0 inet dhcp

auto eth0
rae@LT-Destop:~$

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2007-12-30
Last reply:
2007-12-30
Gilbert Mendoza (gmendoza) said : #1

NetworkManager will not connect using your wireless adapter while the physical NIC is being used. Unplug from that device, and re-initialize the wireless connection.

You should also *remove* the following lines from your /etc/network/interfaces file:

iface eth0 inet dhcp
auto eth0

The only lines you should have in there are:

auto lo
iface lo inet loopback

NetworkManager will be unable to work with anything else defined manually in that file.

Rae (get-passionate) said : #2

my ethernet line was disconnected while i had all these problems. i only reconnected it to post here.

I do not know how to update that file, can you walk me through where to go?

thx

Rae (get-passionate) said : #3

and this network manager thing.. synatic says i have it, but how do i find it? is this the same as going into the system>administration>network section?

Rae (get-passionate) said : #4

synaptic i mean. sorry, spelling issues

Gilbert Mendoza (gmendoza) said : #5

:-) Sure thing. From a terminal (Applications -> Accessories -> Terminal), type the following command:

$ sudo gedit /etc/network/interfaces

Enter your password when prompted, edit the file, and save your changes.

You may have to restart NetworkManager for the changes to take affect. Close gedit from the step above, and at the terminal again, run the following command:

$ sudo /etc/dbus-1/event.d/25NetworkManager restart

After you do that, It would be interesting to see if your radio can scan for available wireless networks.

$ sudo iwlist wlan0 scanning

Gilbert Mendoza (gmendoza) said : #6

Regarding your question:
"is this the same as going into the system>administration>network section"

No... that applet is a legacy configuration utility that manually configures the /etc/network/interfaces files (and a couple others). NetworkManager is by what is installed by default and is recommended as the new way of managing networking in Ubuntu. It uses DBUS.

After you restart NetworkManager as I mentioned above... you will see the applet loaded near your clock. Left click on it to see wireless networks listed. You can also "manually" define a wireless network by selecting the option "Connect to other wireless network..."

Rae (get-passionate) said : #7

OK I did all of that and restarted the network manager and when I did the scan it errored with: wlan0 Interface doesn't support scanning : Network is down

its not because im on it on another pc typing to you......

thx :)

Gilbert Mendoza (gmendoza) said : #8

Ah, actually I almost expected that. ndiswrapper enabled cards often have trouble with that function. It's not required for the card to work.

Have you tried configuring the wireless network as I mentioned in my last message?

Rae (get-passionate) said : #9

HI, yup, thx. Back to the original problem. It never shows anything in the available networks list. I typed in the known name of the network im on and it just keeps trying to access it and every c ouple mins asks me for the passphrase again. same thing it was doing before.....

still confused on how to get to that network manager you are mentioning.. is that the etc/network/interfaces command to bring that app up? or something i missed?

Rae (get-passionate) said : #10

well i typed sudo /etc/dbus-1/event.d/25NetworkManager start and it said it started.. but i didnt see anything show up,,

Rae (get-passionate) said : #11

i also tried to config the network manually and that didnt work either.. cause then the wireless stuff disappeared from the list again and it just said manual and still couldn't get to the web.....

Gilbert Mendoza (gmendoza) said : #12

The application "NetworkManager" is the little applet on your task bar near your clock. When you right clock on it, you should have a few options such as "Enable Networking" and "Enable Wireless". You also have an "About" option, which will tell you what version of NetworkManager you are running.

A screenshot can be found here:
http://www.gnome.org/projects/NetworkManager/

As for NetworkManager asking you for your password again, this may be due to authentication failure. What Wireless security options are you using on your access point? WPA? WPA2? WEP? Double check all of these settings before continuing.

Also, one thing you can try is disabling all wireless security on your access point and try connecting to this open network. (Obviously a temporary thing for testing). Just to rule out security and card issues.

Rae (get-passionate) said : #13

HI, Yup tested all secutiry issues on my access point already, even had a live chat session with lynksys tech support. Tried it with and wirout security and its definitely an issue with just my linox bos. My laptop is on my network just fine.

and ok, I was confused thinking the network manager was something i had to open but its been open for me this whole time. its there and has wireless networks (the words) but nothing underneath it except the options to connect to other networks... i also tried to ping something on my network and couldn't ./...

Gilbert Mendoza (gmendoza) said : #14

You do not want to use the "Manual configuration" option. I know it's confusing, but think of "Manual" as legacy. It disables Network Manager.

You want to use the "Connect to Other Wireless Network" option. This will allow NetworkManager to do its thing.

Rae (get-passionate) said : #15

Oh I know I changed back afterwards, but I was testing it sinced nothing else worked. Nothing works at all to connect it. Network Manager does nothing really because it I find other networks it constantly just every couple mins re-asks for the pass phrase and never connects. If I let it try and find the networks on its own, it does nothing at all....

Gilbert Mendoza (gmendoza) said : #16

But what if you disable security on the wireless network? Just open up the AP to make sure the radio is working on your card. If you can connect to a completely open network, you at least know the card is working.

Rae (get-passionate) said : #17

I tried that earlier b ut I'll try again...

Gilbert Mendoza (gmendoza) said : #18

Can you join IRC? irc.freenode.net.

My nick is Kr0ntab, and I am in the #Ubuntu channel. This threads getting a tad long... and we can probably wrap it up in there.

Rae (get-passionate) said : #19

it asked me for a user name and password and wouldn't even let me access the webpage to try and get an account.... :(

i unsecured my network and same problem.. says no network connections,... this time it just gives up instead of asking for the password continuously....

thanks.. sorry to be such a pain but im ready to throw this stupid thing out the window :)

Gilbert Mendoza (gmendoza) said : #20

You and me both. :-P

Rae (get-passionate) said : #21

Could the driver have gotten screwed up when I put it on? should i remove them and redo them or something?

why do they make these things so difficult.....all i want to do is avoid running cables all over my house lol.

Gilbert Mendoza (gmendoza) said : #22

If you join IRC or email me, I can give you a webex URL and help you remotely.

Rae (get-passionate) said : #23

This is my first time at this site so I don't know how to do either lol. IRC didn't work but if you send me your email addy i can email you....

Gilbert Mendoza (gmendoza) said : #24

gmendoza at gmail.com

Can you help with this problem?

Provide an answer of your own, or ask Rae for more information if necessary.

To post a message you must log in.