WiFi is not saying steadily connected.

Asked by Michael Hazell on 2012-05-01

I have a Toshiba M55-S139 laptop. It has the Atheros AR5005G Wireless Network Adapter. In Ubuntu 10.04, the WiFi worked fine, with very little issues. Now in Ubuntu 12.04, the WiFi connects for about 10 seconds and then randomly disconnects. I have tried resetting the WiFi settings, and it has not helped at all.

I don't know if it has something to do with the kernel, but I need an answer to fix this problem, or I'll have to rollback to Ubuntu 10.04.

I can provide more hardware info it it is needed. My laptop has been upgraded with maxed out ram....but I believe that is irrelevant in this matter.

Question information

Barry Drake (b-drake) said : #1

Can you try running from a live-CD? If the wifi works OK from there, then there is something that has gone wrong with your upgrade and it would be well worthwhile to do a clean install after backing everything up. If not, please report a kernel bug. I am not aware of any kernel issues that affect Atheros chipsets - they are normally VERY well supported.

Michael Hazell (techman-) said : #2

I have a fresh install of Ubuntu 12.04, since I heard that fresh installs are the way to go. CD has same effect.

It might be a kernel bug, or an actual flaw with whatever the network manager is. Ubuntu 10.04 with GNOME 2, WiFi worked fine.

Can you help with this problem?

Provide an answer of your own, or ask Michael Hazell for more information if necessary.

To post a message you must log in.