DNS-Resolving fails irregularly (Ubuntu 12.04)

Asked by cirrus

I just updated to Ubuntu 12.04.
After the update I cannot resolve hostnames reliably:
I use Konsole in Unity. There sometimes the DNS resolving works fine and suddenly after two commands or so it fails for the same address.

E.g. I ping a machine without DNS-Suffix (the suffix is shown in my network config correctly aside 3 valid nameserver IPs) and everything works fine. Then I try to log into the machine with the same address via ssh and I get a "Name or service not known".
Trying again, it works with a fully qualified name containing the suffix. I also had cases, when the IP wasn't resolved although I put in the fully qualified name. When I am more lucky, it starts working again with machine names only (without suffix, which is configured and worked perfectly up to now)

Is there probably a bug in the new Ubuntu Version?

Question information

English Edit question
Ubuntu gnome-nettool Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
cirrus (andreas-kahl) said :

Now this happened from Firefox and the Java Virtual Machine, too. In the beginning I thought this was shell-specific, but it isn't

Revision history for this message
actionparsnip (andrew-woodhead666) said :

If you run:

echo "nameserver" | sudo tee /etc/resolv.conf

Does it help?

Revision history for this message
tomx (tom-xitio) said :

No, it does not help. Names are still not resolved properly.

Revision history for this message
tomx (tom-xitio) said :

I had to restore values of our company network that i entered when on 11.10:

in /etc/resolv.conf:

domain int.snakeoil.com
search int.snakeoil.com ext.snakeoil.com com

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Does it work ok if you use your own manual settings?

Can you help with this problem?

Provide an answer of your own, or ask cirrus for more information if necessary.

To post a message you must log in.