Ubuntu

New 11.10 install wireless disabled by hardware switch

Asked by Rick Bryant on 2012-04-25

Hi all...hoping for some help here. I just installed 11.10 on an old laptop of mine. It's an HP Pavilion Dv2200 Series laptop with an Intel Pro/Wireless 2200 bg internal card. The wireless was working under Windows, but now it tells me that wireless is disabled by hardware switch. I have a toggle switch for wireless on the laptop, but it doesn't seem to be working. Here are the results from a couple of commands. Don't know if there's anything useful here or not. I also tried using a usb wireless to connect and get the same result which seems to indicate that it's probably not a driver issue, rather maybe a bios issue that's preventing the switch from being toggled on. Any help would be greatly appreciated. Thanks!

Rick

rick@rick:~$ sudo lshw -C network
  *-network:0 DISABLED
       description: Wireless interface
       product: PRO/Wireless 2200BG [Calexico2] Network Connection
       vendor: Intel Corporation
       physical id: 5
       bus info: pci@0000:06:05.0
       logical name: eth1
       version: 05
       serial: 00:15:00:24:d5:1a
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG:9.0.5.27 (Dec 12 2007) latency=128 link=no maxlatency=24 mingnt=3 multicast=yes wireless=IEEE 802.11bg
       resources: irq:20 memory:b0106000-b0106fff
  *-network:1
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 7
       bus info: pci@0000:06:07.0
       logical name: eth0
       version: 10
       serial: 00:0a:e4:d9:6e:75
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=10.203.0.18 latency=128 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:20 ioport:3000(size=256) memory:b0109400-b01094ff

rick@rick:~$ dmesg | grep ipw
[ 7.785070] libipw: 802.11 data/management/control stack, git-1.1.13
[ 7.785074] libipw: Copyright (C) 2004-2005 Intel Corporation <email address hidden>
[ 8.019916] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 8.019920] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 8.020043] ipw2200 0000:06:05.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[ 8.020071] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[ 9.986725] ipw2200: Radio Frequency Kill Switch is On:
[ 9.988932] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
[ 29.548028] ipw2200: Failed to send POWER_MODE: Command timed out.
[ 43.368021] ipw2200: Failed to send POWER_MODE: Command timed out.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-27
Last reply:
2012-05-13

In device manager, disable the ability for the wifi to wake up the system as well as disable power management in it. Your Windows OS is affecting the hardware.

Rick Bryant (rick-bryant) said : #2

Ubuntu is installed on the entire hard drive. There is no Windows installation. Booted with Hirens boot CD and tried to access device manager through Mini XP. No power management settings for the Wireless card. There are power management settings for ethernaet, but not wireless. Able to toggle wireless on and off. When booting back into Ubuntu, same message.

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.