Ubuntu

internet not working- network card issue???

Asked by mr lee on 2012-03-06

I recently had a UVerse modem installed from AT&T. when the tech left, both my machines (PC and Lap) were working perfect.

Within the next couple of days, the desktop would connect intermittenly (laptop was fine).

I would shut down the PC, reboot, and it would be fine. Then, it started failing after it was up and running, until finally, prob 4-5 days later, I got no connection AT ALL.

Laptop has been fine, no probs. Both machines are running 11.10, I have swapped ethernet cables, unplugged and replugged the modem, my system says "network cable unplugged"...but it ain't...

could my network card be bad?

Is there something else I can check, or a diagnostic i can run?

pls help, I know you guys (and girls) are the best!!! thanks in advance...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
mr lee
Solved:
2012-03-23
Last query:
2012-03-23
Last reply:
2012-03-19

Can you give the output of:

sudo lshw -C network; lsb_release -a; uname -a; sudo rfkill list

Thanks

mr lee (mrlee1953) said : #2

@actionparsnip- sadly, I can run the command and see the results...however, I have no way to "transfer" it to my laptop in order to send it...is there something in particular you are looking for? I may be able to "copy by hand" for you... thanks

Not got a USB stick, or can't bluetooth it to a phone or other storage device....

mr lee (mrlee1953) said : #4

@actionparsnip- yes, found one (why didnt *I* think of that)?

mrlee@mrlee-desktop:~$ sudo lshw -C network; lsb_release -a; uname -a;sudo rfkill list[sudo] password for mrlee:
DMI
  *-network:0 UNCLAIMED
       description: Ethernet controller
       product: RT8139 (B/C) Cardbus Fast Ethernet Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 9
       bus info: pci@0000:00:09.0
       version: 10
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=32 maxlatency=64 mingnt=32
  *-network:1
       description: Ethernet interface
       product: VT6102 [Rhine-II]
       vendor: VIA Technologies, Inc.
       physical id: 12
       bus info: pci@0000:00:12.0
       logical name: eth0
       version: 78
       serial: 00:14:85:1a:1a:88
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=via-rhine driverversion=1.5.0 duplex=half latency=64 link=no maxlatency=8 mingnt=3 multicast=yes port=MII speed=10Mbit/s
       resources: irq:23 ioport:c400(size=256) memory:ea002000-ea0020ff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux mrlee-desktop 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:50:54 UTC 2012 i686 athlon i386 GNU/Linux
mrlee@mrlee-desktop:~$
mrlee@mrlee-desktop:~$

mr lee (mrlee1953) said : #5

@actionparsnip- have you seen the info you requested me to send you?

Is it the via or the realtek?

mr lee (mrlee1953) said : #7

it is a new type modem/router from AT&T/U-verse. made by Pace Americas... model # 3801HGV...IS THERE ANY OTHER INFO U NEED?

Which interface do you have it connected to?

Does this help:
https://help.ubuntu.com/community/ADSLPPPoE

mr lee (mrlee1953) said : #9

I'm not sure what u mean...the old type of modem was powered by the phone line---this type apparently backfeeds into the phone line to power it...not sure how all that stuff works...by interface did u mean that it is running thru the phone line?

mr lee (mrlee1953) said : #10

I checked with the dpkg -s pppoeconf and it says it is installed...also says "priority optional"...

Well you have 2 Ethernet ports, which is the one being used?

mr lee (mrlee1953) said : #12

if U R referring to the computer, I only have 1 port, there are 4 ports in the modem, currently ports 1 & 3 are being used. I have tried plugging, unplugging, switching ports etc to no avail...(sorry for being dunce-like)

Your lshw says you have 2 ethernet ports:

    product: VT6102 [Rhine-II]
and
       product: RT8139 (B/C) Cardbus Fast Ethernet Adapter

The VIA one seems to have picked up as ok wheras the other has no driver (Hence the UNCLAIMED bit).

mr lee (mrlee1953) said : #14

...ok...i did locate the other... do u want me to connect to the other port and see if THAT one works? I'll shut down, switch and let you know... i hope i wont incur any damage by switching ports...(again, sorry for bein a doofus).........

mr lee (mrlee1953) said : #15

I plugged in to the other port, rebooted and still nothing...

mr lee (mrlee1953) said : #16

@actionparsnip- yesterday, I happened to look over at the desktop, and saw the internet arrows present. I wanted to wait a bit to make sure it didnt fail (again)...so far, the internet connection IS WORKING! I dont know if it was your suggestion about switching ports or not (it was not working when I initially switched)...wanted to let you know the update...thank you AGAIN for your assistance...