wireless connection issues - Very slow

Asked by Philipp Kober on 2012-03-05

Hi,
Just installed ubuntu 11.10 32bit and i got massive wifi problems.
When connected to wifi, my download speed is at about 5kb/s or somehting like that.
When connected via my wired connection, i gt normal speed (like i have with Windows 7 both via wifi and wired connction).

Please tell me which output u need to help me!

Hope sbdy can help me :)

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2012-03-06
Last reply:
2012-03-06

Can you give the output of:

sudo lshw -C network; lsb_release -a; uname -a; sudo rfkill list

Thanks

Philipp Kober (philipp-kober) said : #2

phil@d1asp0ra:~$ sudo lshw -C network
[sudo] password for phil:
  *-network
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: e0:b9:a5:ae:82:f9
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.0.0-16-generic-pae firmware=N/A ip=10.0.0.3 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:dea00000-dea0ffff
  *-network
       description: Ethernet interface
       product: AR8151 v2.0 Gigabit Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: c0
       serial: f4:6d:04:46:c6:fe
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full firmware=N/A latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:43 memory:de000000-de03ffff ioport:b000(size=128)
---------------------------------------------------------------------------------------------------------------------------------------------------------------------
phil@d1asp0ra:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
---------------------------------------------------------------------------------------------------------------------------------------------------------------------
phil@d1asp0ra:~$ uname -a
Linux d1asp0ra 3.0.0-16-generic-pae #29-Ubuntu SMP Tue Feb 14 13:56:31 UTC 2012 i686 i686 i386 GNU/Linux
---------------------------------------------------------------------------------------------------------------------------------------------------------------------
phil@d1asp0ra:~$ sudo rfkill list
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: asus-wlan: Wireless LAN
 Soft blocked: no
 Hard blocked: no

smil3y (smil3y) said : #3

try disable ipv6....

sudo gedit /etc/modprobe.d/bad_list

type:
alias net-pf-10 off
alias ipv6 off

comment all ipv6 in the /etc/sysctl.conf

then sysctl -p

If you run it all as one command, as I gave it, it will have been quicker and easier for you and there will be less probability of error. Please don't cut up commands. If they are on one line, copy the command as one line.

You could try disabling ipv6 with the boot option:

ipv6.disable=1

or try:

cd; wget http://dl.dropbox.com/u/8850924/sysctl; cat ./sysctl | sudo tee -a /etc/sysctl.conf; sudo sysctl -p; rm ./sysctl

May help

Philipp Kober (philipp-kober) said : #5

created the bad_list file, didnt have to comment anything out in /etc/sysctl.conf because everything in this file was anyway commented!

rebootet but i still got the same problem, so nothing changed...

Thank you anyways. Any other ideas?

Philipp Kober (philipp-kober) said : #6

created the bad_list file, didnt have to comment anything out in /etc/sysctl.conf because everything in this file was anyway commented!

rebootet but i still got the same problem, so nothing changed...

Thank you anyways. Any other ideas?

Philipp Kober (philipp-kober) said : #7

phil@d1asp0ra:~$ cd; wget http://dl.dropbox.com/u/8850924/sysctl; cat ./sysctl | sudo tee -a /etc/sysctl.conf; sudo sysctl -p; rm ./sysctl
--2012-03-05 16:57:54-- http://dl.dropbox.com/u/8850924/sysctl
Auflösen des Hostnamen »dl.dropbox.com«... 174.129.254.86, 107.22.210.127, 50.17.217.128, ...
Verbindungsaufbau zu dl.dropbox.com|174.129.254.86|:80... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 455 [text/plain]
In »»sysctl«« speichern.

100%[======================================>] 455 --.-K/s in 0s

2012-03-05 16:57:55 (26.3 MB/s) - »»sysctl«« gespeichert [455/455]

[sudo] password for phil:
net.core.rmem_default = 524288
net.core.rmem_max = 524288
net.core.wmem_default = 524288
net.core.wmem_max = 524288
net.ipv4.tcp_wmem = 4096 87380 524288
net.ipv4.tcp_rmem = 4096 87380 524288
net.ipv4.tcp_mem = 524288 524288 524288
net.ipv4.tcp_rfc1337 = 1
net.ipv4.ip_no_pmtu_disc = 0
net.ipv4.tcp_sack = 1
net.ipv4.tcp_fack = 1
net.ipv4.tcp_window_scaling = 1
net.ipv4.tcp_timestamps = 1
net.ipv4.tcp_ecn = 0
net.ipv4.route.flush = 1
vm.swappiness = 10
net.core.rmem_default = 524288
net.core.rmem_max = 524288
net.core.wmem_default = 524288
net.core.wmem_max = 524288
net.ipv4.tcp_wmem = 4096 87380 524288
net.ipv4.tcp_rmem = 4096 87380 524288
net.ipv4.tcp_mem = 524288 524288 524288
net.ipv4.tcp_rfc1337 = 1
net.ipv4.ip_no_pmtu_disc = 0
net.ipv4.tcp_sack = 1
net.ipv4.tcp_fack = 1
net.ipv4.tcp_window_scaling = 1
net.ipv4.tcp_timestamps = 1
net.ipv4.tcp_ecn = 0
net.ipv4.route.flush = 1
vm.swappiness = 10

--------------------------------------------------------------------------------------------------------------------

did not know where to disable ipv6 in the boot option!
but also after a reboot the second option didnt change anything :(

any more ideas?

run:

gksudo gedit /etc/default/grub

change this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

To:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash ipv6.disable=1"

Save the new file, close gedit and run:
sudo update-grub

reboot to test. Nobody is born knowing how to disable ipv6 using boot options but there are plenty of guides around.With some very simple websearching you could have found this out.....

Philipp Kober (philipp-kober) said : #9

sorry, i just wanted to make everything right / according to your guidance....

i changed the boot options as you said, but it didnt help, still extremely slow internet speed while on wireless...

Philipp Kober (philipp-kober) said : #10

has anybody got more ideas that could possibly help? i just dont know what to do...

Ubfan (ubfan1) said : #11

Could be interference with other wireless access points.
Please run:
sudo iwlist scan |egrep "Channel:|Quality=|ESSID:"
and post back here.
If you see too many networks on your channel which are of a quality near your's, change your channel. Only channels 1, 6, and 11 do not overlap to some degree.

Philipp Kober (philipp-kober) said : #12

the output is:

phil@d1asp0ra:~$ sudo iwlist scan |egrep "Channel:|Quality=|ESSID:"
[sudo] password for phil:
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

                    Channel:11
                    Quality=31/70 Signal level=-79 dBm
                    ESSID:"ThomsonC24304"
                    Channel:6
                    Quality=56/70 Signal level=-54 dBm
                    ESSID:"NerdRage"
                    Channel:11
                    Quality=32/70 Signal level=-78 dBm
                    ESSID:"PBS-5FCB6D"

should i cange channel? how do I do so? does it make sense to change?

anybody else got any ideas?

Ubfan (ubfan1) said : #13

If your network is "NerdRage" on channel 6 you are OK. If you are one of the channel 11 networks, change to channel 1. Change channels by logging into the wireless router (usually enough to point your browser to
192.168.0.1 or whatever IP your router is set to). Also look into repositioning your antennas, your signal is very weak (if you are on channel 11).

Philipp Kober (philipp-kober) said : #14

im on NerdRage.

Has anybody got an idea what could help? i already did all of the things proposed to me in this thread....

Philipp Kober (philipp-kober) said : #16

ok i found out that the problem is my router i guess, because on an other WiFi network i got normal internet speed -

can anybody help me? what could i do?

Can you help with this problem?

Provide an answer of your own, or ask Philipp Kober for more information if necessary.

To post a message you must log in.