Ubuntu

iwl3945 disconnects, network-manager shows connected, 12.04 beta 1

Asked by mconley3 on 2012-03-04

I have a laptop with a PRO/Wireless 3945ABG network controller.

I installed 11.04 and then 11.10.

After installing 11.10, I started having problems with the network connection dropping, I would have to disable networking and reenable networking to get it to work again.

Note, it was a little flaky on 11.04 too but worked.

Network Manager would always show connected, even though I could not ping the router.

I tried everything I found in the different forums, but it never really fixed the problems.

I decided to wait for 12.04 and was pleased when I tried alpha 2.

The network connection stayed working, it would drop and reconnect every so often, and network manager would show the drop and reconnect, but it wasn't too intrusive.

I've just updated to beta 1 and now its back to dropping the connection with network manager still showing the connection is there.

I can get it to connect again, but it will only work for a few minutes.

I've never posted a bug on launchpad but I can pull lshw, lspci, iwconfig, rfkill info.

I'll just have to hardwire the network connection to get it posted.

Mark

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2012-03-04
Last reply:
2012-07-04
mconley3 (mconley3) said : #1

lshw:
 *-network
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 02
       serial: 00:1c:bf:7e:b8:06
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 driverversion=3.2.0-17-generic-pae firmware=15.32.2.9 ip=192.168.2.107 latency=0 link=yes multicast=yes wireless=IEEE 802.11abg
       resources: irq:45 memory:d6000000-d6000fff

lspci:
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Radeon Mobility X1400
02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controller
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
04:09.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
04:09.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
04:09.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)

iwconfig:
lo no wireless extensions.

wlan0 IEEE 802.11abg ESSID:"Cheese"
          Mode:Managed Frequency:2.457 GHz Access Point: 00:22:2D:BD:0A:1D
          Bit Rate=54 Mb/s Tx-Power=15 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=62/70 Signal level=-48 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:60 Missed beacon:0

eth0 no wireless extensions.

rfkill:
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

mconley3 (mconley3) said : #2

The network seems to cut out most when downloading larger files, not as much when just using the internet. When I try to install with software center or synaptic is when the network will close. I can switch the hardware switch off and on and reconnect. Here is what goes to the syslog when the connection is lost.

Mar 4 10:39:27 lightsaber kernel: [ 7982.820130] iwl3945 0000:03:00.0: Queue 2 stuck for 2000 ms.
Mar 4 10:39:27 lightsaber kernel: [ 7982.820139] iwl3945 0000:03:00.0: On demand firmware reload
Mar 4 10:39:27 lightsaber kernel: [ 7982.870982] ieee80211 phy0: Hardware restart was requested

I suggest you report a bug.Precise is not ready and not stable.

I believe your wireless card is experiencing the following bug, for which there is currently no solution yet:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/903437

mconley3 (mconley3) said : #5

looks very similar, may be the same. However mine never reconnects. I have to flip the hardware switch off and on. I'm not familar with the bug system, will this get linked to the existing bug so my issue is taken into account also?

Thanks,
Mark

mconley3 (mconley3) said : #6

hmm, looks like it is linked in some way. I'll try to subscribe to the bug so I know when or if this get fixed. The laptop is not useable as it is.

If you need a stable OS then use Oneiric. If you are happy to continue with instability, bugs and feature holes but are happy to log bugs then keep Precise.

You are using PRERELEASE software. It is not finished and not stable. What did you exactly expect????

mconley3 (mconley3) said : #8

This has been a problem since 11.10. Read my comments and read the bug that has been associated with this. It was opened against 11.10. I've waited for 12.04 in hopes that the problem would be resolved and it wasn't. I choose to take the time to report the bug, with expectations that I would help resolve the issue, if only by testing.

I'm not sure what your perception of what I expect is, but it is obviously wrong. I never complain about open source software, espesially if I don't contribute. I this case of choosen to try and help where I can.

If it would calm you down, I'll reinstall 11.10 and rereport the bug.

Voronin Viktor (wizard-wcs) said : #9

3.4.0-030400 also affected

Did you try disabling n speed with module options?

Can you help with this problem?

Provide an answer of your own, or ask mconley3 for more information if necessary.

To post a message you must log in.