ubuntu 11.10 not able to access Internet

Asked by Jeanette Hall on 2011-12-19

My only way to get to the Internet with my computer is by using my wireless connection. It connects fine with Windows 7, but ubuntu doesn't seem to find the connection. It is Dell INSPIRON 1545.
I tried following the directions given be the web page, but I kept getting the response that it couldn't be installedon my machine,because it required an i386. I allways thought my laptop was an i386.

Here is some information on my system I gathered for your trouble shooters previosly. It was gathered using the root account.

To run a command as administrator (user "root"), use "sudo <command>".
jhall@ubuntu:~$ apt-get update; apt-get install hwinfo grep; lshw -C network; rfkill list; iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|ireless|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt5|rt6|rt7|usb|witch|wl';dmidecode|egrep 'anufact|roduct|erial|elease'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|wmi|witch|wl'; cat /var/lib/NetworkManager/NetworkManager.state; o hwinfo --netcard ; ps -aux|egrep 'icd|etwork'; lsmod
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
WARNING: you should run this program as super-user.
  *-network
       description: Network controller
       product: BCM4312 802.11b/g LP-PHY
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0c:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:17 memory:f69fc000-f69fffff
  *-network
       description: Ethernet interface
       product: 88E8040 PCI-E Fast Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 13
       serial: 00:25:64:80:b5:8b
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.28 firmware=N/A latency=0 multicast=yes port=twisted pair
       resources: irq:45 memory:f68fc000-f68fffff ioport:de00(size=256)
  *-network DISABLED
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 70:1a:04:aa:c7:ce
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=3.0.0-12-generic firmware=N/A multicast=yes wireless=IEEE 802.11bg
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Failed to read scan data : Network is down

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 [8086:2944] (rev 03)
00:1c.4 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 [8086:2948] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation ICH9M/M-E SATA AHCI Controller [8086:2929] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
09:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller [11ab:4354] (rev 13)
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0c45:63ee Microdia
Bus 007 Device 002: ID 0461:4d4c Primax Electronics, Ltd
WARNING: you should run this program as super-user.
H/W path Device Class Description
==============================================
                       system Computer
/0 bus Motherboard
/0/0 memory 3922MiB System memory
/0/1 processor Pentium(R) Dual-Core CPU T4400 @ 2.20GHz
/0/100 bridge Mobile 4 Series Chipset Memory Controller Hub
/0/100/2 display Mobile 4 Series Chipset Integrated Graphics Controller
/0/100/2.1 display Mobile 4 Series Chipset Integrated Graphics Controller
/0/100/1a bus 82801I (ICH9 Family) USB UHCI Controller #4
/0/100/1a.1 bus 82801I (ICH9 Family) USB UHCI Controller #5
/0/100/1a.2 bus 82801I (ICH9 Family) USB UHCI Controller #6
/0/100/1a.7 bus 82801I (ICH9 Family) USB2 EHCI Controller #2
/0/100/1b multimedia 82801I (ICH9 Family) HD Audio Controller
/0/100/1c bridge 82801I (ICH9 Family) PCI Express Port 1
/0/100/1c.1 bridge 82801I (ICH9 Family) PCI Express Port 2
/0/100/1c.1/0 network BCM4312 802.11b/g LP-PHY
/0/100/1c.2 bridge 82801I (ICH9 Family) PCI Express Port 3
/0/100/1c.2/0 eth0 network 88E8040 PCI-E Fast Ethernet Controller
/0/100/1c.4 bridge 82801I (ICH9 Family) PCI Express Port 5
/0/100/1d bus 82801I (ICH9 Family) USB UHCI Controller #1
/0/100/1d.1 bus 82801I (ICH9 Family) USB UHCI Controller #2
/0/100/1d.2 bus 82801I (ICH9 Family) USB UHCI Controller #3
/0/100/1d.7 bus 82801I (ICH9 Family) USB2 EHCI Controller #1
/0/100/1e bridge 82801 Mobile PCI Bridge
/0/100/1f bridge ICH9M LPC Interface Controller
/0/100/1f.2 storage ICH9M/M-E SATA AHCI Controller
/0/100/1f.3 bus 82801I (ICH9 Family) SMBus Controller
/1 wlan0 network Wireless interface
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
Linux ubuntu 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
[ 0.000000] No AGP bridge found
[ 0.000000] No NUMA configuration found
[ 0.000000] No AGP bridge found
[ 0.208138] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 0.272499] ACPI: No dock devices found.
[ 0.272503] HEST: Table not found.
[ 0.334173] usbcore: registered new interface driver usbfs
[ 0.334183] usbcore: registered new interface driver hub
[ 0.334212] usbcore: registered new device driver usb
[ 0.340146] Switching to clocksource hpet
[ 0.343670] Switched to NOHz mode on CPU #0
[ 0.343706] Switched to NOHz mode on CPU #1
[ 0.379252] pnp: PnP ACPI: found 13 devices
[ 0.457529] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input0
[ 0.458825] ACPI: Lid Switch [LID]
[ 0.479301] ERST: Table is not found!
[ 0.644127] hub 1-0:1.0: USB hub found
[ 0.664129] hub 2-0:1.0: USB hub found
[ 0.664447] hub 3-0:1.0: USB hub found
[ 0.664717] hub 4-0:1.0: USB hub found
[ 0.664964] hub 5-0:1.0: USB hub found
[ 0.665217] hub 6-0:1.0: USB hub found
[ 0.665467] hub 7-0:1.0: USB hub found
[ 0.665715] hub 8-0:1.0: USB hub found
[ 0.716819] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.879706] b43-pci-bridge 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 0.879724] b43-pci-bridge 0000:0c:00.0: setting latency timer to 64
[ 0.891735] sky2 0000:09:00.0: eth0: addr 00:25:64:80:b5:8b
[ 0.896334] ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x16, vendor 0x4243)
[ 0.896353] ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x0F, vendor 0x4243)
[ 0.896371] ssb: Core 2 found: PCMCIA (cc 0x80D, rev 0x0A, vendor 0x4243)
[ 0.896388] ssb: Core 3 found: PCI-E (cc 0x820, rev 0x09, vendor 0x4243)
[ 0.976057] usb 1-5: new high speed USB device number 2 using ehci_hcd
[ 0.980368] ssb: Sonics Silicon Backplane found on PCI device 0000:0c:00.0
[ 1.125768] usbcore: registered new interface driver uas
[ 1.236063] usb 1-6: new high speed USB device number 3 using ehci_hcd
[ 1.880063] usb 7-1: new low speed USB device number 2 using uhci_hcd
[ 2.261047] usbcore: registered new interface driver usb-storage
[ 2.274608] usb 1-5: USB disconnect, device number 2
[ 2.278503] scsi6 : usb-storage 1-5:1.0
[ 2.278645] usbcore: registered new interface driver ums-realtek
[ 2.287815] input: Primax Electronics Dynex Wireless Optical Mouse as /devices/pci0000:00/0000:00:1d.1/usb7/7-1/7-1:1.0/input/input4
[ 2.288019] generic-usb 0003:0461:4D4C.0001: input,hiddev0,hidraw0: USB HID v1.10 Mouse [Primax Electronics Dynex Wireless Optical Mouse] on usb-0000:00:1d.1-1/input0
[ 2.288041] usbcore: registered new interface driver usbhid
[ 2.288043] usbhid: USB HID core driver
[ 22.962951] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
[ 23.098025] Registered led device: b43-phy0::tx
[ 23.099022] Registered led device: b43-phy0::rx
[ 23.099086] Registered led device: b43-phy0::radio
[ 23.099134] Broadcom 43xx driver loaded [ Features: PNL, Firmware-ID: FW13 ]
[ 23.358263] uvcvideo: Found UVC 1.00 device Integrated_Webcam_1.3M (0c45:63ee)
[ 23.384909] input: Integrated_Webcam_1.3M as /devices/pci0000:00/0000:00:1a.7/usb1/1-6/1-6:1.0/input/input5
[ 23.385028] usbcore: registered new interface driver uvcvideo
[ 23.686637] Console: switching to colour frame buffer device 170x48
[ 23.746102] [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.
[ 23.800966] input: HDA Intel Mic at Ext Right Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[ 23.801104] input: HDA Intel HP Out at Ext Right Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
[ 29.337881] type=1400 audit(1322076582.119:9): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/mission-control-5" pid=842 comm="apparmor_parser"
[ 29.338204] type=1400 audit(1322076582.119:10): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/telepathy-*" pid=842 comm="apparmor_parser"
[ 29.393514] lp: driver loaded but no devices found
[ 29.597951] b43-phy0 ERROR: Firmware file "b43/ucode15.fw" not found
[ 29.597955] b43-phy0 ERROR: Firmware file "b43-open/ucode15.fw" not found
[ 29.597958] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
[ 29.603971] sky2 0000:09:00.0: eth0: enabling interface
[ 29.604584] ADDRCONF(NETDEV_UP): eth0: link is not ready
/dev/mem: Permission denied
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:on

install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist uart6850
blacklist twl4030_wdt

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true
o: command not found
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 840 0.0 0.1 162548 5384 ? Ssl 13:29 0:00 NetworkManager
jhall 2761 0.0 0.0 7964 888 pts/0 S+ 13:46 0:00 egrep --color=auto icd|etwork
Module Size Used by
nls_utf8 12557 1
udf 93640 1
crc_itu_t 12707 1 udf
bnep 18436 2
rfcomm 47946 0
bluetooth 166112 10 bnep,rfcomm
parport_pc 36962 0
ppdev 17113 0
lp 17799 0
parport 46562 3 parport_pc,ppdev,lp
binfmt_misc 17540 1
snd_hda_codec_idt 70553 1
joydev 17693 0
dell_wmi 12681 0
sparse_keymap 13890 1 dell_wmi
snd_hda_intel 33390 6
snd_hda_codec 104802 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 13668 1 snd_hda_codec
snd_pcm 96755 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 13324 0
uvcvideo 72711 0
videodev 93004 1 uvcvideo
snd_rawmidi 30547 1 snd_seq_midi
v4l2_compat_ioctl32 17083 1 videodev
dell_laptop 13831 0
dcdbas 14490 1 dell_laptop
snd_seq_midi_event 14899 1 snd_seq_midi
snd_seq 61896 2 snd_seq_midi,snd_seq_midi_event
arc4 12529 2
snd_timer 29991 2 snd_pcm,snd_seq
i915 566711 7
snd_seq_device 14540 3 snd_seq_midi,snd_rawmidi,snd_seq
b43 341198 0
psmouse 73882 0
mac80211 310872 1 b43
serio_raw 13166 0
drm_kms_helper 42558 1 i915
snd 68266 21 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
drm 236330 8 i915,drm_kms_helper
soundcore 12680 1 snd
cfg80211 199587 2 b43,mac80211
snd_page_alloc 18529 2 snd_hda_intel,snd_pcm
i2c_algo_bit 13423 1 i915
wmi 19256 1 dell_wmi
video 19412 1 i915
usbhid 47198 0
ums_realtek 13272 0
usb_storage 57901 1 ums_realtek
hid 95463 1 usbhid
uas 18027 0
ahci 26002 2
libahci 26861 1 ahci
ssb 52752 1 b43
sky2 58674 0
jhall@ubuntu:~$

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Jeanette Hall
Solved:
2012-01-13
Last query:
2012-01-13
Last reply:
2012-01-09
peter b (b1pete) said : #1

Jeanette,

pls run cmds described above as instructed .....'run a command as administrator (user "root"), use "sudo <command>".'.... or in other words, in summary, it would be something like

jhall@ubuntu:~$ sudo apt-get update; apt-get install h.....................................

pls note

sudo

at the very beginning of cmds listed.

The information I pasted when I opened this question was obtained using the root account. I don't know why it has problems accessing files. Probably the same reason I can't use the sudo commands on my personal user ID.

When I try downloading a copy ofthe firmware from http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware my laptop doesn't seem to accept the upgrade.

José Antonio Rey (jose) said : #4

Please, try again. Maybe there was any other program using root privileges.

I've tried it several times. Result is always the same.

On 12/19/11, José Antonio Rey <email address hidden> wrote:
> Your question #182319 on gnome-nettool in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/182319
>
> Status: Open => Needs information
>
> José Antonio Rey requested more information:
> Please, try again. Maybe there was any other program using root
> privileges.
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/182319
>
> You received this question notification because you asked the question.
>

Created a new user ID in ubuntu,and ran commands again. Got new
response. It wanted to connect to Internet to download files. It
would be nice if I could get to the, but that's the problem in the
first place.

On 12/21/11, Jeanette Hall <email address hidden> wrote:
> Your question #182319 on gnome-nettool in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/182319
>
> Status: Needs information => Open
>
> You gave more information on the question:
> I've tried it several times. Result is always the same.
>
> On 12/19/11, José Antonio Rey <email address hidden> wrote:
>> Your question #182319 on gnome-nettool in Ubuntu changed:
>> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/182319
>>
>> Status: Open => Needs information
>>
>> José Antonio Rey requested more information:
>> Please, try again. Maybe there was any other program using root
>> privileges.
>>
>> --
>> To answer this request for more information, you can either reply to
>> this email or enter your reply at the following page:
>> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/182319
>>
>> You received this question notification because you asked the question.
>>
>
> --
> You received this question notification because you asked the question.
>

Tried working with my laptop again today. Using the new account I set up yesterday, it is now giving me errors about failing to access arcives. I can't copy the exact errors to send you guys without wasting another DVD. I'm getting to the point of runnung out of them.

Launchpad Janitor (janitor) said : #8

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

José Antonio Rey (jose) said : #9

Have you tried to MD5 check the CD that you used to install Ubuntu? Maybe the problem is in ubiquity, and not in your PC.

How do you MD5 check a CD?

Tried to learn how to MD5 check a CD, but the only tools I could find were for Windows, nothing for ubuntu.

Tried checking the MD5 file in my copied DVD of ununtu and it failed. 3 copies and all failed. Should copying the files onto a DVD instead of a CD be causing the problem?

Made CD this time, it failed too! I didn't think there should have been any difference,but I thought it was worth the try. I've been downloading it from the ubuntu web site,so I don't know where to look now.

I give up. I've got an official ubuntu CD on order. It should be here some time next week.