11.10 can't find my network

Asked by crazyputer on 2011-10-16

I upgraded my main system to 11.10 after some problems and asking some questions I got my system working but I couldn't get the network to go.

I have tried to set the IP addresses manually but that hasn't worked

It appears that 11.10 hasn't found the network card I'm not sure what to do to check that 11.10 has found the network card

Realtek R8111/8168B Network Card
On board Giga-Byte Motherboard
DSl Modem
DSL-502T
Network Switch
DGS-1008D

I have now spent many hours working on the system trying any suggestion I could find none have got the network to work. I'm currently updating my backups, then planning to do a reinstall from a Live CD.

Here are some of the functions I have tried.

lspci showed that the network exists

route I don't know what is missing or what should be there

I went to the realtek website and downloaded their drivers
that didn't do anything

I typed in this command
sudo lshw -C network;lsb_release -a; sudo rfkill list
This is the results
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 03
       serial: 1c:6f:65:2d:0f:4e
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168d-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:42 ioport:ce00(size=256) memory:fdfff000-fdffffff memory:fdff8000-fdffbfff memory:fdf00000-fdf1ffff
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

so I'm now stuck I've been using Ubuntu since 8.04 and I like it. I want to use Ubuntu in the new business I'm starting which within 12 months will be needing over 1000 computers + Servers but this is not giving me the confidence I really need to recommend Ubuntu as the O/S for the business.

I really want to solve this problem but need some help

Cheers Tony

Question information

Evan Burkitt (ubuntu-burkitt) said : #1

My network failed to come up after the initial reboot due to a failure of the dbus service during bootup. This caused a number of things to fail to initialize, among them my NIC's driver.

Take a look in the dmesg log for any references to 'dbus' (run 'dmesg | grep -i dbus' from a shell prompt, or just open /var/log/dmesg in a text editor and search). If you find them, they are error output and an indication that this bug [https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/811441] (linked above in 'Related bugs') is the culprit.

Post #24 at that link gives a clear description of a fix. The bad news is it's a bit tricky, but nothing a reasonably technical person can't work through. Feel free to read the other posts, as well as the bug of which #811441 is considered a duplicate, as other solutions may be posted over time.

NO THIS DIDN'T WORK

My system is running without the network

When I reboot the lights on my network switch tell me it has connected to the computer briefly then the O/S starts to boot and the connection is lost.

In system settings under network the cable is unplugged

I have now been trying to fix these problems for 2 days I need a stable reliable system and my wife needs her Windows 7 laptop back
I'm going to reinstall 11.04 from DVD

This takes me back to the DOS 1 - 6.1 days if linux is going to take over the world then we need to get things right. I now realise that I have lost much my programming skills by not using anything more than I needed and becoming a point & click person.

The Network card isn't working with any Ubuntu now

Can you help with this problem?

Provide an answer of your own, or ask crazyputer for more information if necessary.

To post a message you must log in.