Wireless adapter won't turn on on my Inspiron 1501

Asked by Jeff Gibson on 2011-09-21

I have very little experience with any operating system other than windows. I recently installed Ubuntu 11.04 on my Dell Inspiron 1501. I'm showing that my broadcom drivers are installed but can not get my wireless to work at all, wired works fine. The wifi light above my keyboard is not on and i'm assuming it's not turning on, i've tried to Fn +F2, uninstall the driver and reinstall. Restarting the computer, and making sure everything is up to date and i've gotten nowhere. Any help is appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2011-09-21
Last reply:
2011-09-21
thelinuxfan (arparp3733) said : #1

Fire up terminal and try issuing this command:-
             sudo rfkill unblock all

Let me know about the status.

Thanks & Regards,
arparp3733

Please first connect your wired network adapter to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1:

If you are using the Gnome interface, open the Terminal console via "Applications->Accessories->Terminal"

If you are using the Unity interface, the easiest way to open the Terminal is to use the 'search' function on the dash. Or you can click on the 'More Apps' button, click on the 'See more results' by the installed section, and find it in that list of applications. A third way, available after you click on the 'More Apps' button, is to go to the search bar, and see that the far right end of it says 'All Applications'. You then click on that, and you'll see the full list. Then you can go to Accessories > Terminal after that.

So the methods in Unity are:
Dash > Search for Terminal
Dash > More Apps > 'See More Results' > Terminal
Dash > More Apps > Accessories > Terminal

Step 2: Please copy-paste the following command from https://help.ubuntu.com/community/WirelessTroubleshootingProcedure in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word lsmod. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|ireless|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt5|rt6|rt7|usb|witch|wl';sudo dmidecode|egrep 'Manufact|Product'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|wmi|witch|wl'; cat /var/lib/NetworkManager/NetworkManager.state; sudo hwinfo --netcard ; ps -aux|egrep 'icd|etwork'; sudo lsmod

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Jeff Gibson (bleepit84) said : #3

arparp3733,
That did nothing

Jeff Gibson (bleepit84) said : #4

Mark,

Ign http://us.archive.ubuntu.com natty InRelease
Ign http://us.archive.ubuntu.com natty-updates InRelease
Ign http://extras.ubuntu.com natty InRelease
Ign http://security.ubuntu.com natty-security InRelease
Hit http://us.archive.ubuntu.com natty Release.gpg
Get:1 http://extras.ubuntu.com natty Release.gpg [72 B]
Get:2 http://security.ubuntu.com natty-security Release.gpg [198 B]
Get:3 http://us.archive.ubuntu.com natty-updates Release.gpg [198 B]
Hit http://extras.ubuntu.com natty Release
Get:4 http://security.ubuntu.com natty-security Release [31.4 kB]
Hit http://us.archive.ubuntu.com natty Release
Get:5 http://us.archive.ubuntu.com natty-updates Release [31.4 kB]
Hit http://extras.ubuntu.com natty/main Sources
Get:6 http://security.ubuntu.com natty-security/main Sources [68.7 kB]
Hit http://extras.ubuntu.com natty/main i386 Packages
Ign http://extras.ubuntu.com natty/main TranslationIndex
Hit http://us.archive.ubuntu.com natty/main Sources
Hit http://us.archive.ubuntu.com natty/restricted Sources
Hit http://us.archive.ubuntu.com natty/universe Sources
Hit http://us.archive.ubuntu.com natty/multiverse Sources
Hit http://us.archive.ubuntu.com natty/main i386 Packages
Hit http://us.archive.ubuntu.com natty/restricted i386 Packages
Hit http://us.archive.ubuntu.com natty/universe i386 Packages
Hit http://us.archive.ubuntu.com natty/multiverse i386 Packages
Ign http://us.archive.ubuntu.com natty/main TranslationIndex
Ign http://us.archive.ubuntu.com natty/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com natty/restricted TranslationIndex
Ign http://us.archive.ubuntu.com natty/universe TranslationIndex
Get:7 http://us.archive.ubuntu.com natty-updates/main Sources [107 kB]
Get:8 http://security.ubuntu.com natty-security/restricted Sources [14 B]
Get:9 http://security.ubuntu.com natty-security/universe Sources [11.3 kB]
Get:10 http://security.ubuntu.com natty-security/multiverse Sources [650 B]
Get:11 http://security.ubuntu.com natty-security/main i386 Packages [182 kB]
Ign http://extras.ubuntu.com natty/main Translation-en_US
Ign http://extras.ubuntu.com natty/main Translation-en
Get:12 http://us.archive.ubuntu.com natty-updates/restricted Sources [753 B]
Get:13 http://us.archive.ubuntu.com natty-updates/universe Sources [27.0 kB]
Get:14 http://us.archive.ubuntu.com natty-updates/multiverse Sources [1,890 B]
Get:15 http://us.archive.ubuntu.com natty-updates/main i386 Packages [323 kB]
Get:16 http://security.ubuntu.com natty-security/restricted i386 Packages [14 B]
Get:17 http://security.ubuntu.com natty-security/universe i386 Packages [38.6 kB]
Get:18 http://security.ubuntu.com natty-security/multiverse i386 Packages [2,071 B]
Ign http://security.ubuntu.com natty-security/main TranslationIndex
Ign http://security.ubuntu.com natty-security/multiverse TranslationIndex
Ign http://security.ubuntu.com natty-security/restricted TranslationIndex
Ign http://security.ubuntu.com natty-security/universe TranslationIndex
Get:19 http://us.archive.ubuntu.com natty-updates/restricted i386 Packages [839 B]
Get:20 http://us.archive.ubuntu.com natty-updates/universe i386 Packages [94.5 kB]
Get:21 http://us.archive.ubuntu.com natty-updates/multiverse i386 Packages [4,258 B]
Ign http://us.archive.ubuntu.com natty-updates/main TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/restricted TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/universe TranslationIndex
Ign http://security.ubuntu.com natty-security/main Translation-en_US
Ign http://security.ubuntu.com natty-security/main Translation-en
Ign http://security.ubuntu.com natty-security/multiverse Translation-en_US
Ign http://security.ubuntu.com natty-security/multiverse Translation-en
Ign http://security.ubuntu.com natty-security/restricted Translation-en_US
Ign http://security.ubuntu.com natty-security/restricted Translation-en
Ign http://security.ubuntu.com natty-security/universe Translation-en_US
Ign http://security.ubuntu.com natty-security/universe Translation-en
Ign http://us.archive.ubuntu.com natty/main Translation-en_US
Ign http://us.archive.ubuntu.com natty/main Translation-en
Ign http://us.archive.ubuntu.com natty/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com natty/multiverse Translation-en
Ign http://us.archive.ubuntu.com natty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com natty/restricted Translation-en
Ign http://us.archive.ubuntu.com natty/universe Translation-en_US
Ign http://us.archive.ubuntu.com natty/universe Translation-en
Ign http://us.archive.ubuntu.com natty-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/main Translation-en
Ign http://us.archive.ubuntu.com natty-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/multiverse Translation-en
Ign http://us.archive.ubuntu.com natty-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/restricted Translation-en
Ign http://us.archive.ubuntu.com natty-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/universe Translation-en
Fetched 925 kB in 7s (129 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
The following extra packages will be installed:
  libhal1 libhd16
The following NEW packages will be installed:
  hwinfo libhal1 libhd16
0 upgraded, 3 newly installed, 0 to remove and 9 not upgraded.
Need to get 818 kB of archives.
After this operation, 2,269 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com/ubuntu/ natty/universe libhal1 i386 0.5.14-5+svn1 [74.4 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ natty/universe libhd16 i386 16.0-2 [698 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ natty/universe hwinfo i386 16.0-2 [46.1 kB]
Fetched 818 kB in 3s (219 kB/s)
Selecting previously deselected package libhal1.
(Reading database ... 157423 files and directories currently installed.)
Unpacking libhal1 (from .../libhal1_0.5.14-5+svn1_i386.deb) ...
Selecting previously deselected package libhd16.
Unpacking libhd16 (from .../libhd16_16.0-2_i386.deb) ...
Selecting previously deselected package hwinfo.
Unpacking hwinfo (from .../hwinfo_16.0-2_i386.deb) ...
Processing triggers for man-db ...
Setting up libhal1 (0.5.14-5+svn1) ...
Setting up libhd16 (16.0-2) ...
Setting up hwinfo (16.0-2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
  *-network
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:18 memory:c0200000-c0203fff
  *-network
       description: Ethernet interface
       product: BCM4401-B0 100Base-TX
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: eth0
       version: 02
       serial: 00:19:b9:51:21:e3
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=full ip=192.168.1.115 latency=64 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:21 memory:c0300000-c0301fff
0: dell-wifi: Wireless LAN
 Soft blocked: yes
 Hard blocked: yes
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
00:00.0 Host bridge [0600]: ATI Technologies Inc RS480 Host Bridge [1002:5950] (rev 10)
00:01.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a3f]
00:05.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a37]
00:06.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a38]
00:12.0 SATA controller [0106]: ATI Technologies Inc SB600 Non-Raid-5 SATA [1002:4380]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI0) [1002:4387]
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI1) [1002:4388]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI2) [1002:4389]
00:13.3 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI3) [1002:438a]
00:13.4 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI4) [1002:438b]
00:13.5 USB Controller [0c03]: ATI Technologies Inc SB600 USB Controller (EHCI) [1002:4386]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 13)
00:14.1 IDE interface [0101]: ATI Technologies Inc SB600 IDE [1002:438c]
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB600 PCI to LPC Bridge [1002:438d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS482 [Radeon Xpress 200M] [1002:5975]
05:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
08:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX [14e4:170c] (rev 02)
08:01.0 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 19)
08:01.1 System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev 01)
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
========================================================
                                 system Portable Computer
/0 bus 0UW744
/0/1 memory 105KiB BIOS
/0/5 processor AMD Turion(tm) 64 Mobile Technology
/0/5/6 memory 512KiB L2 cache
/0/5/0 memory 128KiB L1 cache
/0/5/1 memory 512KiB L2 cache
/0/19 memory 1GiB System Memory
/0/19/0 memory 512MiB DIMM DRAM Synchronous
/0/19/1 memory 512MiB DIMM DRAM Synchronous
/0/100 bridge RS480 Host Bridge
/0/100/1 bridge RS480 PCI Bridge
/0/100/1/5 display RS482 [Radeon Xpress 200M]
/0/100/5 bridge RS480 PCI Bridge
/0/100/6 bridge RS480 PCI Bridge
/0/100/6/0 network BCM4311 802.11b/g WLAN
/0/100/12 scsi2 storage SB600 Non-Raid-5 SATA
/0/100/12/0.0.0 /dev/sda disk 60GB SAMSUNG HM060HI
/0/100/12/0.0.0/1 /dev/sda1 volume 55GiB EXT4 volume
/0/100/12/0.0.0/2 /dev/sda2 volume 893MiB Extended partition
/0/100/12/0.0.0/2/5 /dev/sda5 volume 893MiB Linux swap / Solaris partiti
/0/100/13 bus SB600 USB (OHCI0)
/0/100/13.1 bus SB600 USB (OHCI1)
/0/100/13.2 bus SB600 USB (OHCI2)
/0/100/13.3 bus SB600 USB (OHCI3)
/0/100/13.4 bus SB600 USB (OHCI4)
/0/100/13.5 bus SB600 USB Controller (EHCI)
/0/100/14 bus SBx00 SMBus Controller
/0/100/14.1 scsi0 storage SB600 IDE
/0/100/14.1/0.0.0 /dev/cdrom disk CDRW/DVD TSL462D
/0/100/14.2 multimedia SBx00 Azalia (Intel HDA)
/0/100/14.3 bridge SB600 PCI to LPC Bridge
/0/100/14.4 bridge SBx00 PCI to PCI Bridge
/0/100/14.4/0 eth0 network BCM4401-B0 100Base-TX
/0/100/14.4/1 generic R5C822 SD/SDIO/MMC/MS/MSPro Host Ad
/0/100/14.4/1.1 generic R5C843 MMC Host Controller
/0/101 bridge K8 [Athlon64/Opteron] HyperTranspor
/0/102 bridge K8 [Athlon64/Opteron] Address Map
/0/103 bridge K8 [Athlon64/Opteron] DRAM Controll
/0/104 bridge K8 [Athlon64/Opteron] Miscellaneous
/1 power Sanyo DELLUD2646
Linux JeffGibson-LT 2.6.38-11-generic #48-Ubuntu SMP Fri Jul 29 19:05:14 UTC 2011 i686 athlon i386 GNU/Linux
[ 0.000000] found SMP MP-table at [c00f8780] f8780
[ 0.005008] SMP alternatives: switching to UP code
[ 0.028001] ..... (found apic 0 pin 0) ...
[ 0.074783] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 0.083088] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[ 0.084366] ACPI: No dock devices found.
[ 0.084369] HEST: Table not found.
[ 0.084982] ACPI Error: Needed type [Reference], found [Device] f5021f90 (20110112/exresop-104)
[ 0.084996] ACPI Error: Method parse/execution failed [\_SB_.PCI0._OSC] (Node f5029d98), AE_AML_OPERAND_TYPE (20110112/psparse-536)
[ 0.091828] ACPI Error: Needed type [Reference], found [Device] f5021f90 (20110112/exresop-104)
[ 0.091840] ACPI Error: Method parse/execution failed [\_SB_.PCI0._OSC] (Node f5029d98), AE_AML_OPERAND_TYPE (20110112/psparse-536)
[ 0.091889] ACPI Error: Needed type [Reference], found [Device] f5021f90 (20110112/exresop-104)
[ 0.091900] ACPI Error: Method parse/execution failed [\_SB_.PCI0._OSC] (Node f5029d98), AE_AML_OPERAND_TYPE (20110112/psparse-536)
[ 0.096890] usbcore: registered new interface driver usbfs
[ 0.096904] usbcore: registered new interface driver hub
[ 0.096932] usbcore: registered new device driver usb
[ 0.108057] pnp: PnP ACPI: found 10 devices
[ 0.145757] Switching to clocksource acpi_pm
[ 0.147996] Switched to NOHz mode on CPU #0
[ 0.190570] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input2
[ 0.191141] ACPI: Lid Switch [LID]
[ 0.196705] ERST: Table is not found!
[ 0.204660] i2c-core: driver [adp5520] using legacy suspend method
[ 0.204662] i2c-core: driver [adp5520] using legacy resume method
[ 0.205633] ehci_hcd 0000:00:13.5: applying AMD SB600/SB700 USB freeze workaround
[ 0.255233] hub 1-0:1.0: USB hub found
[ 0.468446] hub 2-0:1.0: USB hub found
[ 0.528300] hub 3-0:1.0: USB hub found
[ 0.619956] isapnp: No Plug & Play device found
[ 0.656508] hub 4-0:1.0: USB hub found
[ 0.712426] hub 5-0:1.0: USB hub found
[ 0.768347] hub 6-0:1.0: USB hub found
[ 0.776407] device-mapper: multipath: version 1.2.0 loaded
[ 0.776412] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 0.781371] powernow-k8: Found 1 AMD Turion(tm) 64 Mobile Technology MK-36 (1 cpu cores) (version 2.20.00)
[ 0.781986] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 1.048061] usb 5-1: new low speed USB device using ohci_hcd and address 2
[ 1.286727] sdhci-pci 0000:08:01.0: SDHCI controller found [1180:0822] (rev 19)
[ 1.287806] mmc0: no vmmc regulator found
[ 1.342268] sdhci-pci 0000:08:01.1: SDHCI controller found [1180:0843] (rev 1)
[ 1.342330] mmc1: no vmmc regulator found
[ 1.840034] ata3: applying SB600 PMP SRST workaround and retrying
[ 2.112861] input: PIXART USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:13.3/usb5/5-1/5-1:1.0/input/input5
[ 2.113093] generic-usb 0003:093A:2510.0001: input,hidraw0: USB HID v1.11 Mouse [PIXART USB OPTICAL MOUSE] on usb-0000:00:13.3-1/input0
[ 2.113335] usbcore: registered new interface driver usbhid
[ 2.113338] usbhid: USB HID core driver
[ 20.021655] lp: driver loaded but no devices found
[ 20.241642] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[ 21.131160] wl: module license 'MIXED/Proprietary' taints kernel.
[ 21.741639] wl 0000:05:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 21.741648] wl 0000:05:00.0: setting latency timer to 64
[ 21.744230] eth%d: 5.100.82.38 driver failed with code 21
[ 21.852417] b43-pci-bridge 0000:05:00.0: setting latency timer to 64
[ 21.876897] ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x11, vendor 0x4243)
[ 21.876911] ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x0A, vendor 0x4243)
[ 21.876919] ssb: Core 2 found: USB 1.1 Host (cc 0x817, rev 0x03, vendor 0x4243)
[ 21.876926] ssb: Core 3 found: PCI-E (cc 0x820, rev 0x01, vendor 0x4243)
[ 21.932350] ssb: Sonics Silicon Backplane found on PCI device 0000:05:00.0
[ 21.964064] ssb: Core 0 found: Fast Ethernet (cc 0x806, rev 0x07, vendor 0x4243)
[ 21.964075] ssb: Core 1 found: V90 (cc 0x807, rev 0x03, vendor 0x4243)
[ 21.964084] ssb: Core 2 found: PCI (cc 0x804, rev 0x0A, vendor 0x4243)
[ 22.009255] ssb: Sonics Silicon Backplane found on PCI device 0000:08:00.0
[ 22.034025] b44 ssb1:0: eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:19:b9:51:21:e3
[ 22.101430] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 22.304229] input: HDA ATI SB Mic at Ext Right Jack as /devices/pci0000:00/0000:00:14.2/sound/card0/input9
[ 22.304494] input: HDA ATI SB HP Out at Ext Right Jack as /devices/pci0000:00/0000:00:14.2/sound/card0/input10
[ 22.396071] Console: switching to colour frame buffer device 160x50
[ 25.816203] b44 ssb1:0: eth0: Link is up at 100 Mbps, full duplex
[ 25.816208] b44 ssb1:0: eth0: Flow control is off for TX and off for RX
[ 25.816694] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 36.688022] eth0: no IPv6 routers present
 Manufacturer: Dell Inc.
 Product Name: Inspiron 1501
 Manufacturer: Dell Inc.
 Product Name: 0UW744
 Manufacturer: Dell Inc.
 Manufacturer: AMD
 Manufacturer: Not Specified
 Manufacturer: Not Specified
 Manufacturer: Sanyo DELLUD2646
 SBDS Manufacture Date: 1980-00-00
lo no wireless extensions.

eth0 no wireless extensions.

install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
blacklist b43
blacklist b43legacy
blacklist bcm43xx
blacklist brcm80211
install wl modprobe -r b43 b44 b43legacy ssb; modprobe --ignore-install wl ; modprobe --ignore-install b44
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist uart6850
blacklist twl4030_wdt

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
> hal.1: read hal dataprocess 1911: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
29: PCI 500.0: 0280 Network controller
  [Created at pci.318]
  Unique ID: Ddhb.AUabv0M9SM3
  Parent ID: H0_h.bsmdjgJdggA
  SysFS ID: /devices/pci0000:00/0000:00:06.0/0000:05:00.0
  SysFS BusID: 0000:05:00.0
  Hardware Class: network
  Model: "Dell Wireless 1390 WLAN Mini-Card"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4311 "BCM4311 802.11b/g WLAN"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0007 "Wireless 1390 WLAN Mini-Card"
  Revision: 0x01
  Driver: "b43-pci-bridge"
  Driver Modules: "ssb"
  Memory Range: 0xc0200000-0xc0203fff (rw,non-prefetchable)
  IRQ: 18 (2 events)
  Module Alias: "pci:v000014E4d00004311sv00001028sd00000007bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is active
    Driver Activation Cmd: "modprobe ssb"
  Driver Info #1:
    Driver Status: wl is active
    Driver Activation Cmd: "modprobe wl"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #11 (PCI bridge)

30: PCI 800.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.HQwXbECfpC4
  Parent ID: qscc.ULOo3yhA66C
  SysFS ID: /devices/pci0000:00/0000:00:14.4/0000:08:00.0
  SysFS BusID: 0000:08:00.0
  Hardware Class: network
  Model: "Broadcom BCM4401-B0 100Base-TX"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x170c "BCM4401-B0 100Base-TX"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x01f5
  Revision: 0x02
  Driver: "b44"
  Driver Modules: "ssb", "b44"
  Device File: eth0
  Memory Range: 0xc0300000-0xc0301fff (rw,non-prefetchable)
  IRQ: 21 (4474 events)
  HW Address: 00:19:b9:51:21:e3
  Link detected: yes
  Module Alias: "pci:v000014E4d0000170Csv00001028sd000001F5bc02sc00i00"
  Driver Info #0:
    Driver Status: b44 is active
    Driver Activation Cmd: "modprobe b44"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #23 (PCI bridge)
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 474 0.0 0.4 25452 4408 ? Ssl 13:27 0:00 NetworkManager
root 1220 0.0 0.1 2552 1192 ? S 13:27 0:00 /sbin/dhclient -d -4 -sf /usr/lib/NetworkManager/nm-dhcp-client.action -pf /var/run/dhclient-eth0.pid -lf /var/lib/dhcp/dhclient-92739095-251b-424e-b00f-c85600fcab12-eth0.lease -cf /var/run/nm-dhclient-eth0.conf eth0
jeff 1923 0.0 0.0 4148 840 pts/0 S+ 13:33 0:00 egrep --color=auto icd|etwork
Module Size Used by
parport_pc 32111 0
ppdev 12849 0
snd_hda_codec_idt 60537 1
radeon 900494 3
snd_hda_intel 24113 2
snd_hda_codec 90901 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 13274 1 snd_hda_codec
snd_pcm 80042 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 13132 0
ttm 65184 1 radeon
b44 35301 0
snd_rawmidi 25269 1 snd_seq_midi
drm_kms_helper 40745 1 radeon
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
ssb 45942 1 b44
joydev 17322 0
binfmt_misc 13213 1
snd_timer 28659 2 snd_pcm,snd_seq
dell_wmi 12601 0
wl 2642531 0
drm 184164 5 radeon,ttm,drm_kms_helper
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
sparse_keymap 13666 1 dell_wmi
dell_laptop 13515 0
dcdbas 14054 1 dell_laptop
snd 55295 13 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
i2c_algo_bit 13184 1 radeon
soundcore 12600 1 snd
psmouse 73312 0
shpchp 32345 0
sp5100_tco 13456 0
k8temp 12872 0
snd_page_alloc 14073 2 snd_hda_intel,snd_pcm
serio_raw 12990 0
lib80211 14570 1 wl
i2c_piix4 13095 0
ati_agp 13202 0
video 18951 0
lp 13349 0
parport 36746 3 parport_pc,ppdev,lp
usbhid 41704 0
ahci 21591 2
hid 77084 1 usbhid
sdhci_pci 13623 0
sdhci 22720 1 sdhci_pci
libahci 25548 1 ahci
pata_atiixp 12968 0

I am pretty sure that your BCM4311 wireless adapter is experiencing the following Broadcom driver bug in Ubuntu 11.04:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677

I suggest installing bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu5) from maverick (Ubuntu 10.10) using gdebi

Solution is described here:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677/comments/23

Then reboot your PC and run the following commands to enable your wireless adapter:

rfkill unblock all
sudo rfkill unblock all

Then retest wireless using NetworkManager

John Coulthard (retired) said : #6

Thank you - the previous post (replacing the bcmwl-kernel-source with the release from maverick) worked for me.

Is there some way to stop the update manager from nagging me to replace it with the newer version? I have to remember to uncheck the Broadcom update each time update manger runs.

John Coulthard (retired) said : #7

 I stopped the update manager from nagging by using the Synaptic Package Manager, highlighting the package and using the menu selection "Package... Lock version...".

See: "Stop update manager from updating certain packages? " - http://ubuntuforums.org/showthread.php?t=1098683

Can you help with this problem?

Provide an answer of your own, or ask Jeff Gibson for more information if necessary.

To post a message you must log in.