Ubuntu oneiric unstable: RTL8111E is very slow

Asked by pschonmann on 2011-09-20

Hi, i have strange problem with my wired connection. I have RTL8111E and now im testing Oneiric ocelot ( but problem persist from 11.04 )
I have installed ubuntu via wubi.
The problem i have very slow network connection over cable - 1gbps switch - and dsl router. Speed is very varying but never exceed 100kpbs. When i turn off PC and turn off switch on PSU ( waiting to led on switch is not lit ) and turn on again . everything is ok. Under W7 i have no problem. On RTL site is driver for kernel 2.6.x only ( im not able use it on 3.x oneiric )
-
Here is lspci of my LAN card
-
ps@ubuntu:~$ sudo lspci -s 07:00.0 -vvv
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
 Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 4 bytes
 Interrupt: pin A routed to IRQ 50
 Region 0: I/O ports at ee00 [size=256]
 Region 2: Memory at fbeff000 (64-bit, prefetchable) [size=4K]
 Region 4: Memory at fbef8000 (64-bit, prefetchable) [size=16K]
 Capabilities: [40] Power Management version 3
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
  Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
  Address: 00000000fee0100c Data: 41b1
 Capabilities: [70] Express (v2) Endpoint, MSI 01
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
   MaxPayload 128 bytes, MaxReadReq 4096 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 unlimited, L1 <64us
   ClockPM+ Surprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk-
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
  DevCap2: Completion Timeout: Range ABCD, TimeoutDis+
  DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
  LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
    Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
    Compliance De-emphasis: -6dB
  LnkSta2: Current De-emphasis Level: -6dB
 Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
  Vector table: BAR=4 offset=00000000
  PBA: BAR=4 offset=00000800
 Capabilities: [d0] Vital Product Data
  Unknown small resource type 00, will not decode more.
 Capabilities: [100 v1] Advanced Error Reporting
  UESta: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
  UEMsk: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
  UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
  CESta: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
  CEMsk: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
  AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
 Capabilities: [140 v1] Virtual Channel
  Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
  Arb: Fixed- WRR32- WRR64- WRR128-
  Ctrl: ArbSelect=Fixed
  Status: InProgress-
  VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
   Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
   Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
   Status: NegoPending- InProgress-
 Capabilities: [160 v1] Device Serial Number 01-00-00-00-68-4c-e0-00
 Kernel driver in use: r8169
 Kernel modules: r8169

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-05
Last reply:
2011-10-03

Try disabling ipv6, it can help. I also suggest you report a bug

pschonmann (pschonmann) said : #2

I disabled ipv6 in grub ipv6.disable=1, but doesnt work.

pschonmann (pschonmann) said : #3

Maybe problem is that ubuntu is using wrong module. Card is reported as RTL8111/8168B, but you can see Kernel driver in use: r8169

Try blacklisting the driver maybe, may help

pschonmann (pschonmann) said : #5

I added blacklist r8169 into /etc/modprobe.d/blacklist.conf at the tail, but module still loading. This doesnt help.

pschonmann (pschonmann) said : #6

dmesg still writing link up
-
[ 220.050687] r8169 0000:07:00.0: eth0: link up
[ 222.257654] r8169 0000:07:00.0: eth0: link up
[ 224.580515] r8169 0000:07:00.0: eth0: link up
[ 225.979865] r8169 0000:07:00.0: eth0: link up
[ 275.396506] r8169 0000:07:00.0: eth0: link up
[ 319.859431] r8169 0000:07:00.0: eth0: link up
[ 323.297798] r8169 0000:07:00.0: eth0: link up
[ 326.924119] r8169 0000:07:00.0: eth0: link up
[ 328.971146] r8169 0000:07:00.0: eth0: link up
[ 330.586355] r8169 0000:07:00.0: eth0: link up
[ 331.693833] r8169 0000:07:00.0: eth0: link up
[ 333.233104] r8169 0000:07:00.0: eth0: link up
[ 336.155719] r8169 0000:07:00.0: eth0: link up
[ 340.269768] r8169 0000:07:00.0: eth0: link up
[ 342.936504] r8169 0000:07:00.0: eth0: link up
[ 344.863596] r8169 0000:07:00.0: eth0: link up
[ 346.514852] r8169 0000:07:00.0: eth0: link up
[ 347.546336] r8169 0000:07:00.0: eth0: link up
[ 349.873289] r8169 0000:07:00.0: eth0: link up
[ 351.372528] r8169 0000:07:00.0: eth0: link up
[ 353.099718] r8169 0000:07:00.0: eth0: link up
[ 354.890845] r8169 0000:07:00.0: eth0: link up
[ 356.654030] r8169 0000:07:00.0: eth0: link up

pschonmann (pschonmann) said : #8

No, bad cable or port cant be, under W7 works ok. And if you read carefully im not getting
eth0: link is not ready
but
eth0: link up

pschonmann (pschonmann) said : #10

Seems thats my problem. But notging changes when i tried to add noapic and pci=nomsi into boot options

Can you help with this problem?

Provide an answer of your own, or ask pschonmann for more information if necessary.

To post a message you must log in.