wireless not working with 11.04 terminal shows conflict

Asked by Thomas Cutchin on 2011-09-09

broadcom 802.11wireless is unclaimed looked at broadcom.com it tells me to remove snd as it's a conflict but i do not know how? I am good in vista but a newbe in linux
Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2011-09-11
Last reply:
2011-09-11

Can you give the output of:

sudo lshw -C network; lsb_release -a; sudo rfkill list

Thanks

Thomas Cutchin (tcutchin1-g) said : #2

thomas@thomas-Presario-C500-RQ335UA-ABA:~$ sudo lshw -C network; lsb_release -a; sudo rfkill list
[sudo] password for thomas:
  *-network UNCLAIMED
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:06:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:80400000-80403fff
  *-network
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 8
       bus info: pci@0000:08:08.0
       logical name: eth0
       version: 10
       serial: 00:16:d4:bb:9c:de
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.1.5 latency=32 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:16 ioport:2000(size=256) memory:d0100000-d01000ff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
0: hp-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
thomas@thomas-Presario-C500-RQ335UA-ABA:~$
thanks sorry i had to be gone for a time

I am pretty sure that your BCM4311 wireless adapter is experiencing the following Broadcom driver bug in Ubuntu 11.04:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677

I suggest installing bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu5) from maverick (Ubuntu 10.10) using gdebi

Solution is described here:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677/comments/23

Then reboot your PC and run the following commands to enable your wireless adapter:

rfkill unblock all
sudo rfkill unblock all

Then retest wireless using NetworkManager

Thomas Cutchin (tcutchin1-g) said : #4

Hello I think every thing is done but i still do not have showing networks,

I think it is the network manger it says installed but not showing up in apps
 BUMMER do I need to open a new ?

Thanks

Maybe these instructions are more helpful:

http://computerandu.wordpress.com/2011/05/04/how-to-solve-no-wireless-networks-in-ubuntu-11-04/

It is essentially the same procedure.

A user called 'Fallen' on that webpage tried the procedure and it worked for him on his Compaq Presario C500, but he was using Ubuntu 10.04, not Ubuntu 11.04

So you could also perform a clean install of Ubuntu 10.04 and then try this procedure again.

Thomas Cutchin (tcutchin1-g) said : #6

I installed 11.04 2 times, I installed 10.04 and now have 3 os on the HD, but using Vista I got into my router and checked the key, and had to redo the ip's as I lost them (: But in Vista my wireless is now a lot faster and in linux it works but fades in and out
so I think I can say it may be solved.

Sorry that I did not get back to you but just got it done yesterday.
Thank you
Tom

Can you help with this problem?

Provide an answer of your own, or ask Thomas Cutchin for more information if necessary.

To post a message you must log in.