wireless network in maverick (10.10) and natty (11.04) painfully slow

Asked by Mark on 2011-07-02

I have a DLink PCIe W-LAN card which uses the Atheros chip and the ath9k driver.

I was running lucid (10.04) and had wonderful wireless network performance. For example I downloaded the 648Mbyte natty LiveCD in a little over 3 minutes.

I then used the upgrade manager to upgrade to maverick (10.10) and then natty (11.04). After the upgrade to maverick, downloading the natty updates took an extremely long time - over an hour. After the upgrade to natty, I continue to have painfully slow networking so much so that I would like to go downgrade back to lucid.

Here are the speedtest.net results. All in Mbps.

                                  Download | Upload
11.04 W-LAN (ath9k) 4 - 5 | 21
11.04 wired 38.2 | 22.2
Windows 7 notebook 29.97 | 22.67
on same W-LAN
in same room

I looked at all the articles I could find about slow networking in Ubuntu. Discounting the ones relating to lucid or earlier, I found only 3 suggestions:
- disable ipv6. It is already disabled. In the ipv6 settings dialog Method: ignore is set.
- a problem with "cifs". Since speedtest.net does not use Samba, I do not think cifs has anything to do with it.
- try restarting the router. Did that; didn't help

One person who reported a slow network added a later note that he had a problem with his line filter. Well the 2nd and 3rd results above indicate that I have no such problem.

When I ping my router, I get 20% packet loss. This and the much faster upload speed suggests ath9k driver or some other part of the W-LAN network stack is dropping incoming packets.

An obvious conclusion one might make from the above information is that my W-LAN card has a problem. However the chance of it breaking at exactly the moment I upgraded to maverick is so remote as to be unbelievable. It looks to me like a bug but before reporting it, I thought I would ask here. Has anyone else had similar problems? Is there some network configuration setting that was changed in maverick/natty compared to lucid.

Just to be clear, I changed absolutely nothing else in my home network setup. I did not even power off the router. I simply upgraded the Ubuntu box's software and the network performance disappeared.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Mark
Solved:
Last query:
Last reply:
Mark (1aunchpad-nct) said : #1

Another indication that ipv6 is disabled is that "lsmod | grep ipv6" does not show anything.

Seems to be the following bug:

https://bugs.launchpad.net/ubuntu/natty/+source/linux/+bug/735171

I suggest trying the solution described in the bug description.

Please also check out the proposed solutions in the following bugreport:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/761176

Mark (1aunchpad-nct) said : #3

Thank you for the help. Those reports do look like the bug I am seeing. I do not know why I did not find them in my search.

Do any of the workarounds proposed in those reports work for you?

Mark (1aunchpad-nct) said : #5

I already have kernel 2.6.38.8, suggested in bug #761176 as containing a fix. Clearly it does not. I tried also the commands given in comment #8 of bug #761176 to upgrade to kernel 2.6.39. Those commands did not result in an upgrade. See the note I added to #761176. I have not tried the other 2 suggestions there: building the driver from source and turning off the hardware encryption

Bug #735171 also talks about the 2.6.38.8 kernel. Later it is mentioned that the fix is in "proposed" but no instructions are given as to how to install the "proposed" kernel.

I think I'll keep using a wired connection until a fix arrives via the normal upgrade channels.

If you change your mind and you want to test the new kernel in -proposed, this explains how (and, as always, please feel free to post a reply here with any questions you may have, or, if they seem unrelated to the topic of this post, then to post a new question): https://wiki.ubuntu.com/Testing/EnableProposed

Mark (1aunchpad-nct) said : #7

Thank you for the non-judgemental answers to my questions and the encouragement t to try things and ask more questions. It makes this place feel a very welcoming site to ask questions.

A kernel update came through the Ubuntu Update Manager today which has fixed the problem. I am now running, according to 'uname -a'

$ uname -a
Linux NeurosLINK 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:07:17 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

The System Monitor reports this kernel as 2.6.38-10-generic. It reported my previous kernel as 2.6.38-8-generic.

The changes in the 2.6.38-10 kernel include fixes to (something like) the wireless compatibility module. I am happy to report that I can now ping my router without packet loss and one test with speedtest.net gave a result of 45Mbps, the closest I have ever got to my ISP's advertised 50Mbps, though the average speed is around 32 Mbps.