eth%d: 5.100.82.38 driver failed with code 21 -> UNCLAIMED Wireless Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01) not working on acer extensa 5420 in Ubuntu 11.04

Asked by nevarest on 2011-06-17

Hey Ubuntu gurus. I'm having a issue powering on a acer extensa 5420 wlan adapter button running 11.04. i've installed the os many times on laptops and desk tops and on this particular device when i activated the broad com wireless adapter drivers after connecting lan line--it connected via lan line but i'm not able to power on the adapter to enable wireless capabilities. NOw i went to the Synaptic Package Manager but was not sure what package could possibly resolve this issue. With other laptops in most cases the wlan controls enabled on their own for me. Any help would be much appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2011-06-30
Last query:
2011-06-30
Last reply:
2011-06-25

Hi,

Please first connect your wired network adapter to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1:

If you are using the Gnome interface, open the Terminal console via "Applications->Accessories->Terminal"

If you are using the Unity interface, the easiest way to open the Terminal is to use the 'search' function on the dash. Or you can click on the 'More Apps' button, click on the 'See more results' by the installed section, and find it in that list of applications. A third way, available after you click on the 'More Apps' button, is to go to the search bar, and see that the far right end of it says 'All Applications'. You then click on that, and you'll see the full list. Then you can go to Accessories > Terminal after that.

So the methods in Unity are:
Dash > Search for Terminal
Dash > More Apps > 'See More Results' > Terminal
Dash > More Apps > Accessories > Terminal

Step 2: Please copy-paste the following command from the https://answers.launchpad.net/ubuntu website in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word lsmod. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|ireless|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt5|rt6|rt7|usb|witch|wl';sudo dmidecode|egrep 'Manufact|Product'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl'; sudo hwinfo --netcard ; cat /var/lib/NetworkManager/NetworkManager.state; sudo lsmod

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Step 4: Please also clarify if you installed Ubuntu to the harddisk and are running from a harddisk install OR if you are only testing Ubuntu in a LiveCD session.

Regards,

Mark

nevarest (nevarest) said : #2

step 3: complete

[sudo] password for millionaire:
Ign http://us.archive.ubuntu.com natty InRelease
Ign http://us.archive.ubuntu.com natty-updates InRelease
Ign http://security.ubuntu.com natty-security InRelease
Hit http://us.archive.ubuntu.com natty Release.gpg
Get:1 http://security.ubuntu.com natty-security Release.gpg [198 B]
Get:2 http://us.archive.ubuntu.com natty-updates Release.gpg [198 B]
Get:3 http://security.ubuntu.com natty-security Release [27.2 kB]
Hit http://us.archive.ubuntu.com natty Release
Get:4 http://us.archive.ubuntu.com natty-updates Release [27.2 kB]
Get:5 http://security.ubuntu.com natty-security/main Sources [57.2 kB]
Hit http://us.archive.ubuntu.com natty/main Sources
Hit http://us.archive.ubuntu.com natty/restricted Sources
Hit http://us.archive.ubuntu.com natty/universe Sources
Hit http://us.archive.ubuntu.com natty/multiverse Sources
Hit http://us.archive.ubuntu.com natty/main i386 Packages
Hit http://us.archive.ubuntu.com natty/restricted i386 Packages
Hit http://us.archive.ubuntu.com natty/universe i386 Packages
Hit http://us.archive.ubuntu.com natty/multiverse i386 Packages
Ign http://us.archive.ubuntu.com natty/main TranslationIndex
Ign http://us.archive.ubuntu.com natty/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com natty/restricted TranslationIndex
Ign http://us.archive.ubuntu.com natty/universe TranslationIndex
Get:6 http://us.archive.ubuntu.com natty-updates/main Sources [88.2 kB]
Get:7 http://security.ubuntu.com natty-security/restricted Sources [14 B]
Get:8 http://security.ubuntu.com natty-security/universe Sources [6,102 B]
Get:9 http://security.ubuntu.com natty-security/multiverse Sources [649 B]
Get:10 http://security.ubuntu.com natty-security/main i386 Packages [146 kB]
Get:11 http://us.archive.ubuntu.com natty-updates/restricted Sources [14 B]
Get:12 http://us.archive.ubuntu.com natty-updates/universe Sources [15.0 kB]
Get:13 http://us.archive.ubuntu.com natty-updates/multiverse Sources [1,891 B]
Get:14 http://us.archive.ubuntu.com natty-updates/main i386 Packages [258 kB]
Get:15 http://security.ubuntu.com natty-security/restricted i386 Packages [14 B]
Get:16 http://security.ubuntu.com natty-security/universe i386 Packages [20.7 kB]
Get:17 http://security.ubuntu.com natty-security/multiverse i386 Packages [2,065 B]
Ign http://security.ubuntu.com natty-security/main TranslationIndex
Ign http://security.ubuntu.com natty-security/multiverse TranslationIndex
Ign http://security.ubuntu.com natty-security/restricted TranslationIndex
Ign http://security.ubuntu.com natty-security/universe TranslationIndex
Get:18 http://us.archive.ubuntu.com natty-updates/restricted i386 Packages [14 B]
Get:19 http://us.archive.ubuntu.com natty-updates/universe i386 Packages [62.8 kB]
Get:20 http://us.archive.ubuntu.com natty-updates/multiverse i386 Packages [4,270 B]
Ign http://us.archive.ubuntu.com natty-updates/main TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/restricted TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/universe TranslationIndex
Ign http://security.ubuntu.com natty-security/main Translation-en_US
Ign http://security.ubuntu.com natty-security/main Translation-en
Ign http://security.ubuntu.com natty-security/multiverse Translation-en_US
Ign http://security.ubuntu.com natty-security/multiverse Translation-en
Ign http://security.ubuntu.com natty-security/restricted Translation-en_US
Ign http://security.ubuntu.com natty-security/restricted Translation-en
Ign http://security.ubuntu.com natty-security/universe Translation-en_US
Ign http://security.ubuntu.com natty-security/universe Translation-en
Ign http://us.archive.ubuntu.com natty/main Translation-en_US
Ign http://us.archive.ubuntu.com natty/main Translation-en
Ign http://us.archive.ubuntu.com natty/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com natty/multiverse Translation-en
Ign http://us.archive.ubuntu.com natty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com natty/restricted Translation-en
Ign http://us.archive.ubuntu.com natty/universe Translation-en_US
Ign http://us.archive.ubuntu.com natty/universe Translation-en
Ign http://us.archive.ubuntu.com natty-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/main Translation-en
Ign http://us.archive.ubuntu.com natty-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/multiverse Translation-en
Ign http://us.archive.ubuntu.com natty-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/restricted Translation-en
Ign http://us.archive.ubuntu.com natty-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/universe Translation-en
Fetched 718 kB in 13s (55.2 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
The following extra packages will be installed:
  libhal1 libhd16
The following NEW packages will be installed:
  hwinfo libhal1 libhd16
0 upgraded, 3 newly installed, 0 to remove and 9 not upgraded.
Need to get 818 kB of archives.
After this operation, 2,269 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com/ubuntu/ natty/universe libhal1 i386 0.5.14-5+svn1 [74.4 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ natty/universe libhd16 i386 16.0-2 [698 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ natty/universe hwinfo i386 16.0-2 [46.1 kB]
Fetched 818 kB in 11s (73.5 kB/s)
Selecting previously deselected package libhal1.
(Reading database ... 130124 files and directories currently installed.)
Unpacking libhal1 (from .../libhal1_0.5.14-5+svn1_i386.deb) ...
Selecting previously deselected package libhd16.
Unpacking libhd16 (from .../libhd16_16.0-2_i386.deb) ...
Selecting previously deselected package hwinfo.
Unpacking hwinfo (from .../hwinfo_16.0-2_i386.deb) ...
Processing triggers for man-db ...
Setting up libhal1 (0.5.14-5+svn1) ...
Setting up libhd16 (16.0-2) ...
Setting up hwinfo (16.0-2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
  *-network
       description: Ethernet interface
       product: 88E8071 PCI-E Gigabit Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 15
       serial: 00:1d:72:1c:a1:f3
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.28 duplex=full firmware=N/A ip=192.168.0.101 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:43 memory:f0200000-f0203fff ioport:a000(size=256) memory:f0500000-f051ffff
  *-network UNCLAIMED
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f0300000-f0303fff
0: acer-wireless: Wireless LAN
 Soft blocked: yes
 Hard blocked: no
1: acer-threeg: Wireless WAN
 Soft blocked: yes
 Hard blocked: no
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

irda0 Interface doesn't support scanning.

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
00:00.0 Host bridge [0600]: ATI Technologies Inc RS690 Host Bridge [1002:7910]
00:01.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx) [1002:7912]
00:04.0 PCI bridge [0604]: ATI Technologies Inc Device [1002:7914]
00:05.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1) [1002:7915]
00:06.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2) [1002:7916]
00:12.0 SATA controller [0106]: ATI Technologies Inc SB600 Non-Raid-5 SATA [1002:4380]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI0) [1002:4387]
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI1) [1002:4388]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI2) [1002:4389]
00:13.3 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI3) [1002:438a]
00:13.4 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI4) [1002:438b]
00:13.5 USB Controller [0c03]: ATI Technologies Inc SB600 USB Controller (EHCI) [1002:4386]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 14)
00:14.1 IDE interface [0101]: ATI Technologies Inc SB600 IDE [1002:438c]
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB600 PCI to LPC Bridge [1002:438d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS690M [Radeon X1200 Series] [1002:791f]
02:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8071 PCI-E Gigabit Ethernet Controller [11ab:436b] (rev 15)
05:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
0b:06.0 CardBus bridge [0607]: O2 Micro, Inc. OZ711SP1 Memory CardBus Controller [1217:7136] (rev 01)
0b:06.2 SD Host controller [0805]: O2 Micro, Inc. Integrated MMC/SD Controller [1217:7120] (rev 02)
0b:06.3 Mass storage controller [0180]: O2 Micro, Inc. Integrated MS/xD Controller [1217:7130] (rev 01)
0b:06.4 FireWire (IEEE 1394) [0c00]: O2 Micro, Inc. Firewire (IEEE 1394) [1217:00f7] (rev 02)
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 064e:a101 Suyin Corp. Acer CrystalEye Webcam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
======================================================
                               system Computer
/0 bus Extensa 5420
/0/0 memory 113KiB BIOS
/0/4 processor AMD Turion(tm) 64 X2 Mobile Technolog
/0/4/5 memory 128KiB L1 cache
/0/4/6 memory 512KiB L2 cache
/0/1b memory 2GiB System Memory
/0/1b/0 memory 1GiB DIMM DDR2 Synchronous
/0/1b/1 memory 1GiB DIMM DDR2 Synchronous
/0/1 processor
/0/1/0 memory 128KiB L1 cache
/0/1/1 memory 512KiB L2 cache
/0/100 bridge RS690 Host Bridge
/0/100/1 bridge RS690 PCI to PCI Bridge (Internal gfx
/0/100/1/5 display RS690M [Radeon X1200 Series]
/0/100/4 bridge ATI Technologies Inc
/0/100/4/0 eth0 network 88E8071 PCI-E Gigabit Ethernet Contro
/0/100/5 bridge RS690 PCI to PCI Bridge (PCI Express
/0/100/5/0 network BCM4311 802.11b/g WLAN
/0/100/6 bridge RS690 PCI to PCI Bridge (PCI Express
/0/100/12 scsi2 storage SB600 Non-Raid-5 SATA
/0/100/12/0.0.0 /dev/sda disk 160GB TOSHIBA MK1646GS
/0/100/12/0.0.0/1 /dev/sda1 volume 10000MiB Windows FAT volume
/0/100/12/0.0.0/2 /dev/sda2 volume 69GiB Windows NTFS volume
/0/100/12/0.0.0/3 /dev/sda3 volume 69GiB Windows NTFS volume
/0/100/13 bus SB600 USB (OHCI0)
/0/100/13.1 bus SB600 USB (OHCI1)
/0/100/13.2 bus SB600 USB (OHCI2)
/0/100/13.3 bus SB600 USB (OHCI3)
/0/100/13.4 bus SB600 USB (OHCI4)
/0/100/13.5 bus SB600 USB Controller (EHCI)
/0/100/14 bus SBx00 SMBus Controller
/0/100/14.1 scsi0 storage SB600 IDE
/0/100/14.1/0.0.0 /dev/cdrom disk DVDRAM GSA-T20N
/0/100/14.2 multimedia SBx00 Azalia (Intel HDA)
/0/100/14.3 bridge SB600 PCI to LPC Bridge
/0/100/14.4 bridge SBx00 PCI to PCI Bridge
/0/100/14.4/6 bridge OZ711SP1 Memory CardBus Controller
/0/100/14.4/6.2 generic Integrated MMC/SD Controller
/0/100/14.4/6.3 storage Integrated MS/xD Controller
/0/100/14.4/6.4 bus Firewire (IEEE 1394)
/0/101 bridge K8 [Athlon64/Opteron] HyperTransport
/0/102 bridge K8 [Athlon64/Opteron] Address Map
/0/103 bridge K8 [Athlon64/Opteron] DRAM Controller
/0/104 bridge K8 [Athlon64/Opteron] Miscellaneous C
Linux ubuntu 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 athlon i386 GNU/Linux
[ 0.000000] found SMP MP-table at [c00f8400] f8400
[ 0.032001] ..... (found apic 0 pin 0) ...
[ 0.008000] Switch to broadcast mode on CPU1
[ 0.160370] Switch to broadcast mode on CPU0
[ 0.169413] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 0.984227] ACPI: No dock devices found.
[ 0.984230] HEST: Table not found.
[ 1.008162] usbcore: registered new interface driver usbfs
[ 1.008180] usbcore: registered new interface driver hub
[ 1.008187] usbcore: registered new device driver usb
[ 1.014570] Switching to clocksource hpet
[ 1.014575] Switched to NOHz mode on CPU #1
[ 1.014585] Switched to NOHz mode on CPU #0
[ 1.223674] pnp: PnP ACPI: found 12 devices
[ 1.282093] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input1
[ 1.312020] ACPI: Lid Switch [LID0]
[ 1.539998] ERST: Table is not found!
[ 1.896486] isapnp: No Plug & Play device found
[ 2.131163] i2c-core: driver [adp5520] using legacy suspend method
[ 2.131165] i2c-core: driver [adp5520] using legacy resume method
[ 2.132305] ehci_hcd 0000:00:13.5: applying AMD SB600/SB700 USB freeze workaround
[ 2.144217] hub 1-0:1.0: USB hub found
[ 2.200196] hub 2-0:1.0: USB hub found
[ 2.256186] hub 3-0:1.0: USB hub found
[ 2.312180] hub 4-0:1.0: USB hub found
[ 2.368185] hub 5-0:1.0: USB hub found
[ 2.428172] hub 6-0:1.0: USB hub found
[ 2.448924] device-mapper: multipath: version 1.2.0 loaded
[ 2.448927] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 2.450391] powernow-k8: Found 1 AMD Turion(tm) 64 X2 Mobile Technology TL-58 (2 cpu cores) (version 2.20.00)
[ 2.451082] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 2.456060] usb 1-7: new high speed USB device using ehci_hcd and address 2
[ 2.851829] sky2 0000:02:00.0: eth0: addr 00:1d:72:1c:a1:f3
[ 2.876462] sdhci-pci 0000:0b:06.2: SDHCI controller found [1217:7120] (rev 2)
[ 2.876525] mmc0: no vmmc regulator found
[ 3.936036] ata3: applying SB600 PMP SRST workaround and retrying
[ 14.255271] lp: driver loaded but no devices found
[ 14.744995] wl: module license 'MIXED/Proprietary' taints kernel.
[ 15.135882] yenta_cardbus 0000:0b:06.0: CardBus bridge found [1025:0124]
[ 15.194611] nsc_ircc_pnp_probe() : From PnP, found firbase 0x2F8 ; irq 3 ; dma 3.
[ 15.200699] nsc-ircc, Found chip at base=0x02e
[ 15.201607] nsc-ircc, Found dongle: Supports SIR Mode only
[ 15.205037] nsc-ircc, Found chip at base=0x02e
[ 15.375651] uvcvideo: Found UVC 1.00 device Acer CrystalEye webcam (064e:a101)
[ 15.379437] input: Acer CrystalEye webcam as /devices/pci0000:00/0000:00:13.5/usb1/1-7/1-7:1.0/input/input6
[ 15.390802] usbcore: registered new interface driver uvcvideo
[ 15.425639] wl 0000:05:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 15.425648] wl 0000:05:00.0: setting latency timer to 64
[ 15.428115] eth%d: 5.100.82.38 driver failed with code 21
[ 15.677514] input: HDA ATI SB Headphone as /devices/pci0000:00/0000:00:14.2/sound/card0/input7
[ 16.141304] sky2 0000:02:00.0: eth0: enabling interface
[ 16.141629] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 16.585806] Console: switching to colour frame buffer device 160x50
[ 30.928026] hda-intel: azx_get_response timeout, switching to polling mode: last cmd=0x01270700
[ 31.932026] hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x01270700
[ 151.001941] sky2 0000:02:00.0: eth0: Link is up at 100 Mbps, full duplex, flow control both
[ 151.002590] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 161.520039] eth0: no IPv6 routers present
 Manufacturer: Acer
 Product Name: Extensa 5420
 Manufacturer: Acer
 Product Name: Extensa 5420
 Manufacturer: Acer
 Manufacturer: AMD
 Manufacturer: Not Specified
 Manufacturer: Not Specified
lo no wireless extensions.

eth0 no wireless extensions.

irda0 no wireless extensions.

# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
blacklist b43
blacklist b43legacy
blacklist bcm43xx
blacklist brcm80211
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist uart6850
blacklist twl4030_wdt
> hal.1: read hal dataprocess 1986: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
30: PCI 200.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.7h_qr9FEtJF
  Parent ID: 8otl.Nl9GME61y7C
  SysFS ID: /devices/pci0000:00/0000:00:04.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Marvell 88E8071 PCI-E Gigabit Ethernet Controller"
  Vendor: pci 0x11ab "Marvell Technology Group Ltd."
  Device: pci 0x436b "88E8071 PCI-E Gigabit Ethernet Controller"
  SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
  SubDevice: pci 0x0124
  Revision: 0x15
  Driver: "sky2"
  Driver Modules: "sky2"
  Device File: eth0
  Memory Range: 0xf0200000-0xf0203fff (rw,non-prefetchable)
  I/O Ports: 0xa000-0xafff (rw)
  Memory Range: 0xf0500000-0xf051ffff (ro,non-prefetchable,disabled)
  IRQ: 43 (4862 events)
  HW Address: 00:1d:72:1c:a1:f3
  Link detected: yes
  Module Alias: "pci:v000011ABd0000436Bsv00001025sd00000124bc02sc00i00"
  Driver Info #0:
    Driver Status: sky2 is active
    Driver Activation Cmd: "modprobe sky2"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

31: PCI 500.0: 0280 Network controller
  [Created at pci.318]
  Unique ID: Ddhb.D1FqthfVec2
  Parent ID: CvwD.u960roDkTWC
  SysFS ID: /devices/pci0000:00/0000:00:05.0/0000:05:00.0
  SysFS BusID: 0000:05:00.0
  Hardware Class: network
  Model: "Broadcom BCM4311 802.11b/g WLAN"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4311 "BCM4311 802.11b/g WLAN"
  SubVendor: pci 0x1468 "AMBIT Microsystem Corp."
  SubDevice: pci 0x0422
  Revision: 0x01
  Memory Range: 0xf0300000-0xf0303fff (rw,non-prefetchable)
  IRQ: 17 (2 events)
  Module Alias: "pci:v000014E4d00004311sv00001468sd00000422bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is not active
    Driver Activation Cmd: "modprobe ssb"
  Driver Info #1:
    Driver Status: wl is active
    Driver Activation Cmd: "modprobe wl"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #11 (PCI bridge)

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
Module Size Used by
parport_pc 32111 0
ppdev 12849 0
binfmt_misc 13213 1
joydev 17322 0
snd_hda_codec_realtek 255820 1
snd_hda_intel 24140 2
snd_hda_codec 90901 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13274 1 snd_hda_codec
radeon 896428 3
snd_pcm 80244 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 13132 0
snd_rawmidi 25269 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
ttm 65184 1 radeon
wl 2642531 0
drm_kms_helper 40745 1 radeon
snd_timer 28659 2 snd_pcm,snd_seq
pcmcia 39671 0
acer_wmi 23123 0
uvcvideo 66851 0
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
drm 180037 5 radeon,ttm,drm_kms_helper
sparse_keymap 13666 1 acer_wmi
nsc_ircc 23199 0
yenta_socket 27230 0
snd 55295 13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
irda 185091 1 nsc_ircc
pcmcia_rsrc 18292 1 yenta_socket
videodev 75143 1 uvcvideo
psmouse 73312 0
sp5100_tco 13456 0
pcmcia_core 21505 3 pcmcia,yenta_socket,pcmcia_rsrc
soundcore 12600 1 snd
i2c_algo_bit 13184 1 radeon
k8temp 12872 0
serio_raw 12990 0
crc_ccitt 12595 1 irda
i2c_piix4 13095 0
snd_page_alloc 14073 2 snd_hda_intel,snd_pcm
shpchp 32345 0
video 18951 0
ati_agp 13202 0
lib80211 14570 1 wl
lp 13349 0
parport 36746 3 parport_pc,ppdev,lp
sky2 49172 0
sdhci_pci 13623 0
ahci 21591 1
sdhci 22720 1 sdhci_pci
firewire_ohci 31504 0
firewire_core 56138 1 firewire_ohci
libahci 25548 1 ahci
crc_itu_t 12627 1 firewire_core
pata_atiixp 12968 0

step 4: complete
I'm running ubuntu via the run it with windows option where i choose which operating system i would like to boot up in. Hope this helps--thanks guy for all your help.

I am pretty sure that your wireless adapter is experiencing the following Broadcom driver bug in Ubuntu 11.04:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677

As I understand it, there are 2 possible solutions for the BCM4311 wireless problem in Ubuntu 11.04:

1) installing b43-fwcutter and firmware-b43-installer as described here:

https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/157369

or

2) manually installing bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu5) from maverick (Ubuntu 10.10) using gdebi

Solution 2 is described here:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677/comments/23

I suggest try solution 2.

Then reboot your PC and run the following commands to enable your wireless adapter:

rfkill unblock all
sudo rfkill unblock all

Then retest wireless using NetworkManager.

nevarest (nevarest) said : #4

Thanks for all your help I had a few problems doing solution 1 and 2 so tried a combination of both and "somehow" it worked. Not really sure what all I did because i'm by no means a expert in linux but i noted down my steps the best to my ability. And im posting this via my wireless connection as i type ;-)

This is what worked for me not really sure how all this played out but I did the following

ran each command seperately

sudo apt-get update
sudo apt-get remove bcmwl-kernel-source
sudo apt-get install b43-fwcutter

rebooted

ran commands
sudo modprobe -r b43 b44 b43legacy ssb
sudo modprobe b43

NOTE: I had a enabled wireless button but it still was not fully functional til i install the below componet

then installed the bcmwl-kernel-source_5.60.48.36+bdcom-0ubuntu5_i386.deb with the gdebi installer utility

then rebooted device

once my pc came back up my wireless card was enabled and could see the networks avaliable.

Thanks again for all your help UBUNTU rocks ;-)

nevarest (nevarest) said : #5

Thanks Mark Rijckenberg, that solved my question.