BCM 4311 driver is "activated" but wireless does not work

Asked by Glen Dickson on 2011-06-14

I installed 11.04 on our Dell laptop. The wireless does not work.

The Additional Drivers window says that "Broadcom STA wireless driver is activated and currently in use."

The lshw command shows network controller BCM4311, configuration: driver=b43-pci-bridge latency=0

I ran the lsmod command but it did not list anything that I recognized as a wireless driver.

iwconfig says "no wireless extensions"

iwlist scn says "interface does not support scanning"

rfkill list says "soft blocked:no, hard blocked:no"

When I boot into Windows (dual boot), the wireless works fine.

I have read some good discussion of this kind of problem at question # 157369 and at bug # 732677. I get the impression that the problem is caused by two competing drivers (STA and b43), and that the solution involves fwcutter, but I only know a little bit about computers and don't want to start installing/uninstalling/blacklisting things at the command line without getting some specific advice. I will greatly appreciate any help!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2011-06-15
Last query:
2011-06-15
Last reply:
2011-06-15
marcus aurelius (adbiz) said : #1

press CTL+ALT+T to get into terminal

then type

sudo apt-get install b43-fwcutter

enter your password when asked. it will not be displayed on the screen

I am pretty sure that your wireless adapter is experiencing the following Broadcom driver bug in Ubuntu 11.04:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677

As I understand it, there are 2 possible solutions for the BCM4311 wireless problem in Ubuntu 11.04:

1) installing b43-fwcutter and firmware-b43-installer as described here:

https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/157369

or

2) manually installing bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu5) from maverick (Ubuntu 10.10) using gdebi

Solution 2 is described here:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677/comments/23

Glen Dickson (hbdickson) said : #3

Wireless now working. Thank you!

I ran: sudo apt-get install b43-fwcutter firmware-b43-installer

then removed the STA driver at the Additional Drivers window, then re-booted.

@Glen: You are welcome.

By the way: it was smart of you to first ask for advice before starting to muck around with blacklist settings and installing stuff that shouldn't be installed. Some people first muck around before asking for advice and then it takes 10 times longer than usual to get the original issue fixed. ;-)