network-manager : wifi always disconnecting

Asked by Jean F. on 2011-05-22

Hi,

i'm running Ubuntu 10.04.2 LTS.
05:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

When using network-manager to connect to the wifi, I get disconnected every few minutes (or few seconds).
in dmesg, i can see messages such as
[ 1463.913102] wlan0: deauthenticating from a2:a1:d7:41:29:45 by local choice (reason=3)
[ 1464.047227] wlan0: deauthenticating from a2:a1:d7:41:29:45 by local choice (reason=3)

(lots of them.)

When I use wicd instead of network-manager, I have no problem at all, the connection is fine, and doesn't disconnect.

Is it a bug with network-manager?

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2011-05-22
Last reply:
2011-05-22

Have you tried disabling IPv6, it may help

Jean F. (jean-f-gmail) said : #2

I have tried disabling ipv6, it doesn't help.
however, as I said, it is now working without problem, with wicd instead of network-manager.

I guess my question is, should I report a bug in the network-manager?

Sure, if you wish.

Jean F. (jean-f-gmail) said : #4

Ok, i created a bug using the link in this page.
Can someone explain to me why this question (and thus the bug) was associated to the gnome-nettool package though? I was under the impression that it should be the network-manager package, but I'm new to this, so maybe I'm wrong...

Krisztian Poos (rocky-poos) said : #5

I also have this problem on WPA2 networks with 10.10 as well on a T500 Thinkpad notebook.
It is really annoying, and does not let you use the net at all...

Can you help with this problem?

Provide an answer of your own, or ask Jean F. for more information if necessary.

To post a message you must log in.