wireless stopped working when upgrading from 10.10 to 11.04

Asked by James Cooper on 2011-05-16

I have been using Ubuntu 10.10 on a Dell Inspiron 1501 laptop. Everything worked correctly. When I upgraded to 11.04 the wireless stopped working. I removed 11.04 and reinstalled 10.10 from the CD and the wireless started working again.

I downloaded the 11.04 .iso file and did a clean install of 11.04. The wireless does not work. The light on the keyboard does not light and the software cannot see it. The correct supplemental driver was installed. I could just go back to 10.10, but I'd really like to try out 11.04.

Thanks - Jim

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2011-05-19
Last query:
2011-05-19
Last reply:
2011-05-19

Hi,

Please first connect your wired network adapter to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1:

If you are using the Gnome interface, open the Terminal console via "Applications->Accessories->Terminal"

If you are using the Unity interface, the easiest way to open the Terminal is to use the 'search' function on the dash. Or you can click on the 'More Apps' button, click on the 'See more results' by the installed section, and find it in that list of applications. A third way, available after you click on the 'More Apps' button, is to go to the search bar, and see that the far right end of it says 'All Applications'. You then click on that, and you'll see the full list. Then you can go to Accessories > Terminal after that.

So the methods in Unity are:
Dash > Search for Terminal
Dash > More Apps > 'See More Results' > Terminal
Dash > More Apps > Accessories > Terminal

Step 2: Please copy-paste the following command from the https://answers.launchpad.net/ubuntu website in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word lsmod. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt6|rt7|usb|witch|wl';sudo dmidecode|egrep 'Manufact|Product'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl'; sudo hwinfo --netcard ; cat /var/lib/NetworkManager/NetworkManager.state; sudo lsmod

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Regards,

Mark

James Cooper (uncas) said : #2

jim@LinuxLaptop:~$ sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt6|rt7|usb|witch|wl';sudo dmidecode|egrep 'Manufact|Product'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl'; sudo hwinfo --netcard ; cat /var/lib/NetworkManager/NetworkManager.state; sudo lsmod
[sudo] password for jim:
Ign http://linux.dropbox.com maverick InRelease
Hit http://linux.dropbox.com maverick Release.gpg
Ign http://extras.ubuntu.com natty InRelease
Ign http://ca.archive.ubuntu.com natty InRelease
Ign http://ca.archive.ubuntu.com natty-updates InRelease
Ign http://security.ubuntu.com natty-security InRelease
Hit http://linux.dropbox.com maverick Release
Hit http://ca.archive.ubuntu.com natty Release.gpg
Get:1 http://extras.ubuntu.com natty Release.gpg [72 B]
Get:2 http://security.ubuntu.com natty-security Release.gpg [198 B]
Get:3 http://ca.archive.ubuntu.com natty-updates Release.gpg [198 B]
Hit http://extras.ubuntu.com natty Release
Hit http://linux.dropbox.com maverick/main i386 Packages
Get:4 http://security.ubuntu.com natty-security Release [23.2 kB]
Ign http://linux.dropbox.com maverick/main TranslationIndex
Hit http://ca.archive.ubuntu.com natty Release
Hit http://extras.ubuntu.com natty/main Sources
Get:5 http://ca.archive.ubuntu.com natty-updates Release [27.2 kB]
Hit http://extras.ubuntu.com natty/main i386 Packages
Ign http://extras.ubuntu.com natty/main TranslationIndex
Get:6 http://security.ubuntu.com natty-security/main Sources [6,215 B]
Ign http://linux.dropbox.com maverick/main Translation-en_CA
Get:7 http://security.ubuntu.com natty-security/restricted Sources [14 B]
Get:8 http://security.ubuntu.com natty-security/universe Sources [2,682 B]
Get:9 http://security.ubuntu.com natty-security/multiverse Sources [647 B]
Get:10 http://security.ubuntu.com natty-security/main i386 Packages [23.5 kB]
Ign http://linux.dropbox.com maverick/main Translation-en
Hit http://ca.archive.ubuntu.com natty/main Sources
Hit http://ca.archive.ubuntu.com natty/restricted Sources
Hit http://ca.archive.ubuntu.com natty/universe Sources
Hit http://ca.archive.ubuntu.com natty/multiverse Sources
Hit http://ca.archive.ubuntu.com natty/main i386 Packages
Hit http://ca.archive.ubuntu.com natty/restricted i386 Packages
Hit http://ca.archive.ubuntu.com natty/universe i386 Packages
Hit http://ca.archive.ubuntu.com natty/multiverse i386 Packages
Ign http://ca.archive.ubuntu.com natty/main TranslationIndex
Ign http://ca.archive.ubuntu.com natty/multiverse TranslationIndex
Ign http://ca.archive.ubuntu.com natty/restricted TranslationIndex
Ign http://ca.archive.ubuntu.com natty/universe TranslationIndex
Get:11 http://ca.archive.ubuntu.com natty-updates/main Sources [28.1 kB]
Get:12 http://security.ubuntu.com natty-security/restricted i386 Packages [14 B]
Get:13 http://security.ubuntu.com natty-security/universe i386 Packages [7,715 B]
Get:14 http://security.ubuntu.com natty-security/multiverse i386 Packages [2,071 B]
Ign http://security.ubuntu.com natty-security/main TranslationIndex
Ign http://security.ubuntu.com natty-security/multiverse TranslationIndex
Ign http://security.ubuntu.com natty-security/restricted TranslationIndex
Ign http://security.ubuntu.com natty-security/universe TranslationIndex
Get:15 http://ca.archive.ubuntu.com natty-updates/restricted Sources [14 B]
Get:16 http://ca.archive.ubuntu.com natty-updates/universe Sources [7,364 B]
Get:17 http://ca.archive.ubuntu.com natty-updates/multiverse Sources [1,362 B]
Get:18 http://ca.archive.ubuntu.com natty-updates/main i386 Packages [99.0 kB]
Ign http://extras.ubuntu.com natty/main Translation-en_CA
Get:19 http://ca.archive.ubuntu.com natty-updates/restricted i386 Packages [14 B]
Get:20 http://ca.archive.ubuntu.com natty-updates/universe i386 Packages [34.3 kB]
Ign http://extras.ubuntu.com natty/main Translation-en
Get:21 http://ca.archive.ubuntu.com natty-updates/multiverse i386 Packages [3,754 B]
Ign http://ca.archive.ubuntu.com natty-updates/main TranslationIndex
Ign http://ca.archive.ubuntu.com natty-updates/multiverse TranslationIndex
Ign http://ca.archive.ubuntu.com natty-updates/restricted TranslationIndex
Ign http://ca.archive.ubuntu.com natty-updates/universe TranslationIndex
Hit http://ca.archive.ubuntu.com natty/main Translation-en_CA
Hit http://ca.archive.ubuntu.com natty/restricted Translation-en_CA
Ign http://security.ubuntu.com natty-security/main Translation-en_CA
Ign http://security.ubuntu.com natty-security/main Translation-en
Ign http://security.ubuntu.com natty-security/multiverse Translation-en_CA
Ign http://security.ubuntu.com natty-security/multiverse Translation-en
Ign http://security.ubuntu.com natty-security/restricted Translation-en_CA
Ign http://security.ubuntu.com natty-security/restricted Translation-en
Ign http://security.ubuntu.com natty-security/universe Translation-en_CA
Ign http://security.ubuntu.com natty-security/universe Translation-en
Ign http://ca.archive.ubuntu.com natty/main Translation-en
Ign http://ca.archive.ubuntu.com natty/multiverse Translation-en_CA
Ign http://ca.archive.ubuntu.com natty/multiverse Translation-en
Ign http://ca.archive.ubuntu.com natty/restricted Translation-en
Ign http://ca.archive.ubuntu.com natty/universe Translation-en_CA
Ign http://ca.archive.ubuntu.com natty/universe Translation-en
Ign http://ca.archive.ubuntu.com natty-updates/main Translation-en_CA
Ign http://ca.archive.ubuntu.com natty-updates/main Translation-en
Ign http://ca.archive.ubuntu.com natty-updates/multiverse Translation-en_CA
Ign http://ca.archive.ubuntu.com natty-updates/multiverse Translation-en
Ign http://ca.archive.ubuntu.com natty-updates/restricted Translation-en_CA
Ign http://ca.archive.ubuntu.com natty-updates/restricted Translation-en
Ign http://ca.archive.ubuntu.com natty-updates/universe Translation-en_CA
Ign http://ca.archive.ubuntu.com natty-updates/universe Translation-en
Fetched 268 kB in 3s (67.0 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
The following extra packages will be installed:
  libhal1 libhd16
The following NEW packages will be installed:
  hwinfo libhal1 libhd16
0 upgraded, 3 newly installed, 0 to remove and 3 not upgraded.
Need to get 818 kB of archives.
After this operation, 2,269 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ca.archive.ubuntu.com/ubuntu/ natty/universe libhal1 i386 0.5.14-5+svn1 [74.4 kB]
Get:2 http://ca.archive.ubuntu.com/ubuntu/ natty/universe libhd16 i386 16.0-2 [698 kB]
Get:3 http://ca.archive.ubuntu.com/ubuntu/ natty/universe hwinfo i386 16.0-2 [46.1 kB]
Fetched 818 kB in 3s (230 kB/s)
Selecting previously deselected package libhal1.
(Reading database ... 131915 files and directories currently installed.)
Unpacking libhal1 (from .../libhal1_0.5.14-5+svn1_i386.deb) ...
Selecting previously deselected package libhd16.
Unpacking libhd16 (from .../libhd16_16.0-2_i386.deb) ...
Selecting previously deselected package hwinfo.
Unpacking hwinfo (from .../hwinfo_16.0-2_i386.deb) ...
Processing triggers for man-db ...
Setting up libhal1 (0.5.14-5+svn1) ...
Setting up libhd16 (16.0-2) ...
Setting up hwinfo (16.0-2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
  *-network
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:18 memory:c0200000-c0203fff
  *-network
       description: Ethernet interface
       product: BCM4401-B0 100Base-TX
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: eth0
       version: 02
       serial: 00:19:b9:5e:c6:76
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=full ip=192.168.1.115 latency=64 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:21 memory:c0300000-c0301fff
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
00:00.0 Host bridge [0600]: ATI Technologies Inc RS480 Host Bridge [1002:5950] (rev 10)
00:01.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a3f]
00:05.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a37]
00:06.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a38]
00:12.0 SATA controller [0106]: ATI Technologies Inc SB600 Non-Raid-5 SATA [1002:4380]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI0) [1002:4387]
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI1) [1002:4388]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI2) [1002:4389]
00:13.3 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI3) [1002:438a]
00:13.4 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI4) [1002:438b]
00:13.5 USB Controller [0c03]: ATI Technologies Inc SB600 USB Controller (EHCI) [1002:4386]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 13)
00:14.1 IDE interface [0101]: ATI Technologies Inc SB600 IDE [1002:438c]
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB600 PCI to LPC Bridge [1002:438d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS482 [Radeon Xpress 200M] [1002:5975]
05:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
08:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX [14e4:170c] (rev 02)
08:01.0 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 19)
08:01.1 System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev 01)
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 046d:c001 Logitech, Inc. N48/M-BB48 [FirstMouse Plus]
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
========================================================
                                 system Portable Computer
/0 bus 0UW744
/0/1 memory 105KiB BIOS
/0/5 processor AMD Turion(tm) 64 X2 Mobile Technol
/0/5/6 memory 1MiB L2 cache
/0/5/0 memory 128KiB L1 cache
/0/5/1 memory 512KiB L2 cache
/0/19 memory 2GiB System Memory
/0/19/0 memory 1GiB DIMM DRAM Synchronous
/0/19/1 memory 1GiB DIMM DRAM Synchronous
/0/0 processor
/0/0/0 memory 128KiB L1 cache
/0/0/1 memory 512KiB L2 cache
/0/100 bridge RS480 Host Bridge
/0/100/1 bridge RS480 PCI Bridge
/0/100/1/5 display RS482 [Radeon Xpress 200M]
/0/100/5 bridge RS480 PCI Bridge
/0/100/6 bridge RS480 PCI Bridge
/0/100/6/0 network BCM4311 802.11b/g WLAN
/0/100/12 scsi2 storage SB600 Non-Raid-5 SATA
/0/100/12/0.0.0 /dev/sda disk 80GB Hitachi HTS54168
/0/100/12/0.0.0/1 /dev/sda1 volume 72GiB EXT4 volume
/0/100/12/0.0.0/2 /dev/sda2 volume 1917MiB Extended partition
/0/100/12/0.0.0/2/5 /dev/sda5 volume 1917MiB Linux swap / Solaris partit
/0/100/13 bus SB600 USB (OHCI0)
/0/100/13.1 bus SB600 USB (OHCI1)
/0/100/13.2 bus SB600 USB (OHCI2)
/0/100/13.3 bus SB600 USB (OHCI3)
/0/100/13.4 bus SB600 USB (OHCI4)
/0/100/13.5 bus SB600 USB Controller (EHCI)
/0/100/14 bus SBx00 SMBus Controller
/0/100/14.1 scsi0 storage SB600 IDE
/0/100/14.1/0.0.0 /dev/cdrom disk DVD+-RW TS-L632D
/0/100/14.2 multimedia SBx00 Azalia (Intel HDA)
/0/100/14.3 bridge SB600 PCI to LPC Bridge
/0/100/14.4 bridge SBx00 PCI to PCI Bridge
/0/100/14.4/0 eth0 network BCM4401-B0 100Base-TX
/0/100/14.4/1 generic R5C822 SD/SDIO/MMC/MS/MSPro Host Ad
/0/100/14.4/1.1 generic R5C843 MMC Host Controller
/0/101 bridge K8 [Athlon64/Opteron] HyperTranspor
/0/102 bridge K8 [Athlon64/Opteron] Address Map
/0/103 bridge K8 [Athlon64/Opteron] DRAM Controll
/0/104 bridge K8 [Athlon64/Opteron] Miscellaneous
/1 power Sanyo DELLUD2647
Linux LinuxLaptop 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 athlon i386 GNU/Linux
 Manufacturer: Dell Inc.
 Product Name: Inspiron 1501
 Manufacturer: Dell Inc.
 Product Name: 0UW744
 Manufacturer: Dell Inc.
 Manufacturer: AMD
 Manufacturer: Not Specified
 Manufacturer: Not Specified
 Manufacturer: Sanyo DELLUD2647
 SBDS Manufacture Date: 1980-00-00
lo no wireless extensions.

eth0 no wireless extensions.

# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
blacklist b43
blacklist b43legacy
blacklist bcm43xx
blacklist brcm80211
install wl modprobe -r b43 b44 b43legacy ssb; modprobe --ignore-install wl ; modprobe --ignore-install b44
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist uart6850
blacklist twl4030_wdt
> hal.1: read hal dataprocess 1939: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
29: PCI 500.0: 0280 Network controller
  [Created at pci.318]
  Unique ID: Ddhb.AUabv0M9SM3
  Parent ID: H0_h.bsmdjgJdggA
  SysFS ID: /devices/pci0000:00/0000:00:06.0/0000:05:00.0
  SysFS BusID: 0000:05:00.0
  Hardware Class: network
  Model: "Dell Wireless 1390 WLAN Mini-Card"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4311 "BCM4311 802.11b/g WLAN"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0007 "Wireless 1390 WLAN Mini-Card"
  Revision: 0x01
  Driver: "b43-pci-bridge"
  Driver Modules: "ssb"
  Memory Range: 0xc0200000-0xc0203fff (rw,non-prefetchable)
  IRQ: 18 (no events)
  Module Alias: "pci:v000014E4d00004311sv00001028sd00000007bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is active
    Driver Activation Cmd: "modprobe ssb"
  Driver Info #1:
    Driver Status: wl is active
    Driver Activation Cmd: "modprobe wl"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #11 (PCI bridge)

30: PCI 800.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.HQwXbECfpC4
  Parent ID: qscc.ULOo3yhA66C
  SysFS ID: /devices/pci0000:00/0000:00:14.4/0000:08:00.0
  SysFS BusID: 0000:08:00.0
  Hardware Class: network
  Model: "Broadcom BCM4401-B0 100Base-TX"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x170c "BCM4401-B0 100Base-TX"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x01f5
  Revision: 0x02
  Driver: "b44"
  Driver Modules: "ssb", "b44"
  Device File: eth0
  Memory Range: 0xc0300000-0xc0301fff (rw,non-prefetchable)
  IRQ: 21 (19930 events)
  HW Address: 00:19:b9:5e:c6:76
  Link detected: yes
  Module Alias: "pci:v000014E4d0000170Csv00001028sd000001F5bc02sc00i00"
  Driver Info #0:
    Driver Status: b44 is active
    Driver Activation Cmd: "modprobe b44"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #23 (PCI bridge)

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
Module Size Used by
parport_pc 32111 0
ppdev 12849 0
joydev 17322 0
snd_hda_codec_idt 60537 1
binfmt_misc 13213 1
snd_hda_intel 24140 2
snd_hda_codec 90901 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 13274 1 snd_hda_codec
radeon 896428 3
snd_pcm 80244 2 snd_hda_intel,snd_hda_codec
b44 35301 0
snd_seq_midi 13132 0
snd_rawmidi 25269 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
ttm 65184 1 radeon
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
drm_kms_helper 40745 1 radeon
ssb 45942 1 b44
drm 180037 5 radeon,ttm,drm_kms_helper
dell_wmi 12601 0
snd_timer 28659 2 snd_pcm,snd_seq
sparse_keymap 13666 1 dell_wmi
dell_laptop 13515 0
psmouse 73312 0
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
dcdbas 14054 1 dell_laptop
wl 2642531 0
serio_raw 12990 0
i2c_algo_bit 13184 1 radeon
snd 55295 13 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
sp5100_tco 13456 0
soundcore 12600 1 snd
i2c_piix4 13095 0
snd_page_alloc 14073 2 snd_hda_intel,snd_pcm
k8temp 12872 0
ati_agp 13202 0
shpchp 32345 0
lib80211 14570 1 wl
video 18951 0
lp 13349 0
parport 36746 3 parport_pc,ppdev,lp
usbhid 41704 0
hid 77084 1 usbhid
ahci 21591 2
sdhci_pci 13623 0
libahci 25548 1 ahci
sdhci 22720 1 sdhci_pci
pata_atiixp 12968 0
jim@LinuxLaptop:~$

Your wireless adapter BCM4311 is not using the wl driver (contained in bcmwl-kernel-source), because it wants the b43 driver instead. But you blacklisted the b43 driver that is required here.

I suggest running the following Terminal commands to try to fix the damage:

sudo apt-get update

sudo apt-get remove bcmwl-kernel-source

sudo rm /etc/modprobe.d/blacklist-bcm43.conf

sudo apt-get install b43-fwcutter firmware-b43-installer

After installing b43-fwcutter and firmware-b43-installer, make sure to REBOOT your PC!!

Then run the following Terminal commands:

sudo modprobe -r b43 b44 b43legacy ssb

sudo modprobe b43

Then RETEST wireless.

James Cooper (uncas) said : #4

Mark:

Yes, this fixed the problem. After I entered the final command the light was still out, but it came on line when I pressed Function-F2 which is the keyboard control (yes, I tried this before and it didn't work). Thank you!

One comment that might be useful to the programmers preparing the installation disk, I did not make any adjustments manually. If the b43 driver was "blacklisted" it was done by the installation program itself, not by me. And it happened both when I did the update from within 10.10 and when I later did a clean install from the 11.04 installation CD.

Thanks again for your help,

Jim

I am pretty sure now that your wireless adapter was experiencing the following Broadcom driver bug in Ubuntu 11.04:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677

As I understand it now , there are 2 possible solutions for the BCM4311 wireless problem in Ubuntu 11.04:

1) installing b43-fwcutter and firmware-b43-installer as described here:

https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/157369

or

2) manually installing bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu5) from maverick (Ubuntu 10.10) using gdebi

Solution 2 is described here:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677/comments/23