Wireless is Off after Upgrade 10.10 to 11.04

Asked by Eric Moon

Problem: Wireless BCM4311 unavailable after upgrade from 10.10 to 11.04, wireless switch does not turn on the wireless indicator light. I hate to create another post on wireless troubleshooting but my wireless connection worked without my intervention in 10.10 and most of the more detailed troubleshooting I'm finding on the forums relates to much older versions of Ubuntu. So, I'm going to try to get help. Ideally the information below will show that I've already been studying a fix and ideally it will help someone with more knowledge than me see what I'm doing wrong. I appreciate the help in advance.

Environment: Dell Latitude D620 bios v A10, Ubuntu 11.04 64 bit.

How I got here:

1. Upgraded Ubuntu 10.10 to 11.04. (Upgraded, not fresh install)
2. Within 11.04 Unity: Additional Drivers Module states I'm using Broadcom STA wireless driver; with the status “This driver is active and currently in use.
3. Installed Wicd. Neither Wicd Network Manager or Devices Network Tools show Wireless as an Network Device choice for configuration. I didn't need Wicd in 10.10, just tried it to see if it would help.
4. Booting into Bios Settings reveals that I have the wireless switch set to turn on or off the wireless and bluetooth radios. If I turn the switch off, Bluetooth turns off within Ubuntu. If I turn the switch on Bluetooth turns on. I get nothing indicating that wireless is turning on/off and as mentioned the above GUIs don't see anything to configure. In 10.10 I could see on the physical machine a wireless indicator light turn off and on, plus I could see the status in Ubuntu change from off/on.
5. My function key + keyboard doesn't have a keyboard shortcut for wireless. I have tried Fn+F2 as found in some of the troubleshooting guides but this didn't do anything probably because it doesn't apply to my keyboard.
6. Terminal: sudo apt-get update; sudo apt-get --reinstall install bcmwl-kernel-source; reboot machine doesn't fix the issue, but after reboot Additional Drivers Modules still states the Broadcom STA wireless driver is active and currently in use
7. Terminal outputs:

 ~$ iwconfig

 lo no wireless extensions.

 eth0 no wireless extensions.

 vboxnet0 no wireless extensions.

 COMMENTS: Is there a way to assign a logical name to wireless (i.e. eth1)? Is this the problem?


 ~$ sudo lshw -C network

 [sudo] password for emoon:

 *-network UNCLAIMED

 description: Network controller

            product: BCM4311 802.11b/g WLAN

        vendor: Broadcom Corporation

        physical id: 0

        bus info: pci@0000:0c:00.0

        version: 01

        width: 32 bits

        clock: 33MHz

        capabilities: pm msi pciexpress bus_master cap_list

        configuration: latency=0

        resources: memory:ecffc000-ecffffff

COMMENTS: Obviously the “UNCLAIMED” status is a problem and perhaps that is the key to the next step in the solution. In the troubleshooting guide https://help.ubuntu.com/10.04/internet/C/troubleshooting-wireless.html#troubleshooting-wireless-ndiswrapper I'm directed to using the Windows drivers tutorial but I'm curious why I need to do that when 10.10 didn't need it. Plus, when I go to the Broadcom link http://www.broadcom.com/docs/linux_sta/README.txt it states Ubuntu already has a built in driver (which I stated is active and currently in use in #2 above).


 ~$ lspci -n | grep 14e4

 09:00.0 0200: 14e4:1600 (rev 02)

 0c:00.0 0280: 14e4:4311 (rev 01)


~$ sudo lsmod | grep "b43\|ssb\|wl"

[sudo] password for emoon:

wl 2568244 0

lib80211 14991 1 wl

Question information

English Edit question
Ubuntu gnome-nettool Edit question
No assignee Edit question
Solved by:
Eric Moon
Last query:
Last reply:
Revision history for this message
Eric Moon (tetrasanyu) said :

One more Terminal output. I'm curious if lacking a wl.ko is the issue and therefore manually building a wl.ko is the direction I need to take.

:/lib/modules/2.6.38-8-generic/kernel/net/wireless$ dir
cfg80211.ko lib80211_crypt_tkip.ko lib80211.ko
lib80211_crypt_ccmp.ko lib80211_crypt_wep.ko

Revision history for this message
Eric Moon (tetrasanyu) said :

Thanks to Marco Braida for putting me in the gnome-nettools section. I'm working through the list there to see if I can solve this. One step closer:

:~$ sudo modprobe b43

Does something new. I now see that "Wireless Networks" is checked off, but greyed out is "device not ready (firmware missing)"

Revision history for this message
Eric Moon (tetrasanyu) said :

:~$ sudo modprobe b43

Changed the Additional Drivers status for Broadcom STA to active but not in use. So now I can see in Network Manager that Wireless is enabled but the firmware is missing.

:~$ sudo apt-get install b43-fwcutter

reboot with same status

:~$ lspci -vvnn | grep 14e4
09:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express [14e4:1600] (rev 02)
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)

Revision history for this message
Eric Moon (tetrasanyu) said :

:~$ sudo lshw -C network; cat /etc/lsb-release; rfkill list
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0c:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:17 memory:ecffc000-ecffffff
       description: Ethernet interface
       product: NetXtreme BCM5752 Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 02
       serial: 00:18:8b:b6:b3:d1
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.116 duplex=full firmware=5752-v3.19 ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:44 memory:ecef0000-ecefffff
  *-network DISABLED
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: 00:19:7d:8c:7f:98
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=2.6.38-8-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: dell-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no
2: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
5: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

Revision history for this message
Eric Moon (tetrasanyu) said :

Here is how I solved this.

I opened Synaptic Package Manager and did a search for b43.
There was a package called firmware-b43-installer and I marked that for installation and it appears to be the trick.

It is important to note that in addition to above I also needed to use:
:~$ sudo modprobe b43
And because that is needed I did:
:~$ gksudo gedit /etc/rc.local

and added modprobe b43 above the exit 0 line

My thanks again to Marco Braida for getting me into the correct que and to actionparsnip who solved someone elses problem which lead me to edit the rc.local file.

And just in case someone else is reading this and the above is not the answer here is what I did just prior to the above:

In Synaptic Package Manager I selected Complete Removal for b43-fwcutter & I went to the Additional Drivers module and removed the proprietary driver for Broadcom STA wireless driver and then I rebooted the machine. I then installed the b43-fwcutter, activated the Broadcom STA, and after it was still not working I did the above solution by marking the firmware-b43-installer for installation and did the sudo modprobe b43 command and that is when my wireless light lit up and I was able to connect.

Hope this post helps someone.

Revision history for this message
John (suffring) said :

Hi Eric,

Just wanted to say thanks....and a big one at that.. ..your detail is extraordinary. I have to admit i didn't understand more than 80% of it, but tucked away in there is solid gold (the last bit) and it solved my problem. Considering it seems to be a big issue by the number of posts, you should be given an award. By the way I didn't need to remove any files or drivers. Cheers.

Revision history for this message
Aner Alexander (anerjja) said :

Thank you Eric. This trick fixed the problem instantly! I was not upgrading, I simply installed 11.04 using the Windows installer, and ran into this problem. Before that, I also had to go to additional drivers and install the Broadcom STA Driver.

I think this error will be experienced by many more people.

Revision history for this message
Rodney Hooker (reh1971) said :

Your solution worked on my Dell Latitude D830 + Ubuntu 11.04 as well. The symptoms matched yours to a tee, and the solution works perfectly.


Revision history for this message
d.r.fairday (drfairday) said :

Exact same set of symptoms and the solution worked, on a HP DV9000. ++ :)

Revision history for this message
CDSRV TechSupport (cdsrv) said :

can we get the steps again please?

Installing clean 11.04, what is needed and in what order? I ended up with both interfaces "UNCLAIMED" after many hours of similar tinkering.. ( this is the second clean install that's been broken by this experimentation..)

STEPS: (??)

: Complete Removal for b43-fwcutter ( this isn't installed by default..)

: remove Broadcom STA

: install b43-fwcutter

: activate Broadcom STA

: firmware-b43-installer

: sudo modprobe b43


Revision history for this message
Eric Moon (tetrasanyu) said :

CDSRV Tech Support: It is important to note that I was on 10.10 prior to 11.04 and did an upgrade. My 10.10 wireless worked prior to the upgrade routine and after upgrading to 11.04 it no longer worked. That is the key. With your description of your issue I am not sure that your issue is the same. Did you formerly have a working wireless connection on 10.10 and then did a clean install of 11.04 or do you know if 10.10 has the same wireless problems that you are now experiencing? The point is, you may have a different problem that needs its own support ticket. You might visit https://help.ubuntu.com/10.04/internet/C/troubleshooting-wireless.html#troubleshooting-wireless-ndiswrapper to see if there is something there that helps you narrow down the issue.

Revision history for this message
CDSRV TechSupport (cdsrv) said :

yes its correct that the original issue here was related to an upgrade, but this thread was one of the only relevant search results / posts that cites the manual compile issues for the broadcom driver..

there were oddities with the BCM4311 in 9.04.. this required the firmware cutter.. at some point, probably 9.10, the supported method of doing this, "install additional drivers" tool worked correctly from the start, no need to add any packages or run any commands, etc, etc, etc... this has worked flawlessly on every upgrade or clean install up to and including 10.10 with the latest kernel patches and updates...

there are numerous threads that are related to this overall issue with the broadcom drivers - some say they've solved the problem but none are really the same..

short answer is that "wireless is STILL broken after upgrading to 11.04" and trying every suggestion known to the forums..

wireless/ network setup during installation always seems to require going online to download the driver - somewhat of a conundrum, especially since (in this case) broadcom has released source for the drivers..

what can we do to debug this, its quite complex!

Revision history for this message
Eric Moon (tetrasanyu) said :

I am new to Launchpad so I am not 100% sure that this post will be followed by a more informed user if your particular environment/configuration happens to be a bug or other 11.04 configuration issue. I think my particular case illustrates a solution to a very specific pathway but does not fit every wireless issue.

10.10 wireless "just worked" with my particular wireless device that I am using for 11.04 and by following the instructions in the link below I was able to piece together some of the ideas from other support cases to find what worked for me. I then attempted to outline within my case what I did, in hopes that it was enough detail for others to work through their issue if theirs was similar enough to mine without having to search for additional support pages.

One of the issues that we are dealing with is the issue of Open Source vs Closed Source and what comes standard with an install of Ubuntu vs what one might need or want to have "enabled" on their particular machine that may not have an Open Source solution. I don't think we're ever going to get away from this conundrum because generally speaking a Closed Source solution will not be picked automatically for the user. At least this is my take on the situation and is my "rational" that some of the setup issues remain complex. What I do appreciate is the lessons I learned and the tools I found by having this issue. I know a little more about Ubuntu know that I knew before and that is always a good thing.

It is possible that your solution is to use the NDISWrapper solution which allows Ubuntu to use downloaded wireless drivers from the manufacture of your device that were designed for Windows.

You can find the instructions here:

If the above troubleshooting doesn't work (remembering the basics that I know personally I tend to skip over when looking for a quick fix like permissions issues, BIOS issues, and general network configuration), I would recommend creating a new case with your specific details and posting within that case the results for the command line:

sudo lshw -C network

There is a higher probability that someone with better skill will see your post and be able to help you.

Revision history for this message
CDSRV TechSupport (cdsrv) said :

thanks for the intelligent feedback.

bottom line is that this subsystem worked fine for a few years and now isn't.. hopefully all the smart people can get it solved so that it 'just works' like it should.

looking into it has certainly been educational and informative, but a little un-nerving given the importance of having network connectivity on a system...

the licensing issues are an inconvenience, but certainly not the source of the technical problems.

time to run some more tests.. more later.

Revision history for this message
Eric Moon (tetrasanyu) said :

CDSRV Tech Support, just checking in with you. I ran across this link today. I'm wondering if some of the alternate methods mentioned in this conversation chain might fit your environment better than what I needed to fix my issue.


Specifically this sequence which appears to be in a few places on the web from Google search:

•open the 'Synaptic Package Manager' and search for 'bcm'

•uninstall the 'bcm-kernel-source' package

•make sure that the 'firmware-b43-installer' and the 'b43-fwcutter' packages are installed

•type into terminal:

cat /etc/modprobe.d/* | egrep '8180|acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl'
(you may want to copy this) and see if the term 'blacklist bcm43xx' is there

•if it is, type cd /etc/modprobe.d/ and then sudo gedit blacklist.conf

put a # in front of the line: blacklist bcm43xx

then save the file (I was getting error messages in the terminal about not being able to save, but it actually did save properly).


Revision history for this message
CDSRV TechSupport (cdsrv) said :

confirming this fix works.. wish I had found it sooner - thanks for the extra help there..


steps taken:

1) clean install & reboot
2) DON'T ADD "additional drivers" -- add the two b43 packages listed (firmware-b43-installer and b43-fwcutter)-- bcm-kernel-source was not installed
3) comment out the bcm43xx line in the blacklist.conf


its important to note that installing and 'randomly' installing removing other broadcom related driver packages can end up breaking the entire networking setup - (UNCLAIMED interfaces, or they just disappear)- we didn't test this thoroughly, just ended up with a mess after trying various things suggested in other posts..

hopefully this can get addressed in the 'additional drivers' app -- it certainly looks like its affecting a good number of people..


Revision history for this message
SodaMan (sodanet) said :

After upgrade to 11.04 my wireless stop to work. I opened Additional Driver menu and deactivated Broadcom STA proprietary driver and my wireless started. I wonder if there is someone who doesn't regret upgrading to 11.04.

Revision history for this message
Rob Baines (rob-thebaines) said :

Exactly the same symptoms on my D620, adding the modprobe b43 worked for me, thanks Eric