11.04 No Wireless - problem

Asked by Ruben Ackerman on 2011-04-30

Acer Aspire 5251 with a Broadcom BCM43225 802.11b/g/n (rev 01) Everything seems to works except the Wireless. At boot, just before the sign-on screen the Wireless light will flash for a second - then go out. Have tried all the different fixes as seen. I can put in a 10.10 disk and get wireless so I know the computer is good. I'm getting some errors in / on the terminal page: (for this form I deleted the extra lines that looked normal) I may have done to much in that at one point the wireless light came on and it worked until re-boot - then/ since now the light will on even come on during boot. I think it's something in the boot package? My drivers seem to be installed.
runen@runen-Aspire-5251:~$ sudo apt-get --purge remove bcmwl-kernel-source

0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.

Setting up firmware-b43-lpphy-installer (4.174.64.19-5) ...
Not supported card here (PCI id 14e4:1692
14e4:4357)!
Use proper b43 or b43legacy firmware.
Aborting.
dpkg: error processing firmware-b43-lpphy-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 firmware-b43-lpphy-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2011-05-04
Last reply:
2011-05-01

Hi,

Please first connect your wired network adapter to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->Terminal"

Step 2: Please copy-paste the following command from the https://answers.launchpad.net/ubuntu website in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word lsmod. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get --purge remove firmware-b43-lpphy-installer ; sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt6|rt7|usb|witch|wl'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl'; sudo hwinfo --netcard ; cat /var/lib/NetworkManager/NetworkManager.state; sudo lsmod

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Step 4: Please also clarify if you installed Ubuntu to the harddisk and are running from a harddisk install OR if you are only testing Ubuntu in a LiveCD session.

Regards,

Mark

Ruben Ackerman (ackermrd) said : #2

1. I messed up - did not see the link to this page - I copied and pasted from the e-mail
2. I've been running 10.10 since last Oct. 2010 with two problems. Thought the upgrade would fix them.
     a. when printing a pdf file from a .gov - when print was pressed... computer would reset back to sign on screen.
     b. when using Skype - the outgoing audio would stop.
          10.10 was other wise working great on this laptop.
3. I did the upgrade Apr 28th - started at 11A.M and did not finish until 11:05 p.m. - 12 hours of down load/ upgrade.
     a. lost the wireless light and would not/ could not find wireless even after reinstalling from system/admin/add drivers
     b, had to use my 10.10 live disc to get to the internet that night - next day 29th I used my lan line hard line to get on line
4. I am going to paste the 'first' oops' from the e-mail paste' and yes I did messup my password

     runen@runen-Aspire-5251:~$ sudo apt-get --purge remove firmware-b43-lpphy-installer ; sudo apt-get
[sudo] password for runen:
Sorry, try again.
[sudo] password for runen:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  ttf-lyx
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  firmware-b43-lpphy-installer*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 49.2 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 256507 files and directories currently installed.)
Removing firmware-b43-lpphy-installer ...
Purging configuration files for firmware-b43-lpphy-installer ...
apt 0.8.13.2ubuntu3 for i386 compiled on Apr 26 2011 17:43:01
Usage: apt-get [options] command
       apt-get [options] install|remove pkg1 [pkg2 ...]
       apt-get [options] source pkg1 [pkg2 ...]

apt-get is a simple command line interface for downloading and
installing packages. The most frequently used commands are update
and install.

Commands:
   update - Retrieve new lists of packages
   upgrade - Perform an upgrade
   install - Install new packages (pkg is libc6 not libc6.deb)
   remove - Remove packages
   autoremove - Remove automatically all unused packages
   purge - Remove packages and config files
   source - Download source archives
   build-dep - Configure build-dependencies for source packages
   dist-upgrade - Distribution upgrade, see apt-get(8)
   dselect-upgrade - Follow dselect selections
   clean - Erase downloaded archive files
   autoclean - Erase old downloaded archive files
   check - Verify that there are no broken dependencies
   markauto - Mark the given packages as automatically installed
   unmarkauto - Mark the given packages as manually installed
   changelog - Download and display the changelog for the given package
   download - Download the binary package into the current directory

Options:
  -h This help text.
  -q Loggable output - no progress indicator
  -qq No output except for errors
  -d Download only - do NOT install or unpack archives
  -s No-act. Perform ordering simulation
  -y Assume Yes to all queries and do not prompt
  -f Attempt to correct a system with broken dependencies in place
  -m Attempt to continue if archives are unlocatable
  -u Show a list of upgraded packages as well
  -b Build the source package after fetching it
  -V Show verbose version numbers
  -c=? Read this configuration file
  -o=? Set an arbitrary configuration option, eg -o dir::cache=/tmp
See the apt-get(8), sources.list(5) and apt.conf(5) manual
pages for more information and options.
                       This APT has Super Cow Powers.
runen@runen-Aspire-5251:~$

5. Copy and Paste #2 looks like the file was to big for the terminal block it overran the space:
             oh - ps. Last night I reloaded 10.10 as a dull boot system and it works pulled some of my files from 11.04 over to 10.10
              so that I could still get on the internet. If we can find this problem - great...hope that I did not mess up this install by
              all the 'hacking' I did. I did try about 5 or more of the 'fixes' posted. One of the posts worked until I reset the computer
              then it stopped being able to delete and and the software drivers in terminal i.e. "0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded. 1 not fully installed or removed. "

Hit http://us.archive.ubuntu.com natty/multiverse Sources
Hit http://us.archive.ubuntu.com natty/universe Sources
Hit http://us.archive.ubuntu.com natty/main i386 Packages
Hit http://us.archive.ubuntu.com natty/restricted i386 Packages
Hit http://us.archive.ubuntu.com natty/universe i386 Packages
Hit http://us.archive.ubuntu.com natty/multiverse i386 Packages
Ign http://us.archive.ubuntu.com natty/main TranslationIndex
Ign http://us.archive.ubuntu.com natty/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com natty/restricted TranslationIndex
Ign http://us.archive.ubuntu.com natty/universe TranslationIndex
Hit http://us.archive.ubuntu.com natty-updates/restricted Sources
Hit http://us.archive.ubuntu.com natty-updates/main Sources
Hit http://us.archive.ubuntu.com natty-updates/multiverse Sources
Hit http://us.archive.ubuntu.com natty-updates/universe Sources
Hit http://us.archive.ubuntu.com natty-updates/main i386 Packages
Hit http://us.archive.ubuntu.com natty-updates/restricted i386 Packages
Hit http://us.archive.ubuntu.com natty-updates/universe i386 Packages
Hit http://us.archive.ubuntu.com natty-updates/multiverse i386 Packages
Ign http://us.archive.ubuntu.com natty-updates/main TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/restricted TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/universe TranslationIndex
Hit http://us.archive.ubuntu.com natty-backports/main Sources
Hit http://us.archive.ubuntu.com natty-backports/restricted Sources
Hit http://us.archive.ubuntu.com natty-backports/universe Sources
Hit http://us.archive.ubuntu.com natty-backports/multiverse Sources
Hit http://us.archive.ubuntu.com natty-backports/main i386 Packages
Hit http://us.archive.ubuntu.com natty-backports/restricted i386 Packages
Hit http://us.archive.ubuntu.com natty-backports/universe i386 Packages
Hit http://us.archive.ubuntu.com natty-backports/multiverse i386 Packages
Ign http://us.archive.ubuntu.com natty-backports/main TranslationIndex
Ign http://us.archive.ubuntu.com natty-backports/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com natty-backports/restricted TranslationIndex
Ign http://extras.ubuntu.com natty/main Translation-en_US
Ign http://us.archive.ubuntu.com natty-backports/universe TranslationIndex
Hit http://us.archive.ubuntu.com natty-proposed/restricted Sources
Hit http://us.archive.ubuntu.com natty-proposed/main Sources
Hit http://us.archive.ubuntu.com natty-proposed/multiverse Sources
Hit http://us.archive.ubuntu.com natty-proposed/universe Sources
Hit http://us.archive.ubuntu.com natty-proposed/restricted i386 Packages
Hit http://us.archive.ubuntu.com natty-proposed/main i386 Packages
Hit http://us.archive.ubuntu.com natty-proposed/multiverse i386 Packages
Hit http://us.archive.ubuntu.com natty-proposed/universe i386 Packages
Ign http://extras.ubuntu.com natty/main Translation-en
Ign http://us.archive.ubuntu.com natty-proposed/main TranslationIndex
Ign http://us.archive.ubuntu.com natty-proposed/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com natty-proposed/restricted TranslationIndex
Ign http://us.archive.ubuntu.com natty-proposed/universe TranslationIndex
Ign http://security.ubuntu.com natty-security/main Translation-en_US
Ign http://security.ubuntu.com natty-security/main Translation-en
Ign http://security.ubuntu.com natty-security/multiverse Translation-en_US
Ign http://security.ubuntu.com natty-security/multiverse Translation-en
Ign http://security.ubuntu.com natty-security/restricted Translation-en_US
Ign http://security.ubuntu.com natty-security/restricted Translation-en
Ign http://security.ubuntu.com natty-security/universe Translation-en_US
Ign http://security.ubuntu.com natty-security/universe Translation-en
Ign http://archive.canonical.com natty InRelease
Hit http://archive.canonical.com natty Release.gpg
Hit http://archive.canonical.com natty Release
Hit http://archive.canonical.com natty/partner Sources
Hit http://archive.canonical.com natty/partner i386 Packages
Ign http://archive.canonical.com natty/partner TranslationIndex
Ign http://archive.canonical.com natty/partner Translation-en_US
Ign http://archive.canonical.com natty/partner Translation-en
Ign http://us.archive.ubuntu.com natty/main Translation-en_US
Ign http://us.archive.ubuntu.com natty/main Translation-en
Ign http://us.archive.ubuntu.com natty/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com natty/multiverse Translation-en
Ign http://us.archive.ubuntu.com natty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com natty/restricted Translation-en
Ign http://us.archive.ubuntu.com natty/universe Translation-en_US
Ign http://us.archive.ubuntu.com natty/universe Translation-en
Ign http://us.archive.ubuntu.com natty-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/main Translation-en
Ign http://us.archive.ubuntu.com natty-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/multiverse Translation-en
Ign http://us.archive.ubuntu.com natty-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/restricted Translation-en
Ign http://us.archive.ubuntu.com natty-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/universe Translation-en
Ign http://us.archive.ubuntu.com natty-backports/main Translation-en_US
Ign http://us.archive.ubuntu.com natty-backports/main Translation-en
Ign http://us.archive.ubuntu.com natty-backports/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com natty-backports/multiverse Translation-en
Ign http://us.archive.ubuntu.com natty-backports/restricted Translation-en_US
Ign http://us.archive.ubuntu.com natty-backports/restricted Translation-en
Ign http://us.archive.ubuntu.com natty-backports/universe Translation-en_US
Ign http://us.archive.ubuntu.com natty-backports/universe Translation-en
Ign http://us.archive.ubuntu.com natty-proposed/main Translation-en_US
Ign http://us.archive.ubuntu.com natty-proposed/main Translation-en
Ign http://us.archive.ubuntu.com natty-proposed/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com natty-proposed/multiverse Translation-en
Ign http://us.archive.ubuntu.com natty-proposed/restricted Translation-en_US
Ign http://us.archive.ubuntu.com natty-proposed/restricted Translation-en
Ign http://us.archive.ubuntu.com natty-proposed/universe Translation-en_US
Ign http://us.archive.ubuntu.com natty-proposed/universe Translation-en
Fetched 72 B in 10s (7 B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
The following package was automatically installed and is no longer required:
  ttf-lyx
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libhal1 libhd16
The following NEW packages will be installed:
  hwinfo libhal1 libhd16
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 744 kB/818 kB of archives.
After this operation, 2,269 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com/ubuntu/ natty/universe libhd16 i386 16.0-2 [698 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ natty/universe hwinfo i386 16.0-2 [46.1 kB]
Fetched 744 kB in 5s (136 kB/s)
Selecting previously deselected package libhal1.
(Reading database ... 256504 files and directories currently installed.)
Unpacking libhal1 (from .../libhal1_0.5.14-5+svn1_i386.deb) ...
Selecting previously deselected package libhd16.
Unpacking libhd16 (from .../libhd16_16.0-2_i386.deb) ...
Selecting previously deselected package hwinfo.
Unpacking hwinfo (from .../hwinfo_16.0-2_i386.deb) ...
Processing triggers for man-db ...
Setting up libhal1 (0.5.14-5+svn1) ...
Setting up libhd16 (16.0-2) ...
Setting up hwinfo (16.0-2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
  *-network
       description: Ethernet interface
       product: NetLink BCM57780 Gigabit Ethernet PCIe
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 01
       serial: 70:5a:b6:d7:bb:b8
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.116 duplex=full firmware=sb ip=192.168.2.4 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:43 memory:91100000-9110ffff
  *-network DISABLED
       description: Wireless interface
       product: BCM43225 802.11b/g/n
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: wlan0
       version: 01
       serial: 78:e4:00:08:a5:c6
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=brcm80211 driverversion=2.6.38-8-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:91000000-91003fff
0: acer-wireless: Wireless LAN
 Soft blocked: yes
 Hard blocked: no
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS880 Host Bridge [1022:9601]
00:01.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (int gfx) [1022:9602]
00:04.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0) [1022:9604]
00:05.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1) [1022:9605]
00:11.0 SATA controller [0106]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391]
00:12.0 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
00:12.2 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 41)
00:14.1 IDE interface [0101]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 IDE Controller [1002:439c] (rev 40)
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller [1002:439d] (rev 40)
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384] (rev 40)
00:14.5 USB Controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI2 Controller [1002:4399]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration [1022:1200]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor Address Map [1022:1201]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller [1022:1202]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control [1022:1203]
00:18.4 Host bridge [0600]: Advanced Micro Devices [AMD] Family 10h Processor Link Control [1022:1204]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc M880G [Mobility Radeon HD 4200] [1002:9712]
01:05.1 Audio device [0403]: ATI Technologies Inc RS880 Audio Device [Radeon HD 4200] [1002:970f]
02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe [14e4:1692] (rev 01)
08:00.0 Network controller [0280]: Broadcom Corporation BCM43225 802.11b/g/n [14e4:4357] (rev 01)
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 045e:0745 Microsoft Corp.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 064e:a219 Suyin Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
====================================================
                             system Notebook
/0 bus Aspire 5251
/0/0 memory 1MiB BIOS
/0/20 processor AMD V120 Processor
/0/20/21 memory 128KiB L1 cache
/0/20/22 memory 512KiB L1 cache
/0/23 memory 2GiB System Memory
/0/23/0 memory 1GiB DIMM DDR3 Synchronous 1066 MHz (0.
/0/23/1 memory 1GiB DIMM DDR3 Synchronous 1066 MHz (0.
/0/100 bridge RS880 Host Bridge
/0/100/1 bridge RS780/RS880 PCI to PCI bridge (int gfx)
/0/100/1/5 display M880G [Mobility Radeon HD 4200]
/0/100/1/5.1 multimedia RS880 Audio Device [Radeon HD 4200]
/0/100/4 bridge RS780 PCI to PCI bridge (PCIE port 0)
/0/100/4/0 eth0 network NetLink BCM57780 Gigabit Ethernet PCIe
/0/100/5 bridge RS780 PCI to PCI bridge (PCIE port 1)
/0/100/5/0 wlan0 network BCM43225 802.11b/g/n
/0/100/11 scsi2 storage SB7x0/SB8x0/SB9x0 SATA Controller [AHCI
/0/100/11/0 /dev/sda disk 320GB WDC WD3200BEVT-0
/0/100/11/0/1 /dev/sda1 volume 92GiB EXT4 volume
/0/100/11/0/2 /dev/sda2 volume 205GiB Extended partition
/0/100/11/0/2/5 /dev/sda5 volume 5999MiB Linux swap / Solaris partition
/0/100/11/0/2/6 /dev/sda6 volume 194GiB Linux filesystem partition
/0/100/11/0/2/7 /dev/sda7 volume 5995MiB Linux swap / Solaris partition
/0/100/11/1 /dev/cdrom disk DVD RW AD-7585H
/0/100/12 bus SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/12.2 bus SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/13 bus SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/13.2 bus SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/14 bus SBx00 SMBus Controller
/0/100/14.1 storage SB7x0/SB8x0/SB9x0 IDE Controller
/0/100/14.2 multimedia SBx00 Azalia (Intel HDA)
/0/100/14.3 bridge SB7x0/SB8x0/SB9x0 LPC host controller
/0/100/14.4 bridge SBx00 PCI to PCI Bridge
/0/100/14.5 bus SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
/0/101 bridge Family 10h Processor HyperTransport Con
/0/102 bridge Family 10h Processor Address Map
/0/103 bridge Family 10h Processor DRAM Controller
/0/104 bridge Family 10h Processor Miscellaneous Cont
/0/105 bridge Family 10h Processor Link Control
Linux runen-Aspire-5251 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 athlon i386 GNU/Linux
[ 0.004938] SMP alternatives: switching to UP code
[ 0.077120] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 0.082072] Switch to broadcast mode on CPU0
[ 0.216608] ACPI: No dock devices found.
[ 0.216610] HEST: Table not found.
[ 0.251576] usbcore: registered new interface driver usbfs
[ 0.251586] usbcore: registered new interface driver hub
[ 0.251605] usbcore: registered new device driver usb
[ 0.254306] Switching to clocksource hpet
[ 0.254313] Switched to NOHz mode on CPU #0
[ 0.324084] pnp: PnP ACPI: found 10 devices
[ 0.548456] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input2
[ 0.548559] ACPI: Lid Switch [LID]
[ 0.624507] ERST: Table is not found!
[ 0.627440] i2c-core: driver [adp5520] using legacy suspend method
[ 0.627441] i2c-core: driver [adp5520] using legacy resume method
[ 0.632582] ehci_hcd 0000:00:12.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
[ 0.644581] hub 1-0:1.0: USB hub found
[ 0.644868] ehci_hcd 0000:00:13.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
[ 0.698008] hub 2-0:1.0: USB hub found
[ 0.904866] hub 3-0:1.0: USB hub found
[ 0.976435] hub 4-0:1.0: USB hub found
[ 1.140267] hub 5-0:1.0: USB hub found
[ 1.216517] isapnp: No Plug & Play device found
[ 1.232052] device-mapper: multipath: version 1.2.0 loaded
[ 1.232056] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 1.233972] powernow-k8: Found 1 AMD V120 Processor (1 cpu cores) (version 2.20.00)
[ 1.234563] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 1.275668] usb 2-1: new high speed USB device using ehci_hcd and address 2
[ 1.508088] Switching to clocksource tsc
[ 1.560212] tg3 0000:02:00.0: eth0: Tigon3 [partno(BCM57780) rev 57780001] (PCI Express) MAC address 70:5a:b6:d7:bb:b8
[ 1.560216] tg3 0000:02:00.0: eth0: attached PHY driver [Broadcom BCM57780] (mii_bus:phy_addr=200:01)
[ 1.560220] tg3 0000:02:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[ 1.560223] tg3 0000:02:00.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]
[ 1.724087] usb 3-1: new full speed USB device using ohci_hcd and address 2
[ 1.925256] input: Microsoft Microsoft® Nano Transceiver v2.0 as /devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1:1.0/input/input5
[ 1.925399] generic-usb 0003:045E:0745.0001: input,hidraw0: USB HID v1.11 Keyboard [Microsoft Microsoft® Nano Transceiver v2.0] on usb-0000:00:12.0-1/input0
[ 1.933908] input: Microsoft Microsoft® Nano Transceiver v2.0 as /devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1:1.1/input/input6
[ 1.934374] generic-usb 0003:045E:0745.0002: input,hidraw1: USB HID v1.11 Mouse [Microsoft Microsoft® Nano Transceiver v2.0] on usb-0000:00:12.0-1/input1
[ 1.960297] input: Microsoft Microsoft® Nano Transceiver v2.0 as /devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1:1.2/input/input7
[ 1.960642] generic-usb 0003:045E:0745.0003: input,hiddev0,hidraw2: USB HID v1.11 Device [Microsoft Microsoft® Nano Transceiver v2.0] on usb-0000:00:12.0-1/input2
[ 1.960765] usbcore: registered new interface driver usbhid
[ 1.960767] usbhid: USB HID core driver
[ 15.234094] lp: driver loaded but no devices found
[ 16.292256] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 16.557145] tg3 0000:02:00.0: eth0: Link is down
[ 17.090941] uvcvideo: Found UVC 1.00 device 1.3M WebCam (064e:a219)
[ 17.113633] input: 1.3M WebCam as /devices/pci0000:00/0000:00:13.2/usb2/2-1/2-1:1.0/input/input9
[ 17.113770] usbcore: registered new interface driver uvcvideo
[ 17.649834] Found chip type AI (0x13a1a8d9)
[ 17.659899] wlc_bmac_attach:: deviceid 0x4357 nbands 1 board 0xe021 macaddr: 78:e4:00:08:a5:c6
[ 17.726961] input: HDA ATI SB Mic as /devices/pci0000:00/0000:00:14.2/sound/card0/input12
[ 17.727164] input: HDA ATI SB Headphone as /devices/pci0000:00/0000:00:14.2/sound/card0/input13
[ 17.792640] wl_set_hint: Sending country code US to MAC80211
[ 17.792646] wl0: Broadcom BCM43xx 802.11 MAC80211 Driver (1.82.8.0) (Compiled at 04:45:00 on Apr 11 2011)
[ 17.925588] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 18.577035] tg3 0000:02:00.0: eth0: Link is up at 100 Mbps, full duplex
[ 18.577040] tg3 0000:02:00.0: eth0: Flow control is on for TX and on for RX
[ 18.577274] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 18.721054] Console: switching to colour frame buffer device 170x48
[ 23.218933] Broadcom 43xx driver loaded [ Features: PNL, Firmware-ID: FW13 ]
[ 24.725104] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.
[ 28.624028] eth0: no IPv6 routers present
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=19 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off

# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist uart6850
blacklist twl4030_wdt
> hal.1: read hal dataprocess 2667: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
30: PCI 200.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.r0BdbIw7xqB
  Parent ID: 8otl.evobqRX2ya4
  SysFS ID: /devices/pci0000:00/0000:00:04.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Broadcom Ethernet controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x1692
  SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
  SubDevice: pci 0x036e
  Revision: 0x01
  Driver: "tg3"
  Driver Modules: "tg3"
  Device File: eth0
  Memory Range: 0x91100000-0x9110ffff (rw,non-prefetchable)
  IRQ: 43 (2259 events)
  HW Address: 70:5a:b6:d7:bb:b8
  Link detected: yes
  Module Alias: "pci:v000014E4d00001692sv00001025sd0000036Ebc02sc00i00"
  Driver Info #0:
    Driver Status: tg3 is active
    Driver Activation Cmd: "modprobe tg3"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

31: PCI 800.0: 0282 WLAN controller
  [Created at pci.318]
  Unique ID: y9sn.+_yeFkco2S1
  Parent ID: CvwD.9KlLJ0flTz4
  SysFS ID: /devices/pci0000:00/0000:00:05.0/0000:08:00.0
  SysFS BusID: 0000:08:00.0
  Hardware Class: network
  Model: "Broadcom WLAN controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4357
  SubVendor: pci 0x105b "Foxconn International, Inc."
  SubDevice: pci 0xe021
  Revision: 0x01
  Driver: "brcm80211"
  Driver Modules: "brcm80211"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0x91000000-0x91003fff (rw,non-prefetchable)
  IRQ: 17 (58 events)
  HW Address: 78:e4:00:08:a5:c6
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d00004357sv0000105Bsd0000E021bc02sc80i00"
  Driver Info #0:
    Driver Status: brcm80211 is active
    Driver Activation Cmd: "modprobe brcm80211"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #11 (PCI bridge)

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
Module Size Used by
iptable_filter 12706 1
b43 296610 0
ip_tables 18125 1 iptable_filter
x_tables 21907 2 iptable_filter,ip_tables
ssb 45942 1 b43
snd_hda_codec_hdmi 27479 1
binfmt_misc 13213 1
arc4 12473 2
snd_hda_codec_realtek 255820 1
snd_hda_intel 24140 2
snd_hda_codec 90901 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13274 1 snd_hda_codec
snd_pcm 80244 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
radeon 896428 3
snd_seq_midi 13132 0
brcm80211 690428 0
snd_rawmidi 25269 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
ppdev 12849 0
ttm 65184 1 radeon
parport_pc 32111 0
mac80211 257001 2 b43,brcm80211
acer_wmi 23123 0
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
snd_timer 28659 2 snd_pcm,snd_seq
drm_kms_helper 40745 1 radeon
sparse_keymap 13666 1 acer_wmi
uvcvideo 66851 0
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
drm 180037 5 radeon,ttm,drm_kms_helper
snd 55295 14 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
videodev 75143 1 uvcvideo
i2c_algo_bit 13184 1 radeon
joydev 17322 0
cfg80211 156212 3 b43,brcm80211,mac80211
psmouse 73312 0
soundcore 12600 1 snd
shpchp 32345 0
sp5100_tco 13456 0
k10temp 12951 0
i2c_piix4 13095 0
serio_raw 12990 0
snd_page_alloc 14073 2 snd_hda_intel,snd_pcm
video 18951 0
lp 13349 0
parport 36746 3 ppdev,parport_pc,lp
usbhid 41704 0
hid 77084 1 usbhid
ahci 21591 2
tg3 131476 0
libahci 25548 1 ahci
pata_atiixp 12968 0
runen@runen-Aspire-5251:~$

The following Terminal output (that you sent us) shows the issue that your wireless card is having:

"
   *-network DISABLED
       description: Wireless interface
       product: BCM43225 802.11b/g/n

0: acer-wireless: Wireless LAN
 Soft blocked: yes
 Hard blocked: no

wlan0 Interface doesn't support scanning : Network is down
"

So your wireless card is disabled by a hardware switch, a
special key combination (Fn-F2, etc...), by incorrect BIOS settings for
wireless, or a COMBINATION of these factors...

There might also be a BIOS option that allows you to have the wireless
functionality controlled "By application"

Search for the "by application" option in the BIOS and select it (if
possible)....

Also run the following 2 Terminal commands to try to change the rfkill
state of your wireless chipset:

rfkill unblock all

sudo rfkill unblock all

Then retest wireless.

Ruben Ackerman (ackermrd) said : #4

I have done the following:
1. Again today I ran:
sudo apt-get update
sudo apt-get --reinstall install bcmwl-kernel-source
2. Then
synaptic install: firmware-b43-lpphy-installer
3. I ran your rfkill unblock all
rfkill unblock all

4. Then I ran : sudo rfkill unblock all

5. I reset system/ computer – still no wireless
6. I downloaded 11.04 to a cd and booted from the cd – still no wireless. Wireless will work from a 10.10 cd and from my 10.10 install ( I have made this a dull boot system with 10.10 and 11.04 on it – oh, it came with windows 7 , but I took the drive out and put in a new drive for Ubuntu only).
7. I have looked at the Bios set up and there is no way to set up the wireless as you asked -"by application" option in the BIOS
8. I am going to build a 'new' computer this week from Tiger Direct :
Ecs IC780M-A Kit with a AMD Phenom X4-9750 CPU, 2G DDR2, 500 GB HDD
9. Thanks for your help. Can you please Keep me informed as to any updates that may fix this computer as wireless works fine with other programs. Oh, yes it has a 'hot key' Fn + F3 to control wireless... does not work with 11.04 at all. Looks like its in the set-up program at boot up and is not setting up the hard ware first.
I will be up-dating this 11.04 as time goes by to see if they fix my problem. I will be using 10.10 until I get the fix for 11.04. As it goes, I should have downloaded 11.04 to CD first to check to see if it would have worked on this Acer Aspire 5251 first instead of upgrading on the fly.
10. This was done with 11.04 with hard wire to the internet.

            Ruben Ackerman
             ackermrd@q.com

Can you help with this problem?

Provide an answer of your own, or ask Ruben Ackerman for more information if necessary.

To post a message you must log in.