how i control my internet connection...

Asked by Arvind Kumar Gangwar on 2011-04-16

I am new to ubuntu.
i am want to control my Internet connection, because as soon i start system with Ubuntu OS it bydefult connecting with Internet.
But i want that when i need to connect hen it will connect otherwise it be in disconnected mode.
before that i used Xp where a network connection is appear on desktop from where i connect and disconnect with Internet....so want is ther are any facility to control Internet connection.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Eliah Kagan
Solved:
2011-04-17
Last query:
2011-04-17
Last reply:
2011-04-16

Have already tried to use the top right network icon options... ?

On the top panel right hand side next to the speaker icon you will see the wired network connection icon. Click and then choose disconnect. To reconnect simply follow same process and select connect.

as you describe , in my pannel after speaker there are envelop icon which
provide chat, mai and brodcast icon.
after that there time display
after that again a chat icon with my user name
after that power off icon......
so in my panel there is no wired network icon...so please guide me further.

With Regards!
Arvind Kumar Gangwar
OCJP 6, Preparing for SCWCD
+918087142449

2011/4/16 Aruna Hewapathirane-අරැණ හේවාපතිරණ <
<email address hidden>>

> Your question #153001 on gnome-nettool in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001
>
> Aruna Hewapathirane-අරැණ හේවාපතිරණ proposed the following answer:
> On the top panel right hand side next to the speaker icon you will see
> the wired network connection icon. Click and then choose disconnect. To
> reconnect simply follow same process and select connect.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001/+confirm?answer_id=1
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001
>
> You received this question notification because you are a direct
> subscriber of the question.
>

mycae (mycae) said : #4

try right clicking the "broadcast" icon.

If you press ALT+F2 and run:

nm-applet

does it run?

Hi,
firstly Thanks for suggestion, but as you told, in my condition, either way
of clicking (right or left) a Broadcast Account window open, which give
option for adding or removing any social networking site a/c as facebook,
twitter, digg etc.....but no icon or menu for relented to network, Thus
overall its not solve my problem,
I will appreciate for any more suggestion....which solve my problem.....

With Regards!
Arvind Kumar Gangwar
OCJP 6, Preparing for SCWCD
+918087142449

On Sat, Apr 16, 2011 at 6:10 PM, mycae <<email address hidden>
> wrote:

> Your question #153001 on gnome-nettool in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001
>
> mycae posted a new comment:
> try right clicking the "broadcast" icon.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

Hi actionparsnip,
firstly Thanks for suggestion, but as you told, but when i tried your option
there are no application was run.
So this is also not solve my problem.......But thanks for your effort....

With Regards!
Arvind Kumar Gangwar
OCJP 6, Preparing for SCWCD
+918087142449

On Sat, Apr 16, 2011 at 6:13 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #153001 on gnome-nettool in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001
>
> Status: Open => Needs information
>
> actionparsnip requested for more information:
> If you press ALT+F2 and run:
>
> nm-applet
>
> does it run?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Hi,
Thanks for showing interest to solve my problem,
So firstly i discuss my previous experience with XP..
AS i am using BSNL broadband internet connection, in XP my internet
connection not connected by-default...mean not connected automatically... It
provide local area (BSNL) connection icon on desktop and one in quick launch
in status bar, from where i was connected as when i need as it asked
user-name and passord and after authentication of user-name and password, my
internet connection is connected with BSNL service provider's server.
Thus it provide to control internet connection, as have limited plan upto
1.5 gb per month.
Now As i need ubuntu OS, I install it through cd, which ask me 2 option for
installation of Ubuntu OS, first one as full version and second one is as
inside Windows OS.
And i choose second one , mean inside windows OS, so it provide dual boot
mean at boot time it provide menu to choose Which OS you want to boot with
defult one is WIndows XP, second one is Ubuntu OS.
now my problem is that as soon i boot with Ubuntu OS my internet connection
is connected automatically, which i don't want.
after boot the screen appear is two panel....One is upside one is at bottom.
in upside pannel from left there is menus which are application, places,
system after that mozila icon and after that blank space in panel and in
right side there are some option first one for voice, second one is envelop
which have option for chat, mail, broadcast and third one is a icon for
whether report after that time and date after that another icon for chat and
last one is power icon which provide sumenu such as for hibernate restart
shutdown etc....is the description of upper panel.

So what is my problem....
My problem is that is there is any option to connect or disconnect internet
connection in any menu or at panel in Ubuntu OS, because i don't want that
internet connected automatically as soon i boot Ubuntu OS.

If this whole description is not sufficient to understand my problem then
please tell me what i need to describe my problem...
I giving whole view according to me..but still any doubt then guide in which
way i describe my problem,....

So I will appreciate for any more suggestion....which solve my problem....
Thanks!

With Regards!
Arvind Kumar Gangwar
OCJP 6, Preparing for SCWCD
+918087142449

On Sat, Apr 16, 2011 at 8:54 PM, Arvind Kumar Gangwar <
<email address hidden>> wrote:

> Your question #153001 on gnome-nettool in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001
>
> You gave more information on the question:
> Hi actionparsnip,
> firstly Thanks for suggestion, but as you told, but when i tried your
> option
> there are no application was run.
> So this is also not solve my problem.......But thanks for your effort....
>
>
>
>
> With Regards!
> Arvind Kumar Gangwar
> OCJP 6, Preparing for SCWCD
> +918087142449
>
>
> On Sat, Apr 16, 2011 at 6:13 PM, actionparsnip <
> <email address hidden>> wrote:
>
> > Your question #153001 on gnome-nettool in Ubuntu changed:
> >
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001
> >
> > Status: Open => Needs information
> >
> > actionparsnip requested for more information:
> > If you press ALT+F2 and run:
> >
> > nm-applet
> >
> > does it run?
> >
> > --
> > To answer this request for more information, you can either reply to
> > this email or enter your reply at the following page:
> >
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001
> >
> > You received this question notification because you are a direct
> > subscriber of the question.
> >
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

Go to System -> Administration -> Network Connections
Choose the Mobile Broadband tab
Select your connection and in the options it provides, you should uncheck "connect automatically".

I recommend you follow Federico's instructions, but if they don't work, then perhaps the Network Manager is not managing your wired or mobile broadband network interface. To check if that is the case, go to System > Preferences > Network Connections, and see if any connections are listed under the Wired tab or under the Mobile Broadband tab. If none are listed, even while you are connected to the Internet through your computer's Ethernet port, then that's what's going on.

If that is the case, you can make the Network Manager manage all your network interfaces by opening a Terminal window (Ctrl+Alt+T or Applications > Accessories > Terminal) and running these three commands, which you should probably copy and paste into the Terminal in order to reduce the risk of typographic errors:

cd /etc/NetworkManager
sudo cp nm-system-settings.conf nm-system-settings.conf.backup
gksudo gedit nm-system-settings.conf

A text editor will open. In section [ifupdown] find the line managed=false and replace it with managed=true. Save and quit. Then, in the Terminal, run:

sudo service network-manager restart

That might work (i.e., give you the ability to control your Network Connection from an icon in the Notification Area) immediately. If not, please select all the text from the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it here, then reboot and see if it works. If not, the text you posted from the Terminal will provide useful information.

[This post contains ideas and text taken directly or adapted, sometimes without rephrasing, from https://wiki.ubuntu.com/Lubuntu/DocumentationHelp/MinimalInstall#Change%20Network%20Manager%20settings. I do *not* claim that this post, taken as a whole, is an original work of mine--that would be plagiarism. With that said, however, no one but me is responsible for any errors in this post.]

Hi @Eliah Kagan

Thanks to your such a great suggestion. It solve my problem and provide a
network manager in system notification area in panel.

But as i am beginner in linux, as soon i run all these command my Internet
connection got disconnect, and never connect
, so i again run the command which you send to me and think this time i i
do the previous setting so this time i did *managed=true*. to revert my old
setting (in regard this will may connect my Internet connection, i think
this because of reason...when firstly i run those command my connection
disconnect and not connect again...), which result my Ubuntu OS
crashed...got hanged in terminal...and after some time i try restart
manually from restart button...but my linux OS will not boot...it displays
me some error message.....and after two day goggling and installing again
and again...(because second time my XP boot loder not work only Ubntu os
boot...after do More R& D i get finally solution by own....
At current time I learn how to configure Internet connection ..and how to
run network manager ......and currently i am running Ubuntu OS inside
XP.....need again installing both software....(when in relif...now i get
some concept and formal with ubuntu...)
I know it useless to discuss here ...but i happy because after two day head
ache a get a sign of relief......SO Thank Thanks Thanks.....for great
help...
With Regards!
Arvind Kumar Gangwar
OCJP 6, Preparing for SCWCD
+918087142449

On Sat, Apr 16, 2011 at 4:29 PM, Eliah Kagan <
<email address hidden>> wrote:

> Your question #153001 on gnome-nettool in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001
>
> Eliah Kagan proposed the following answer:
> I recommend you follow Federico's instructions, but if they don't work,
> then perhaps the Network Manager is not managing your wired or mobile
> broadband network interface. To check if that is the case, go to System
> > Preferences > Network Connections, and see if any connections are
> listed under the Wired tab or under the Mobile Broadband tab. If none
> are listed, even while you are connected to the Internet through your
> computer's Ethernet port, then that's what's going on.
>
> If that is the case, you can make the Network Manager manage all your
> network interfaces by opening a Terminal window (Ctrl+Alt+T or
> Applications > Accessories > Terminal) and running these three commands,
> which you should probably copy and paste into the Terminal in order to
> reduce the risk of typographic errors:
>
> cd /etc/NetworkManager
> sudo cp nm-system-settings.conf nm-system-settings.conf.backup
> gksudo gedit nm-system-settings.conf
>
> A text editor will open. In section [ifupdown] find the line
> managed=false and replace it with managed=true. Save and quit. Then, in
> the Terminal, run:
>
> sudo service network-manager restart
>
> That might work (i.e., give you the ability to control your Network
> Connection from an icon in the Notification Area) immediately. If not,
> please select all the text from the Terminal (Edit > Select All), copy
> it to the clipboard (Edit > Copy), and paste it here, then reboot and
> see if it works. If not, the text you posted from the Terminal will
> provide useful information.
>
> [This post contains ideas and text taken directly or adapted, sometimes
> without rephrasing, from
>
> https://wiki.ubuntu.com/Lubuntu/DocumentationHelp/MinimalInstall#Change%20Network%20Manager%20settings
> .
> I do *not* claim that this post, taken as a whole, is an original work
> of mine--that would be plagiarism. With that said, however, no one but
> me is responsible for any errors in this post.]
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001/+confirm?answer_id=9
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/153001
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Thanks Thanks Thanks...it works....Great job...

I'm glad the problem is fixed.

You said your Internet connection stopped when followed my instructions--it will almost certainly stop for a short time, and in some cases, depending on how your cable modem is set up, might require rebooting (or another procedure which I did not detail) to restore. So that's not an indication of a problem.

You also talked about a Terminal hang. I would need a more complete description of what happened and when in order to explain this, but I will point out that the Terminal may appear hung while a command is running, and when you run "gksudo gedit ...", that command will remain running until you exit the text editor. In general, if the Terminal seems hung and there's nothing you can do about it, you can press Ctrl+C. If that doesn't work, you can "hang up" the Terminal on the command it's running by closing the Terminal window. If you're performing a system administration task and you have to do that, you might want to reboot, though often doing so is not necessary. You can reboot by selecting Restart in the shut down menu--you should avoid powering off your computer while it's running, except when doing so is absolutely necessary.

You could probably have saved some effort by asking for help rather than repeatedly reinstalling Ubuntu multiple times. But, I'm glad everything seems to be working for you now.