Casper LCD panel brightness and wireless

Asked by Taha KONUK on 2011-04-06

Hello,
I have a Casper CN-HBI720B notebook and I can't adjust my lcd panel brihgtness using fn keys. I can do it with NVIDIA gui. Secondly I couldn't active/deactive my wireless adapter using the fn+f2 key but I could do it with Network manager applet.
I was using the kernel 2.6.35 then I've installed the new one (2.6.38). Now I can't use my wireless adapter. It's just like I don't have one.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-06
Last reply:
2011-04-06

The wireless might not work because of missing firmware or missing modules. Where did you get the 2.6.38 kernel? If you built it yourself, then you did not build all the requiered bits to support your hardware.

The fn keys require kernel support and sometimes they don't work. There are some packages for specific notebook models that map those keys.

Taha KONUK (taha-konuk) said : #2

It's strange but I've changed some setting in bios then my wireless adapter started to work. I disabled the 'AC mode fan always on' and 'DC mode fan always on'. When I changed one of them as enabled it isn't working :/ I didn't compile the kernel myself I download it from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.38.2-natty/ Unfortunately my notebook isn't common so it's hard to find support on the internet.

That kernel is built for natty. The firmware comes in a separate package called linux-firmware and your version might not match the natty one. Other packages that come with natty might be required to use that kernel succesfully.

Taha KONUK (taha-konuk) said : #4

I know that. So Can I find that linux-firmware package before releasing natty?

Taha KONUK (taha-konuk) said : #5

By the way my fn keys weren't working with previous kernel. Moreover my CPU fan stopped randomly and never worked until pc were resetted. Then my USB ports stopped working. After all I tried next kernel.

Try a live session with Natty beta1. I have it installed on a netbook and it works quite well. If it works better there, then you can install it or upgrade.
All your problems seem to be driver related.

Taha KONUK (taha-konuk) said : #7

Ok I'll try. Thank you so much.

Can you help with this problem?

Provide an answer of your own, or ask Taha KONUK for more information if necessary.

To post a message you must log in.