Cannot disable wireless

Asked by Maxim Vasilyev on 2011-03-02

I have a laptop (Asus N50Vn) with Intel WiMAX/WiFi 5150 chipset intergraded, running Ubuntu 10.04. The problem is: I have to disable WiFi in order to enable WiMAX connection, but none of "standart" ways ("Fn+F2" key combination (disables only Bluetooth, not wireless); BIOS setting "Enable WLAN", Network Manager "Enable Wireless" uncheck is not functioning, typing in Terminal "ifconfig wlan0 disable (don't exactly remember, something like this)", using switch on the front panel of laptop) work. The indicator keeps glowing, despite disconnecting any wireless networks. Besides, I'd like to keep the WiFi support, because I use it frequently. WiFi and Bluetooth start every time I Boot Ubuntu. What should I do?

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2011-03-04
Last reply:
2011-03-04
Ubfan (ubfan1) said : #1

R click on the network-manager icon (pie shaped pile of arcs) in the toolbar. and select "Enable wireless" to turn off the checkmark. this will turn off the wifi, but leave bluetooth alone.

Maxim Vasilyev (mxmvasilyev0) said : #2

As I told in original post, "Enable Wireless" uncheck doesn't work.

Ubfan (ubfan1) said : #3

If you have done nothing manually to control the network (i.e. network-manager is in complete control), and the checkoff for "Enable Wireless" does not disconnect/connect you from the wireless network, you should file a bug (for your specific hardware). On my old HP laptop, disconecting wireless is independent of bluetooth.

You can run:

sudo modprobe -r modulename

replace modulename with the actual module which drives your device. You can learn this with:

sudo lshw -C network

And read.

You can re-enable it with:

sudo modprobe modulename

Maxim Vasilyev (mxmvasilyev0) said : #5

I still cannot disable wireless, indicator keeps glowing, connection to WiMAX unavailable.

Can you help with this problem?

Provide an answer of your own, or ask Maxim Vasilyev for more information if necessary.

To post a message you must log in.