WiFi not working on HP ProBook 6550b

Asked by amorfis on 2011-02-03

I just installed Ubuntu on my new HP ProBook 6550b laptop. However, to my surprise, WiFi is not working. It is shown in lspci, but looks like not working. Looks like there are no WiFi networks, but I'm sure there is at least one. My home one. It works well on Windows, detects networks and connects.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-02-03
Last query:
2011-02-03
Last reply:
2011-02-03

Can you give the output of:

uname -a; lsb_release -a; echo; sudo lshw -C network

Thanks

MANY wireless chips don't work out of the box as there are so many DIFFERENT chips which are completely unfeasible to accommodate. Some do work straight away, some require a little effort.

There is a chance it's one of those cheap Broadcom 43xx chips which are super easy to setup but the output will tell us.

amorfis (pawelstawicki) said : #2

Yes, it is Broadcom 4313. Outputs below. I bought this laptop because it is certified to work with ubuntu (http://www.ubuntu.com/certification/hardware/201101-6954). There are even no Certification Notes.

uname -a:
Linux eurybiades 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:32:27 UTC 2010 x86_64 GNU/Linux

lsb_release -a:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick

sudo lshw -C network:

  *-network
       description: Ethernet interface
       product: 82577LC Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 05
       serial: 64:31:50:7a:9b:a1
       capacity: 1GB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=1.0.2-k4 firmware=0.12-6 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:46 memory:d4500000-d451ffff memory:d452a000-d452afff ioport:5020(size=32)
  *-network UNCLAIMED
       description: Network controller
       product: BCM4313 802.11b/g LP-PHY
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:45:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:d0100000-d0103fff

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

Shows how you can use the liveCD to install the driver, it is available you just need to kick it off. The firmware in the hardware is proprietary so cannot be included in the CD but the tool to create the driver can be included.

amorfis (pawelstawicki) said : #4

Thanks actionparsnip, that solved my question.

Luis (seii) said : #5

Okay so i installed Ubuntu within windows. Everything works fine except for the OS not being able to connect to wifi. I tried to look up some stuff and installed some driver and i don't even know what else i did. I have a Compaq Presario CQ56-110US, it works when i plug in my Ethernet cable but i need the wifi working :(. Can any one help?

Luis (seii) said : #6

Sorry wrong post above @_@ ignore.