wlan0 No scan results -> Wireless Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 03) not working on Gateway 7320 laptop in Ubuntu 10.10

Asked by Jarred Hoffmeister

Gateway 7320 laptop, fresh install of Ubuntu 10.10, Wireless is Broadcom 4306/3, b43 drivers/firmware are active.

followed instructions and the following is the terminal output:

Hit http://us.archive.ubuntu.com maverick Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/main Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/main Translation-en_US
Hit http://extras.ubuntu.com maverick Release.gpg
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en
Hit http://security.ubuntu.com maverick-security Release.gpg
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en_US
Hit http://us.archive.ubuntu.com maverick-updates Release.gpg
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en_US
Hit http://extras.ubuntu.com maverick Release
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en
Hit http://security.ubuntu.com maverick-security Release
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en_US
Hit http://us.archive.ubuntu.com maverick Release
Hit http://us.archive.ubuntu.com maverick-updates Release
Hit http://extras.ubuntu.com maverick/main Sources
Hit http://security.ubuntu.com maverick-security/main Sources
Hit http://us.archive.ubuntu.com maverick/main Sources
Hit http://us.archive.ubuntu.com maverick/restricted Sources
Hit http://us.archive.ubuntu.com maverick/universe Sources
Hit http://us.archive.ubuntu.com maverick/multiverse Sources
Hit http://us.archive.ubuntu.com maverick/main i386 Packages
Hit http://extras.ubuntu.com maverick/main i386 Packages
Hit http://us.archive.ubuntu.com maverick/restricted i386 Packages
Hit http://us.archive.ubuntu.com maverick/universe i386 Packages
Hit http://security.ubuntu.com maverick-security/restricted Sources
Hit http://security.ubuntu.com maverick-security/universe Sources
Hit http://security.ubuntu.com maverick-security/multiverse Sources
Hit http://security.ubuntu.com maverick-security/main i386 Packages
Hit http://security.ubuntu.com maverick-security/restricted i386 Packages
Hit http://security.ubuntu.com maverick-security/universe i386 Packages
Hit http://security.ubuntu.com maverick-security/multiverse i386 Packages
Hit http://us.archive.ubuntu.com maverick/multiverse i386 Packages
Hit http://us.archive.ubuntu.com maverick-updates/main Sources
Hit http://us.archive.ubuntu.com maverick-updates/restricted Sources
Hit http://us.archive.ubuntu.com maverick-updates/universe Sources
Hit http://us.archive.ubuntu.com maverick-updates/multiverse Sources
Hit http://us.archive.ubuntu.com maverick-updates/main i386 Packages
Hit http://us.archive.ubuntu.com maverick-updates/restricted i386 Packages
Hit http://us.archive.ubuntu.com maverick-updates/universe i386 Packages
Hit http://us.archive.ubuntu.com maverick-updates/multiverse i386 Packages
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
The following package was automatically installed and is no longer required:
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libhal1 libhd16
The following NEW packages will be installed:
  hwinfo libhal1 libhd16
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 849kB of archives.
After this operation, 2,286kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com/ubuntu/ maverick/main libhal1 i386 0.5.14-0ubuntu6 [106kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ maverick/universe libhd16 i386 16.0-2 [698kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ maverick/universe hwinfo i386 16.0-2 [46.1kB]
Fetched 849kB in 5s (143kB/s)
Selecting previously deselected package libhal1.
(Reading database ... 133903 files and directories currently installed.)
Unpacking libhal1 (from .../libhal1_0.5.14-0ubuntu6_i386.deb) ...
Selecting previously deselected package libhd16.
Unpacking libhd16 (from .../libhd16_16.0-2_i386.deb) ...
Selecting previously deselected package hwinfo.
Unpacking hwinfo (from .../hwinfo_16.0-2_i386.deb) ...
Processing triggers for man-db ...
Setting up libhal1 (0.5.14-0ubuntu6) ...
Setting up libhd16 (16.0-2) ...
Setting up hwinfo (16.0-2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
       description: Ethernet interface
       product: BCM4401 100Base-T
       vendor: Broadcom Corporation
       physical id: 6
       bus info: pci@0000:01:06.0
       logical name: eth0
       version: 01
       serial: 00:03:25:12:b5:63
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list rom ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=full ip= latency=64 link=yes multicast=yes port=twisted pair speed=100MB/s
       resources: irq:19 memory:e00fc000-e00fdfff memory:e00c0000-e00dffff
       description: Network controller
       product: BCM4306 802.11b/g Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 9
       bus info: pci@0000:01:09.0
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master
       configuration: driver=b43-pci-bridge latency=64
       resources: irq:18 memory:e00f6000-e00f7fff
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: 00:90:4b:c4:03:a8
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=2.6.35-24-generic-pae firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 No scan results

auto lo
iface lo inet loopback

00:00.0 Host bridge [0600]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3580] (rev 02)
00:00.1 System peripheral [0880]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3584] (rev 02)
00:00.3 System peripheral [0880]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3585] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)
00:02.1 Display controller [0380]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 [8086:24c2] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 [8086:24c4] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 [8086:24c7] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller [8086:24cd] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 83)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge [8086:24cc] (rev 03)
00:1f.1 IDE interface [0101]: Intel Corporation 82801DBM (ICH4-M) IDE Controller [8086:24ca] (rev 03)
00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller [8086:24c5] (rev 03)
00:1f.6 Modem [0703]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller [8086:24c6] (rev 03)
01:04.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link) [104c:8023]
01:05.0 CardBus bridge [0607]: Texas Instruments PCI1510 PC card Cardbus Controller [104c:ac56]
01:06.0 Ethernet controller [0200]: Broadcom Corporation BCM4401 100Base-T [14e4:4401] (rev 01)
01:09.0 Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 03)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:c505 Logitech, Inc. Cordless Mouse+Keyboard Receiver
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
                               system Gateway M520
/0 bus Gateway M520
/0/0 memory 64KiB BIOS
/0/4 processor Mobile Intel(R) Pentium(R) 4 CPU 2
/0/4/5 memory 16KiB L1 cache
/0/4/6 memory 1MiB L2 cache
/0/4/0.1 processor Logical CPU
/0/4/0.2 processor Logical CPU
/0/25 memory Flash Memory
/0/26 memory Video Memory
/0/27 memory System Memory
/0/27/0 memory 512KiB FLASH Non-volatile
/0/27/0/0 memory 32MiB DDR Synchronous 200 MHz (5.0
/0/27/0/0/0 memory 512MiB DIMM DDR 333 MHz (3.0 ns)
/0/27/0/0/1 memory DIMM DDR 333 MHz (3.0 ns) [empty]
/0/1 memory
/0/2 memory
/0/100 bridge 82852/82855 GM/GME/PM/GMV Processo
/0/100/0.1 generic 82852/82855 GM/GME/PM/GMV Processo
/0/100/0.3 generic 82852/82855 GM/GME/PM/GMV Processo
/0/100/2 display 82852/855GM Integrated Graphics De
/0/100/2.1 display 82852/855GM Integrated Graphics De
/0/100/1d bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-
/0/100/1d.1 bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-
/0/100/1d.2 bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-
/0/100/1d.7 bus 82801DB/DBM (ICH4/ICH4-M) USB2 EHC
/0/100/1e bridge 82801 Mobile PCI Bridge
/0/100/1e/4 bus TSB43AB22/A IEEE-1394a-2000 Contro
/0/100/1e/5 bridge PCI1510 PC card Cardbus Controller
/0/100/1e/6 eth0 network BCM4401 100Base-T
/0/100/1e/9 network BCM4306 802.11b/g Wireless LAN Con
/0/100/1f bridge 82801DBM (ICH4-M) LPC Interface Br
/0/100/1f.1 scsi0 storage 82801DBM (ICH4-M) IDE Controller
/0/100/1f.1/0 /dev/sda disk 80GB IC25N080ATMR04-0
/0/100/1f.1/0/1 /dev/sda1 volume 71GiB EXT4 volume
/0/100/1f.1/0/2 /dev/sda2 volume 3152MiB Extended partition
/0/100/1f.1/0/2/5 /dev/sda5 volume 3152MiB Linux swap / Solaris parti
/0/100/1f.1/1 /dev/cdrom disk DVD-RW GWA-4080N
/0/100/1f.5 multimedia 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-
/0/100/1f.6 communication 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-
/1 power Li4402A
/2 wlan0 network Wireless interface
Linux Angband 2.6.35-24-generic-pae #42-Ubuntu SMP Thu Dec 2 03:21:31 UTC 2010 i686 GNU/Linux
[ 0.000000] found SMP MP-table at [c00ff780] ff780
[ 0.188829] ACPI: No dock devices found.
[ 0.199088] HEST: Table is not found!
[ 0.199957] usbcore: registered new interface driver usbfs
[ 0.200017] usbcore: registered new interface driver hub
[ 0.200078] usbcore: registered new device driver usb
[ 0.200894] Switching to clocksource tsc
[ 0.230077] pnp: PnP ACPI: found 12 devices
[ 0.295390] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
[ 0.295785] ACPI: Lid Switch [LID0]
[ 0.302406] ERST: Table is not found!
[ 0.418313] hub 1-0:1.0: USB hub found
[ 0.419099] hub 2-0:1.0: USB hub found
[ 0.419622] hub 3-0:1.0: USB hub found
[ 0.420170] hub 4-0:1.0: USB hub found
[ 0.545273] device-mapper: multipath: version 1.1.1 loaded
[ 0.545281] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 0.572349] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.689432] isapnp: No Plug & Play device found
[ 0.986988] usb 3-1: new low speed USB device using uhci_hcd and address 2
[ 1.094992] b43-pci-bridge 0000:01:09.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 1.095057] ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x04, vendor 0x4243)
[ 1.095068] ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x05, vendor 0x4243)
[ 1.095078] ssb: Core 2 found: PCMCIA (cc 0x80D, rev 0x02, vendor 0x4243)
[ 1.095087] ssb: Core 3 found: V90 (cc 0x807, rev 0x02, vendor 0x4243)
[ 1.095096] ssb: Core 4 found: PCI (cc 0x804, rev 0x09, vendor 0x4243)
[ 1.098479] ssb: Sonics Silicon Backplane found on PCI device 0000:01:09.0
[ 1.122987] ssb: Core 0 found: Fast Ethernet (cc 0x806, rev 0x04, vendor 0x4243)
[ 1.122996] ssb: Core 1 found: V90 (cc 0x807, rev 0x01, vendor 0x4243)
[ 1.123003] ssb: Core 2 found: PCI (cc 0x804, rev 0x02, vendor 0x4243)
[ 1.165117] ssb: Sonics Silicon Backplane found on PCI device 0000:01:06.0
[ 1.185509] b44 ssb1:0: eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:03:25:12:b5:63
[ 1.198950] usbcore: registered new interface driver hiddev
[ 1.213620] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/input/input5
[ 1.213937] generic-usb 0003:046D:C505.0001: input,hidraw0: USB HID v1.10 Keyboard [Logitech USB Receiver] on usb-0000:00:1d.1-1/input0
[ 1.247958] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.1/input/input6
[ 1.248226] generic-usb 0003:046D:C505.0002: input,hidraw1: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.1-1/input1
[ 1.248269] usbcore: registered new interface driver usbhid
[ 1.248274] usbhid: USB HID core driver
[ 12.198239] lp: driver loaded but no devices found
[ 12.216176] yenta_cardbus 0000:01:05.0: CardBus bridge found [161f:202f]
[ 13.408510] Console: switching to colour frame buffer device 160x50
[ 14.445923] b43-phy0: Broadcom 4306 WLAN found (core revision 5)
[ 15.879212] Registered led device: b43-phy0::tx
[ 15.879263] Registered led device: b43-phy0::rx
[ 15.879309] Registered led device: b43-phy0::radio
[ 15.879475] Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]
[ 22.260768] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 23.537031] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
[ 23.629356] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 25.816168] b44 ssb1:0: eth0: Link is up at 100 Mbps, full duplex
[ 25.816174] b44 ssb1:0: eth0: Flow control is off for TX and off for RX
[ 25.816265] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 36.128018] eth0: no IPv6 routers present
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off

# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist uart6850
blacklist twl4030_wdt
options iwlagn 11n_disable=1
> hal.1: read hal dataprocess 1776: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
24: PCI 106.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.IhC9eApWEv2
  Parent ID: 6NW+.1yBhv2xnpj4
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:01:06.0
  SysFS BusID: 0000:01:06.0
  Hardware Class: network
  Model: "Broadcom BCM4401 100Base-T"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4401 "BCM4401 100Base-T"
  SubVendor: pci 0x161f "Rioworks"
  SubDevice: pci 0x2029
  Revision: 0x01
  Driver: "b44"
  Driver Modules: "ssb", "b44"
  Device File: eth0
  Memory Range: 0xe00fc000-0xe00fdfff (rw,non-prefetchable)
  Memory Range: 0xe00c0000-0xe00dffff (ro,non-prefetchable,disabled)
  IRQ: 19 (14685 events)
  HW Address: 00:03:25:12:b5:63
  Link detected: yes
  Module Alias: "pci:v000014E4d00004401sv0000161Fsd00002029bc02sc00i00"
  Driver Info #0:
    Driver Status: b44 is active
    Driver Activation Cmd: "modprobe b44"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #17 (PCI bridge)

25: PCI 109.0: 0282 WLAN controller
  [Created at pci.318]
  Unique ID: y9sn.onk47P9RYb5
  Parent ID: 6NW+.1yBhv2xnpj4
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:01:09.0
  SysFS BusID: 0000:01:09.0
  Hardware Class: network
  Model: "Broadcom BCM4306 802.11b/g Wireless LAN Controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4320 "BCM4306 802.11b/g Wireless LAN Controller"
  SubVendor: pci 0x14e4 "Broadcom"
  SubDevice: pci 0x0418
  Revision: 0x03
  Driver: "b43-pci-bridge"
  Driver Modules: "ssb"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0xe00f6000-0xe00f7fff (rw,non-prefetchable)
  IRQ: 18 (504 events)
  HW Address: 00:90:4b:c4:03:a8
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d00004320sv000014E4sd00000418bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is active
    Driver Activation Cmd: "modprobe ssb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #17 (PCI bridge)

Module Size Used by
binfmt_misc 6599 1
parport_pc 26378 0
ppdev 5556 0
arc4 1165 2
snd_intel8x0 25632 2
b43 169225 0
snd_ac97_codec 99227 1 snd_intel8x0
ac97_bus 1014 1 snd_ac97_codec
snd_pcm 71603 2 snd_intel8x0,snd_ac97_codec
mac80211 231541 1 b43
snd_seq_midi 4588 0
snd_rawmidi 17783 1 snd_seq_midi
snd_seq_midi_event 6047 1 snd_seq_midi
snd_seq 47174 2 snd_seq_midi,snd_seq_midi_event
cfg80211 144470 2 b43,mac80211
snd_timer 19067 2 snd_pcm,snd_seq
pcmcia 36037 0
snd_seq_device 5744 3 snd_seq_midi,snd_rawmidi,snd_seq
led_class 2633 1 b43
i915 295693 3
drm_kms_helper 30200 1 i915
yenta_socket 21710 0
lp 7342 0
drm 168764 2 i915,drm_kms_helper
pcmcia_rsrc 11142 1 yenta_socket
joydev 8767 0
i2c_algo_bit 5168 1 i915
pcmcia_core 14657 3 pcmcia,yenta_socket,pcmcia_rsrc
intel_agp 27022 2 i915
video 18712 1 i915
agpgart 32075 2 drm,intel_agp
snd 49038 11 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
psmouse 59033 0
parport 31492 3 parport_pc,ppdev,lp
shpchp 29982 0
soundcore 880 1 snd
snd_page_alloc 7216 2 snd_intel8x0,snd_pcm
serio_raw 4022 0
output 1883 1 video
usbhid 36978 0
hid 67742 1 usbhid
b44 27245 0
firewire_ohci 21330 0
ssb 39320 2 b43,b44
firewire_core 46675 1 firewire_ohci
mii 4425 1 b44
crc_itu_t 1383 1 firewire_core

I had gotten it working previously, but then it quit for some reason, so I tried a fresh install, but no joy.

No networks show up, and even when I enter the information manually, still will not connnect.

Question information

English Edit question
Ubuntu gnome-nettool Edit question
No assignee Edit question
Solved by:
Jarred Hoffmeister
Last query:
Last reply:
Revision history for this message
Stanz (stanz) said :

Followed whose or what instructions?
Is the problem at home/work/school?
Are you sure the kill switch is off?

Will "Wifi Rader" {in the repo's} show your network/router?

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

I think that the following Terminal output is showing the issue that your wireless adapter is having:

ssb 39320 2 b43,b44

So the ssb driver is being used by both the b43 (wireless) and the b44 (wired) drivers.

I think the b43 driver will not work if the b44 driver gets loaded by the kernel BEFORE the b43 driver.

So open a Terminal and run the following 2 commands as a workaround procedure:

sudo modprobe -r b43 b44 ssb wl

sudo modprobe b43

Then retest wireless WITHOUT rebooting.

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

And you should also try installing and booting the 2.6.35-24-generic kernel INSTEAD of the 2.6.35-24-generic-pae kernel. Wireless may work better using the 2.6.35-24-generic kernel....

Revision history for this message
Jarred Hoffmeister (preciousroi) said :

no joy on first suggestion, how would I go about implementing the second?

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

Open a Terminal and enter the following command:

sudo apt-get update; sudo apt-get install linux-image-2.6.35-24-generic

Then reboot and choose linux-image-2.6.35-24-generic in the grub boot menu.

Revision history for this message
Jarred Hoffmeister (preciousroi) said :

I never got a boot menu, or was there a key I was supposed to hit while rebooting?

Revision history for this message
Jarred Hoffmeister (preciousroi) said :

I think I managed to install the generic kernel through Synaptic and uninstalling the pae one, but still no joy

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

Please try the solution from forumuser billfinch at this location:


Revision history for this message
Jarred Hoffmeister (preciousroi) said :

used solution from: http://www.uluga.ubuntuforums.org/showthread.php?t=885173&page=4 post #35

also changed setting in BIOS from "Restore" to "On"

Revision history for this message
Jarred Hoffmeister (preciousroi) said :

sorry about the spam, I have indeed changed my hotmail password and haven't had any further occurneces