installation??

Asked by gani on 2007-09-17

hai friends..any body help me... i just started to learn linux....so i have installed ubuntu.....i know that $sudo apt-get whatever will install that stuff....but i download the pakages and use this commend but some errors as follows will come....plz help me.suppose take the case of valknut

gani@gani-desktop:~$ sudo apt-get install valknut-0.3.10
Password:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package valknut-0.3.10

i copied valknut into /var/cache/apt/archives/
and excuted the above command

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Last query:
2007-09-18
Last reply:
2007-09-18

ok, apt-get install works only with Ubuntu package, thats a program to compile, thats more dificult, but don't worry, just type the right thing on your apt-get

$ sudo apt-get install valknut

thats all you have to do.

Otherwhise, if you want to install your file, please tell me the complete name... it TAR.GZ.. TGZ... what??

gani (ganigaadu) said : #2

i tried it many times......i get the same error...thatthe pakage called valknut 0.3.10 cannot be found........

gani (ganigaadu) said : #3

ya its valknut-0.3.10.tar.bz2

Wrwrwr (wrwrwr) said : #4

You can install valknut 0.3.7 through synaptic. It's in the universe so make sure you have it enabled (Settings-->Repositories).

Dpkg & apt-get work only with prepared packages (e.g. ".deb" extension).

If really you want a newer version you'll need to compile from sources; this might get complex. Basically, uncompress this tar.bz2, navigate to this directory in terminal and type "./configure" followed by "make". You can find more precise instructions in the INSTALL file there.

Can you help with this problem?

Provide an answer of your own, or ask gani for more information if necessary.

To post a message you must log in.